aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/buglabs-apps/com.buglabs.app.simpleguicloser.bb
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@buglabs.net>2010-12-02 16:00:50 +0100
committerStefan Schmidt <stefan@buglabs.net>2011-02-03 11:39:20 +0100
commita32e9b20267f506bbbab64cf2d8a45b374df6081 (patch)
tree0be3564e97f98d34dfb9b412ecc6f27a49fb08d5 /recipes/buglabs-apps/com.buglabs.app.simpleguicloser.bb
parent0a509aeb50214b93eff979f6080bced5efe5ca04 (diff)
downloadopenembedded-a32e9b20267f506bbbab64cf2d8a45b374df6081.tar.gz
buglabs-apps: BugLabs java applications.
Tons of small apps that live on buglabs.net and are mostly arch independent. These recipes make them available for images and feeds.
Diffstat (limited to 'recipes/buglabs-apps/com.buglabs.app.simpleguicloser.bb')
-rw-r--r--recipes/buglabs-apps/com.buglabs.app.simpleguicloser.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/buglabs-apps/com.buglabs.app.simpleguicloser.bb b/recipes/buglabs-apps/com.buglabs.app.simpleguicloser.bb
new file mode 100644
index 0000000000..0f6ba80e56
--- /dev/null
+++ b/recipes/buglabs-apps/com.buglabs.app.simpleguicloser.bb
@@ -0,0 +1,31 @@
+require bug-app.inc
+
+DESCRIPTION = "Simple application (a la SimpleGUI from kschultz) demonstrating how to close a Frame by overriding the relevant methods in java.awt.event.WindowAdapter\
+What it does:\
+Constructs and shows a frame at half the screen resolution height and width. \
+Constructs a simple static label\
+Constructs a canvas, which responds to MouseEvents by changing the background color (white for out, green for in) and prints to console information regarding the MouseEvent\
+Registers an anonymous inner WindowAdapter to listen to the Frame for window events, disposing of the Frame (and printing to console) when the frame has been closed.\
+\
+\
+What it shows:\
+Use anonymous inner classing for speedy coding and convenient handling of events (MouseEvent, MouseAdapter).\
+Use of anonymous inner WindowAdapter (abstract class) to handle WindowEvents\
+\
+For more information about AWT, WindowEvents, WindowAdapter, etc, please see here for brief overview:\
+http://www.exampledepot.com/egs/java.awt/pkg.html\
+For more information about use of Anonymous Inner Classing, see a short lecture at Stanford:\
+\
+\
+Please feel free to email me at jconnolly [at] buglabs.net for information. Or check out BUGLabs on IRC:\
+irc://irc.freenode.net/buglabs\
+"
+HOMEPAGE = "http://buglabs.net/applications/SimpleGUICloser"
+
+DEPENDS += "com.buglabs.osgi com.buglabs.common service-tracker com.buglabs.bug.module.lcd "
+
+PV = "4"
+
+SRC_LINK = "http://buglabs.net/program_version/download/337"
+
+APIVERSION = ""