aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/asterisk/asterisk-addons_1.6.0-beta2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/asterisk/asterisk-addons_1.6.0-beta2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/asterisk/asterisk-addons_1.6.0-beta2.bb')
-rw-r--r--recipes/asterisk/asterisk-addons_1.6.0-beta2.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/recipes/asterisk/asterisk-addons_1.6.0-beta2.bb b/recipes/asterisk/asterisk-addons_1.6.0-beta2.bb
new file mode 100644
index 0000000000..06d2dc2dc0
--- /dev/null
+++ b/recipes/asterisk/asterisk-addons_1.6.0-beta2.bb
@@ -0,0 +1,63 @@
+# Copyright (c) 2008, Ovidiu Sas - VoIP Embedded Inc., All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+DESCRIPTION = "The Asterisk open source software PBX"
+HOMEPAGE = "http://www.asterisk.org"
+SECTION = "voip"
+LICENSE = "GPLv2"
+PRIORITY = "optional"
+SECTION = "console/telephony"
+DEPENDS = "asterisk openssl curl"
+PR = "r1"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI="http://downloads.digium.com/pub/asterisk/asterisk-addons-${PV}.tar.gz"
+
+ARCH_efika="ppc"
+ARCH_dht-walnut="ppc"
+ARCH_magicbox="ppc"
+ARCH_sequoia="ppc"
+
+
+inherit autotools
+
+EXTRA_OECONF = "--with-ssl=${STAGING_EXECPREFIXDIR}\
+ --with-termcap=${STAGING_EXECPREFIXDIR}\
+ --with-curl=${STAGING_EXECPREFIXDIR}\
+ --without-curses\
+ --with-ncurses=${STAGING_EXECPREFIXDIR}\
+ --without-mysqlclient\
+ --with-h323\
+ "
+
+#export NOISY_BUILD=yes
+
+export ASTCFLAGS = "-fsigned-char -I${STAGING_INCDIR} -DPATH_MAX=4096"
+export ASTLDFLAGS="${LDFLAGS} -lpthread -ldl -lresolv "
+export PROC="${ARCH}"
+
+do_configure () {
+ # Looks like rebuilding configure doesn't work, so we are skipping
+ # that and are just using the shipped one
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+do_compile() {
+ (
+ #make sure that menuselect gets build using host toolchain
+ unset CC LD CXX CCLD CFLAGS CPPFLAGS LDFLAGS CXXFLAGS
+ cd menuselect
+ ./configure
+ oe_runmake
+ cd ../
+ ) || exit 1
+ oe_runmake
+}
+
+CONFFILES_${PN} += "${sysconfdir}/asterisk/mobile.conf"
+CONFFILES_${PN} += "${sysconfdir}/asterisk/res_mysql.conf"
+CONFFILES_${PN} += "${sysconfdir}/asterisk/ooh323.conf"
+CONFFILES_${PN} += "${sysconfdir}/asterisk/cdr_mysql.conf"
+