aboutsummaryrefslogtreecommitdiffstats
path: root/packages/opie-taskbar
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-03-30 15:39:06 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-03-30 15:39:06 +0000
commita31229ef8c96e6ad6dbe5c7b9c78639354b73ec0 (patch)
tree4d4816c16232e3f25ede5a54cedd24350b7b6114 /packages/opie-taskbar
parent72841378a42ae082ec6790f3debb66433fc495bc (diff)
downloadopenembedded-a31229ef8c96e6ad6dbe5c7b9c78639354b73ec0.tar.gz
opie-taskbar: Split startup and general configuration files into own package, opie-init.
Diffstat (limited to 'packages/opie-taskbar')
-rw-r--r--packages/opie-taskbar/opie-taskbar.inc35
-rw-r--r--packages/opie-taskbar/opie-taskbar/akita/.mtn2git_empty0
-rw-r--r--packages/opie-taskbar/opie-taskbar/akita/qpe.conf22
-rw-r--r--packages/opie-taskbar/opie-taskbar/c7x0/.mtn2git_empty0
-rwxr-xr-xpackages/opie-taskbar/opie-taskbar/c7x0/opie85
-rw-r--r--packages/opie-taskbar/opie-taskbar/c7x0/qpe-suspend-resume33
-rw-r--r--packages/opie-taskbar/opie-taskbar/c7x0/qpe.conf22
-rw-r--r--packages/opie-taskbar/opie-taskbar/htcuniversal/.mtn2git_empty0
-rw-r--r--packages/opie-taskbar/opie-taskbar/htcuniversal/qpe.conf22
-rw-r--r--packages/opie-taskbar/opie-taskbar/locale.conf0
-rw-r--r--packages/opie-taskbar/opie-taskbar/mnci/.mtn2git_empty0
-rwxr-xr-xpackages/opie-taskbar/opie-taskbar/mnci/opie79
-rw-r--r--packages/opie-taskbar/opie-taskbar/mnci/qpe.conf25
-rwxr-xr-xpackages/opie-taskbar/opie-taskbar/opie90
-rwxr-xr-xpackages/opie-taskbar/opie-taskbar/opie-reorgfiles93
-rw-r--r--packages/opie-taskbar/opie-taskbar/opie_defaults15
-rw-r--r--packages/opie-taskbar/opie-taskbar/qpe.conf18
-rw-r--r--packages/opie-taskbar/opie-taskbar/simpad/.mtn2git_empty0
-rw-r--r--packages/opie-taskbar/opie-taskbar/simpad/qpe.conf18
-rw-r--r--packages/opie-taskbar/opie-taskbar/spitz/.mtn2git_empty0
-rw-r--r--packages/opie-taskbar/opie-taskbar/spitz/qpe.conf22
-rw-r--r--packages/opie-taskbar/opie-taskbar/tosa/.mtn2git_empty0
-rw-r--r--packages/opie-taskbar/opie-taskbar/tosa/qpe.conf22
-rw-r--r--packages/opie-taskbar/opie-taskbar_1.2.2.bb10
-rw-r--r--packages/opie-taskbar/opie-taskbar_cvs.bb10
25 files changed, 6 insertions, 615 deletions
diff --git a/packages/opie-taskbar/opie-taskbar.inc b/packages/opie-taskbar/opie-taskbar.inc
index 4c357f54b6..8dae3b2484 100644
--- a/packages/opie-taskbar/opie-taskbar.inc
+++ b/packages/opie-taskbar/opie-taskbar.inc
@@ -27,10 +27,7 @@ PIXMAP_SIZE_asus730 = "-480x640"
PIXMAP_SIZE_htcuniversal= "-480x640"
PIXMAP_SIZE_hx4700 = "-480x640"
-inherit opie update-rc.d
-
-INITSCRIPT_NAME = "opie"
-INITSCRIPT_PARAMS = "start 99 5 . stop 20 0 1 6 ."
+inherit opie
do_configure_prepend() {
ln -s ${WORKDIR}/calibrate ${S}/calibrate
@@ -56,16 +53,13 @@ do_install() {
install -d ${D}${palmtopdir}/pics/launcher
install -d ${D}${palmtopdir}/pics/logo
install -d ${D}${palmtopdir}/pics/RoH/star/
- install -d ${D}${sysconfdir}/init.d
- install -d ${D}${sysconfdir}/profile.d
install -d ${D}${palmtopdir}/etc/colors
install -d ${D}${palmtopdir}/etc/skel
+ install -d ${D}${sysconfdir}
install -m 0755 ${S}/qpe ${D}${palmtopdir}/bin/qpe
- install -m 0755 ${WORKDIR}/opie-reorgfiles ${D}${palmtopdir}/bin/
install -m 0644 ${WORKDIR}/apps/Settings/calibrate.desktop ${D}${palmtopdir}/apps/Settings/
install -m 0644 ${WORKDIR}/apps/Settings/quit.desktop ${D}${palmtopdir}/apps/Settings/
- install -m 0644 ${WORKDIR}/opie_defaults ${D}${sysconfdir}/profile.d/
for p in ${PICS}
do
@@ -80,33 +74,8 @@ do_install() {
install -m 0644 ${WORKDIR}/etc/colors/*.scheme ${D}${palmtopdir}/etc/colors/
install -m 0644 ${WORKDIR}/etc/mime.types ${D}${sysconfdir}/
- install -m 0755 ${WORKDIR}/opie ${D}${sysconfdir}/init.d/opie
- install -m 0644 ${WORKDIR}/qpe.conf ${D}${palmtopdir}/etc/skel/
-
- if [ -s ${WORKDIR}/locale.conf ]; then
- install -m 0644 ${WORKDIR}/locale.conf ${D}${palmtopdir}/etc/skel/
- fi
-
install -m 0644 ${WORKDIR}/pics/capslock.xpm ${D}${palmtopdir}/pics/
install -m 0644 ${WORKDIR}/pics/numlock.xpm ${D}${palmtopdir}/pics/
-
- case ${MACHINE} in
- c7x0)
- install -d ${D}${sysconfdir}/apm/event.d/
- install -m 0755 ${WORKDIR}/qpe-suspend-resume ${D}${sysconfdir}/apm/event.d/00-qpe-suspend-resume.sh
- ;;
- *)
- ;;
- esac
-}
-
-updatercd_postinst_mnci() {
-if test "x$D" != "x"; then
- D="-r $D"
-else
- D="" # do not autostart at installation time
-fi
-update-rc.d $D ${INITSCRIPT_NAME} ${INITSCRIPT_PARAMS}
}
FILES_opie-taskbar_append = " ${sysconfdir} ${palmtopdir}/apps ${palmtopdir}/pics"
diff --git a/packages/opie-taskbar/opie-taskbar/akita/.mtn2git_empty b/packages/opie-taskbar/opie-taskbar/akita/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/opie-taskbar/opie-taskbar/akita/.mtn2git_empty
+++ /dev/null
diff --git a/packages/opie-taskbar/opie-taskbar/akita/qpe.conf b/packages/opie-taskbar/opie-taskbar/akita/qpe.conf
deleted file mode 100644
index e9922e4d86..0000000000
--- a/packages/opie-taskbar/opie-taskbar/akita/qpe.conf
+++ /dev/null
@@ -1,22 +0,0 @@
-[Appearance]
-useBigPixmaps = 1
-SmallIconSize = 32
-BigIconSize = 48
-FontFamily = DejaVu_Sans
-FontStyle = Regular
-FontSize = 16
-FixedFontFamily = DejaVu_Sans_Mono
-FixedFontStyle = Regular
-FixedFontSize = 14
-Background = #d5d0de
-Base = #ffffff
-Button = #e3e3e3
-ButtonText = #000000
-Decoration = libliquid.so
-Highlight = #52719c
-HighlightedText = #ffffff
-Style = Windows
-Text = #000000
-TabStyle = 1
-[InputMethod]
-current = Multikey
diff --git a/packages/opie-taskbar/opie-taskbar/c7x0/.mtn2git_empty b/packages/opie-taskbar/opie-taskbar/c7x0/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/opie-taskbar/opie-taskbar/c7x0/.mtn2git_empty
+++ /dev/null
diff --git a/packages/opie-taskbar/opie-taskbar/c7x0/opie b/packages/opie-taskbar/opie-taskbar/c7x0/opie
deleted file mode 100755
index 84f3b3e673..0000000000
--- a/packages/opie-taskbar/opie-taskbar/c7x0/opie
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/sh
-#
-[ -z $LOGNAME ] && export LOGNAME=root && export HOME=/home/root
-[ -z $HOME ] && export HOME=/home/$LOGNAME
-
-# we need to tinker directly with qws_display until the ODevice
-# default (which is now W100:Rot0:0) works flawlessly with rotation
-# and survives a suspend/resume cycle
-export QWS_DISPLAY=Transformed:Rot0:0
-# export QWS_DISPLAY=W100:Rot0:0
-export QTDIR=/opt/QtPalmtop
-export OPIEDIR=/opt/QtPalmtop
-export QPEDIR=/opt/QtPalmtop
-export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$OPIEDIR/lib
-export PATH=$PATH:$OPIEDIR/bin
-
-if [ ! -x "$OPIEDIR/bin/qpe" ] ; then
- echo Opie not installed
- exit 0
-fi
-
-. /etc/profile
-
-for conf in $OPIEDIR/etc/skel/*.conf; do
- conf_basename=`basename $conf`
- if [ ! -e "$HOME/Settings/$conf_basename" ] ; then
- echo "Copying default $conf_basename into $HOME/Settings/"
- mkdir -p $HOME/Settings/
- cat $conf >$HOME/Settings/$conf_basename
- fi
-done
-
-if [ ! -e "$HOME/systeminfo/linkver" ] ; then
- mkdir -p $HOME/systeminfo/
- echo "1.13" >$HOME/systeminfo/linkver
-fi
-
-if [ ! -e "/opt/Qtopia" ] ; then
- ln -sf /opt/QtPalmtop /opt/Qtopia
-fi
-
-case $1 in
-'start')
- #/sbin/getkey 5 "Starting Opie in 5 seconds... press key to interrupt." && exit 0
-
- if [ -x "$OPIEDIR/bin/opie-login" ]; then
- echo Starting Opie-login....
- $OPIEDIR/bin/opie-login -terminal 2
- else
- $OPIEDIR/bin/opie-reorgfiles
- if [ -x /usr/bin/ssh-agent ]; then
- SSHAGENT=/usr/bin/ssh-agent
- else
- SSHAGENT=""
- fi
-
- if [ -x "$OPIEDIR/bin/opie-sh-ssh-askpass.sh" ]; then
- export SSH_ASKPASS=$OPIEDIR/bin/opie-sh-ssh-askpass.sh
- fi
- echo Starting Opie....
- $SSHAGENT $OPIEDIR/bin/qpe -terminal 2
- fi
-
- ;;
-
-'stop')
- echo "Stopping Opie..."
- killall qpe 2>/dev/null
- killall opie-login 2>/dev/null
- killall quicklauncher 2>/dev/null
-
- ;;
-
-'restart')
- $0 stop && $0 start
-
- ;;
-
-*)
- echo "usage: $0 { start | stop | restart }"
-
- ;;
-
-esac
-
diff --git a/packages/opie-taskbar/opie-taskbar/c7x0/qpe-suspend-resume b/packages/opie-taskbar/opie-taskbar/c7x0/qpe-suspend-resume
deleted file mode 100644
index be37519512..0000000000
--- a/packages/opie-taskbar/opie-taskbar/c7x0/qpe-suspend-resume
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/sh
-
-QTDIR=/opt/QtPalmtop
-LD_LIBRARY_PATH=$QTDIR
-export LD_LIBRARY_PATH QTDIR
-LOGGING=0
-log() {
- if [ $LOGGING -eq 1 ]; then
- echo "$(date +%y/%m/%d-%H:%m:%S): $@" >> /var/log/qte.log
- fi
-}
-
-retcode=1
-tries=3
-
-if [ "$1" = suspend ]; then
- while [ $retcode -ne 0 -a $tries -gt 0 ]; do
- log "-> $QTDIR/bin/qcop QPE/System 'aboutToSuspend()'"
- $QTDIR/bin/qcop QPE/System 'aboutToSuspend()'
- retcode=$?
- tries=`expr $tries - 1`
- log "<- Result $retcode"
- done
-elif [ "$1" = resume ]; then
- while [ $retcode -ne 0 -a $tries -gt 0 ]; do
- log "-> $QTDIR/bin/qcop QPE/System 'returnFromSuspend()'"
- $QTDIR/bin/qcop QPE/System 'returnFromSuspend()'
- retcode=$?
- tries=`expr $tries - 1`
- log "<- Result $retcode"
- done
-fi
-
diff --git a/packages/opie-taskbar/opie-taskbar/c7x0/qpe.conf b/packages/opie-taskbar/opie-taskbar/c7x0/qpe.conf
deleted file mode 100644
index e9922e4d86..0000000000
--- a/packages/opie-taskbar/opie-taskbar/c7x0/qpe.conf
+++ /dev/null
@@ -1,22 +0,0 @@
-[Appearance]
-useBigPixmaps = 1
-SmallIconSize = 32
-BigIconSize = 48
-FontFamily = DejaVu_Sans
-FontStyle = Regular
-FontSize = 16
-FixedFontFamily = DejaVu_Sans_Mono
-FixedFontStyle = Regular
-FixedFontSize = 14
-Background = #d5d0de
-Base = #ffffff
-Button = #e3e3e3
-ButtonText = #000000
-Decoration = libliquid.so
-Highlight = #52719c
-HighlightedText = #ffffff
-Style = Windows
-Text = #000000
-TabStyle = 1
-[InputMethod]
-current = Multikey
diff --git a/packages/opie-taskbar/opie-taskbar/htcuniversal/.mtn2git_empty b/packages/opie-taskbar/opie-taskbar/htcuniversal/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/opie-taskbar/opie-taskbar/htcuniversal/.mtn2git_empty
+++ /dev/null
diff --git a/packages/opie-taskbar/opie-taskbar/htcuniversal/qpe.conf b/packages/opie-taskbar/opie-taskbar/htcuniversal/qpe.conf
deleted file mode 100644
index e9922e4d86..0000000000
--- a/packages/opie-taskbar/opie-taskbar/htcuniversal/qpe.conf
+++ /dev/null
@@ -1,22 +0,0 @@
-[Appearance]
-useBigPixmaps = 1
-SmallIconSize = 32
-BigIconSize = 48
-FontFamily = DejaVu_Sans
-FontStyle = Regular
-FontSize = 16
-FixedFontFamily = DejaVu_Sans_Mono
-FixedFontStyle = Regular
-FixedFontSize = 14
-Background = #d5d0de
-Base = #ffffff
-Button = #e3e3e3
-ButtonText = #000000
-Decoration = libliquid.so
-Highlight = #52719c
-HighlightedText = #ffffff
-Style = Windows
-Text = #000000
-TabStyle = 1
-[InputMethod]
-current = Multikey
diff --git a/packages/opie-taskbar/opie-taskbar/locale.conf b/packages/opie-taskbar/opie-taskbar/locale.conf
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/opie-taskbar/opie-taskbar/locale.conf
+++ /dev/null
diff --git a/packages/opie-taskbar/opie-taskbar/mnci/.mtn2git_empty b/packages/opie-taskbar/opie-taskbar/mnci/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/opie-taskbar/opie-taskbar/mnci/.mtn2git_empty
+++ /dev/null
diff --git a/packages/opie-taskbar/opie-taskbar/mnci/opie b/packages/opie-taskbar/opie-taskbar/mnci/opie
deleted file mode 100755
index d5e2955b10..0000000000
--- a/packages/opie-taskbar/opie-taskbar/mnci/opie
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/bin/sh
-#
-[ -z $LOGNAME ] && export LOGNAME=root && export HOME=/home/root
-[ -z $HOME ] && export HOME=/home/$LOGNAME
-
-export QTDIR=/opt/QtPalmtop
-export OPIEDIR=/opt/QtPalmtop
-export QPEDIR=/opt/QtPalmtop
-export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$OPIEDIR/lib
-export PATH=$PATH:$OPIEDIR/bin
-# export QWS_KEYBOARD=KernelTTY
-
-if [ ! -x "$OPIEDIR/bin/qpe" ] ; then
- echo Opie not installed
- exit 0
-fi
-
-. /etc/profile
-
-if [ ! -e "$HOME/Settings/qpe.conf" ] ; then
- mkdir -p $HOME/Settings
- cp $OPIEDIR/etc/skel/* $HOME/Settings
-fi
-
-if [ ! -e "$HOME/systeminfo/linkver" ] ; then
- mkdir -p $HOME/systeminfo/
- echo "1.13" >$HOME/systeminfo/linkver
-fi
-
-if [ ! -e "/opt/Qtopia" ] ; then
- ln -sf /opt/QtPalmtop /opt/Qtopia
-fi
-
-case $1 in
-'start')
- if [ -x "$OPIEDIR/bin/opie-login" ]; then
- echo Starting Opie-login....
- $OPIEDIR/bin/opie-login -terminal 2
- else
- $OPIEDIR/bin/opie-reorgfiles >/dev/null
- if [ -x /usr/bin/ssh-agent ]; then
- SSHAGENT=/usr/bin/ssh-agent
- else
- SSHAGENT=""
- fi
-
- if [ -x "$OPIEDIR/bin/opie-sh-ssh-askpass.sh" ]; then
- export SSH_ASKPASS=$OPIEDIR/bin/opie-sh-ssh-askpass.sh
- fi
- echo Starting Opie....
- $SSHAGENT $OPIEDIR/bin/qpe -terminal 2 2>/dev/null
- fi
-
- ;;
-
-'stop')
- echo "Stopping Opie..."
- killall qpe 2>/dev/null
- killall opie-login 2>/dev/null
- killall quicklauncher 2>/dev/null
- sleep 1
- killall -9 qpe 2>/dev/null
- killall -9 opie-login 2>/dev/null
- killall -9 quicklauncher 2>/dev/null
-
- ;;
-
-'restart')
- $0 stop && $0 start
-
- ;;
-
-*)
- echo "usage: $0 { start | stop | restart }"
-
- ;;
-
-esac
-
diff --git a/packages/opie-taskbar/opie-taskbar/mnci/qpe.conf b/packages/opie-taskbar/opie-taskbar/mnci/qpe.conf
deleted file mode 100644
index 8efe771ad0..0000000000
--- a/packages/opie-taskbar/opie-taskbar/mnci/qpe.conf
+++ /dev/null
@@ -1,25 +0,0 @@
-[Appearance]
-Decoration = libflat.so
-FontFamily = vera
-FontSize = 10
-FontStyle = Regular
-LeftHand = 0
-Style = libflatstyle.so
-rotatedir = 0
-[Battery]
-[Date]
-ClockApplet = 0
-LongOrder = 273
-Separator = .
-ShortOrder = 273
-[InputMethod]
-current = Multikey
-[Keyboard]
-[Startup]
-FirstUse = 0
-[Time]
-AMPM = 0
-MONDAY = 1
-[Volume]
-[Wireless]
-UpdateFrequency = 2
diff --git a/packages/opie-taskbar/opie-taskbar/opie b/packages/opie-taskbar/opie-taskbar/opie
deleted file mode 100755
index 3fe4d0cdf8..0000000000
--- a/packages/opie-taskbar/opie-taskbar/opie
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/sh
-#
-[ -z $LOGNAME ] && export LOGNAME=root && export HOME=/home/root
-[ -z $HOME ] && export HOME=/home/$LOGNAME
-
-export QTDIR=/opt/QtPalmtop
-export OPIEDIR=/opt/QtPalmtop
-export QPEDIR=/opt/QtPalmtop
-export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$OPIEDIR/lib
-export PATH=$PATH:$OPIEDIR/bin
-
-if [ ! -x "$OPIEDIR/bin/qpe" ] ; then
- echo Opie not installed
- exit 0
-fi
-
-. /etc/profile
-
-if [ ! -e $TSLIB_TSDEVICE ]; then
- export QWS_MOUSE_PROTO=MouseMan:/dev/input/mice
-fi
-
-for conf in $OPIEDIR/etc/skel/*.conf; do
- conf_basename=`basename $conf`
- if [ ! -e "$HOME/Settings/$conf_basename" ] ; then
- echo "Copying default $conf_basename into $HOME/Settings/"
- mkdir -p $HOME/Settings/
- cat $conf >$HOME/Settings/$conf_basename
- fi
-done
-
-if [ ! -e "$HOME/systeminfo/linkver" ] ; then
- mkdir -p $HOME/systeminfo/
- echo "1.13" >$HOME/systeminfo/linkver
-fi
-
-if [ ! -e "/opt/Qtopia" ] ; then
- ln -sf /opt/QtPalmtop /opt/Qtopia
-fi
-
-case $1 in
-'start')
- #/sbin/getkey 5 "Starting Opie in 5 seconds... press key to interrupt." && exit 0
-
- # Turn off psplash if any - sleep is required for anti-race
- if [ -e /mnt/.psplash ]; then
- TMPDIR=/mnt/.psplash psplash-write "QUIT" || true
- sleep 1
- fi
-
- if [ -x "$OPIEDIR/bin/opie-login" ]; then
- echo Starting Opie-login....
- $OPIEDIR/bin/opie-login -terminal 3
- else
- $OPIEDIR/bin/opie-reorgfiles
- if [ -x /usr/bin/ssh-agent ]; then
- SSHAGENT=/usr/bin/ssh-agent
- else
- SSHAGENT=""
- fi
-
- if [ -x "$OPIEDIR/bin/opie-sh-ssh-askpass.sh" ]; then
- export SSH_ASKPASS=$OPIEDIR/bin/opie-sh-ssh-askpass.sh
- fi
- echo Starting Opie....
- $SSHAGENT $OPIEDIR/bin/qpe -terminal 3
- fi
-
- ;;
-
-'stop')
- echo "Stopping Opie..."
- killall qpe 2>/dev/null
- killall opie-login 2>/dev/null
- killall quicklauncher 2>/dev/null
-
- ;;
-
-'restart')
- $0 stop && $0 start
-
- ;;
-
-*)
- echo "usage: $0 { start | stop | restart }"
-
- ;;
-
-esac
-
diff --git a/packages/opie-taskbar/opie-taskbar/opie-reorgfiles b/packages/opie-taskbar/opie-taskbar/opie-reorgfiles
deleted file mode 100755
index 96b3e29da4..0000000000
--- a/packages/opie-taskbar/opie-taskbar/opie-reorgfiles
+++ /dev/null
@@ -1,93 +0,0 @@
-#!/bin/sh
-
-APPS=$HOME/Applications
-DOCS=$HOME/Documents
-
-if [ -d $APPS -a "$1" != "-f" ]
-then
- echo "You seem to already have a $APPS directory."
- echo "Assuming it is the Opie Applications directory. Exiting."
- exit 0
-fi
-
-if [ -d $HOME/Apps ]
-then
- mv $HOME/Apps $APPS
-else
- mkdir $APPS
-fi
-
-if [ -f $DOCS/addressbook.xml ]
-then
- if [ -f $APPS/addressbook/addressbook.xml ]
- then
- echo "$DOCS/addressbook.xml conflicts with $APPS/addressbook/addressbook.xml"
- echo "Moving $DOCS/addressbook.xml to $HOME"
- mv $DOCS/addressbook.xml $HOME
- else
- mkdir $APPS/addressbook
- mv $DOCS/addressbook.xml $APPS/addressbook
- fi
-fi
-
-if [ -f $DOCS/datebooksettings.xml ]
-then
- echo "$DOCS/datebooksettings.xml is obsolete"
- echo "Please re-set your datebook preferences"
- rm $DOCS/datebooksettings.xml
-fi
-
-if [ -f $DOCS/datebook.xml ]
-then
- mkdir $APPS/databook
- mv $DOCS/datebook.xml $APPS/databook
-fi
-
-if [ -d $DOCS/qtmail ]
-then
- mv $DOCS/qtmail $APPS/
-fi
-
-if [ -f $DOCS/todo.xml ]
-then
- if [ -f $APPS/todolist/todolist.xml ]
- then
- mv $DOCS/todo.xml $HOME
- echo "$DOCS/todo.xml is superceded by $APPS/todolist/todolist.xml"
- echo "$DOCS/todo.xml has been moved to $HOME"
- else
- echo "NOTE: $DOCS/todo.xml is obsolete. It will move to $APPS/todolist/todolist.xml"
- echo "when next you run the latest ToDo application."
- fi
-fi
-
-if [ ! -d $APPS/qimpen ]
-then
- mkdir $APPS/qimpen
-fi
-
-if [ -f $DOCS/asciilower.qpt ]
-then
- mv $DOCS/asciilower.qpt $APPS/qimpen
-fi
-
-if [ -f $DOCS/asciiupper.qpt ]
-then
- mv $DOCS/asciiupper.qpt $APPS/qimpen
-fi
-
-if [ -f $DOCS/numeric.qpt ]
-then
- mv $DOCS/numeric.qpt $APPS/qimpen
-fi
-
-if [ -d "$HOME/.qpe" ]
-then
- if [ -d "$HOME/Settings" ]
- then
- mv $HOME/.qpe/* "$HOME/Settings"
- rmdir "$HOME/.qpe"
- else
- mv $HOME/.qpe "$HOME/Settings"
- fi
-fi
diff --git a/packages/opie-taskbar/opie-taskbar/opie_defaults b/packages/opie-taskbar/opie-taskbar/opie_defaults
deleted file mode 100644
index 7de76e4276..0000000000
--- a/packages/opie-taskbar/opie-taskbar/opie_defaults
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-MACHINE="`cat /proc/cpuinfo | sed -n "/^Hardware/s/.*\:\(.*\)/\1/;s/^\ //p"`"
-KVER="`uname -r | sed -n "s/\([0-9]\)\.\([0-9]\)\..*/\1.\2/p"`"
-
-case "$MACHINE" in
-*Poodle) test "$KVER" = "2.6" && export QWS_CURSOR_ROTATION=90;;
-esac
-
-export QTDIR="/opt/QtPalmtop"
-export OPIEDIR="$QTDIR"
-export QPEDIR="$QTDIR"
-export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$OPIEDIR/lib"
-export PATH="$PATH:$OPIEDIR/bin"
-
diff --git a/packages/opie-taskbar/opie-taskbar/qpe.conf b/packages/opie-taskbar/opie-taskbar/qpe.conf
deleted file mode 100644
index 59bb20c762..0000000000
--- a/packages/opie-taskbar/opie-taskbar/qpe.conf
+++ /dev/null
@@ -1,18 +0,0 @@
-[Appearance]
-FontFamily = DejaVu_Sans
-FontStyle = Regular
-FontSize = 9
-FixedFontFamily = DejaVu_Sans_Mono
-FixedFontStyle = Regular
-FixedFontSize = 9
-Background = #d5d0de
-Base = #ffffff
-Button = #e3e3e3
-ButtonText = #000000
-Decoration = libliquid.so
-Highlight = #52719c
-HighlightedText = #ffffff
-Style = libphasestyle.so
-Text = #000000
-[InputMethod]
-current = Multikey
diff --git a/packages/opie-taskbar/opie-taskbar/simpad/.mtn2git_empty b/packages/opie-taskbar/opie-taskbar/simpad/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/opie-taskbar/opie-taskbar/simpad/.mtn2git_empty
+++ /dev/null
diff --git a/packages/opie-taskbar/opie-taskbar/simpad/qpe.conf b/packages/opie-taskbar/opie-taskbar/simpad/qpe.conf
deleted file mode 100644
index b10d90b94e..0000000000
--- a/packages/opie-taskbar/opie-taskbar/simpad/qpe.conf
+++ /dev/null
@@ -1,18 +0,0 @@
-[Appearance]
-FontFamily = DejaVu_Sans
-FontStyle = Regular
-FontSize = 12
-FixedFontFamily = DejaVu_Sans_Mono
-FixedFontStyle = Regular
-FixedFontSize = 12
-Background = #d5d0de
-Base = #ffffff
-Button = #e3e3e3
-ButtonText = #000000
-Decoration = libliquid.so
-Highlight = #52719c
-HighlightedText = #ffffff
-Style = libphasestyle.so
-Text = #000000
-[InputMethod]
-current = Multikey
diff --git a/packages/opie-taskbar/opie-taskbar/spitz/.mtn2git_empty b/packages/opie-taskbar/opie-taskbar/spitz/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/opie-taskbar/opie-taskbar/spitz/.mtn2git_empty
+++ /dev/null
diff --git a/packages/opie-taskbar/opie-taskbar/spitz/qpe.conf b/packages/opie-taskbar/opie-taskbar/spitz/qpe.conf
deleted file mode 100644
index e9922e4d86..0000000000
--- a/packages/opie-taskbar/opie-taskbar/spitz/qpe.conf
+++ /dev/null
@@ -1,22 +0,0 @@
-[Appearance]
-useBigPixmaps = 1
-SmallIconSize = 32
-BigIconSize = 48
-FontFamily = DejaVu_Sans
-FontStyle = Regular
-FontSize = 16
-FixedFontFamily = DejaVu_Sans_Mono
-FixedFontStyle = Regular
-FixedFontSize = 14
-Background = #d5d0de
-Base = #ffffff
-Button = #e3e3e3
-ButtonText = #000000
-Decoration = libliquid.so
-Highlight = #52719c
-HighlightedText = #ffffff
-Style = Windows
-Text = #000000
-TabStyle = 1
-[InputMethod]
-current = Multikey
diff --git a/packages/opie-taskbar/opie-taskbar/tosa/.mtn2git_empty b/packages/opie-taskbar/opie-taskbar/tosa/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/opie-taskbar/opie-taskbar/tosa/.mtn2git_empty
+++ /dev/null
diff --git a/packages/opie-taskbar/opie-taskbar/tosa/qpe.conf b/packages/opie-taskbar/opie-taskbar/tosa/qpe.conf
deleted file mode 100644
index e9922e4d86..0000000000
--- a/packages/opie-taskbar/opie-taskbar/tosa/qpe.conf
+++ /dev/null
@@ -1,22 +0,0 @@
-[Appearance]
-useBigPixmaps = 1
-SmallIconSize = 32
-BigIconSize = 48
-FontFamily = DejaVu_Sans
-FontStyle = Regular
-FontSize = 16
-FixedFontFamily = DejaVu_Sans_Mono
-FixedFontStyle = Regular
-FixedFontSize = 14
-Background = #d5d0de
-Base = #ffffff
-Button = #e3e3e3
-ButtonText = #000000
-Decoration = libliquid.so
-Highlight = #52719c
-HighlightedText = #ffffff
-Style = Windows
-Text = #000000
-TabStyle = 1
-[InputMethod]
-current = Multikey
diff --git a/packages/opie-taskbar/opie-taskbar_1.2.2.bb b/packages/opie-taskbar/opie-taskbar_1.2.2.bb
index c6151d2327..497bff0953 100644
--- a/packages/opie-taskbar/opie-taskbar_1.2.2.bb
+++ b/packages/opie-taskbar/opie-taskbar_1.2.2.bb
@@ -1,5 +1,5 @@
require ${PN}.inc
-PR = "r6"
+PR = "r7"
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/settings/mediummount \
@@ -10,10 +10,4 @@ SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
${HANDHELDS_CVS};tag=${TAG};module=opie/etc \
file://nomax.patch;patch=1;pnum=3 \
file://server.pro \
- file://opie-reorgfiles \
- file://opie \
- file://qpe.conf \
- file://locale.conf \
- file://opie_defaults"
-
-SRC_URI_append_c7x0 = " file://qpe-suspend-resume"
+ "
diff --git a/packages/opie-taskbar/opie-taskbar_cvs.bb b/packages/opie-taskbar/opie-taskbar_cvs.bb
index 41119484c1..6ff5a5ef66 100644
--- a/packages/opie-taskbar/opie-taskbar_cvs.bb
+++ b/packages/opie-taskbar/opie-taskbar_cvs.bb
@@ -1,6 +1,6 @@
require ${PN}.inc
PV = "${OPIE_CVS_PV}"
-PR = "r6"
+PR = "r7"
SRC_URI = "${HANDHELDS_CVS};module=opie/core/apps/calibrate \
${HANDHELDS_CVS};module=opie/noncore/settings/mediummount \
@@ -11,10 +11,4 @@ SRC_URI = "${HANDHELDS_CVS};module=opie/core/apps/calibrate \
${HANDHELDS_CVS};module=opie/etc \
file://nomax.patch;patch=1;pnum=3 \
file://server.pro \
- file://opie-reorgfiles \
- file://opie \
- file://qpe.conf \
- file://locale.conf \
- file://opie_defaults"
-
-SRC_URI_append_c7x0 = " file://qpe-suspend-resume"
+ "