aboutsummaryrefslogtreecommitdiffstats
path: root/packages/monotone
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-12-18 11:37:17 +0000
committerKoen Kooi <koen@openembedded.org>2006-12-18 11:37:17 +0000
commit875d1a0a804b0898e79e532476ee70fdbe1c6a1a (patch)
treee039013ea9473b6a114c8818ba6dd499098bf266 /packages/monotone
parent0fbebb79dea3b8452469709b65c1b729a484e87f (diff)
downloadopenembedded-875d1a0a804b0898e79e532476ee70fdbe1c6a1a.tar.gz
monotone: add 0.31
Diffstat (limited to 'packages/monotone')
-rw-r--r--packages/monotone/files/configure.ac-no-sync-with-stdio-0.31.patch10
-rw-r--r--packages/monotone/monotone-6_0.31.bb48
2 files changed, 58 insertions, 0 deletions
diff --git a/packages/monotone/files/configure.ac-no-sync-with-stdio-0.31.patch b/packages/monotone/files/configure.ac-no-sync-with-stdio-0.31.patch
new file mode 100644
index 0000000000..60759fb727
--- /dev/null
+++ b/packages/monotone/files/configure.ac-no-sync-with-stdio-0.31.patch
@@ -0,0 +1,10 @@
+--- /tmp/configure.ac 2006-12-18 12:14:47.000000000 +0100
++++ monotone-0.31/configure.ac 2006-12-18 12:15:58.022227000 +0100
+@@ -73,7 +73,6 @@
+ AC_CXX_STLPORT_HASHMAP
+ AC_CXX_TR1_UNORDERED_MAP
+ AC_CXX_TR1_UNORDERED_MAP_CONST_CORRECT
+-AC_CXX_SYNC_WITH_STDIO_WORKS
+ AC_CXX_TEMPLATE_STATIC_CONST_BUG
+
+ # Checks for typedefs and structures.
diff --git a/packages/monotone/monotone-6_0.31.bb b/packages/monotone/monotone-6_0.31.bb
new file mode 100644
index 0000000000..7629ff6e61
--- /dev/null
+++ b/packages/monotone/monotone-6_0.31.bb
@@ -0,0 +1,48 @@
+DESCRIPTION = "Monotone is a distributed Source Control System"
+HOMEPAGE = "http://www.venge.net/monotone"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "MIT"
+DEPENDS = "boost"
+
+S = "${WORKDIR}/monotone-${PV}"
+# no cross compile support - it tries to run the test program even with
+# --enable_ipv6=yes
+EXTRA_OECONF = "--disable-ipv6 \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-nls \
+ --with-gnu-ld \
+ --with-bundled-lua --with-bundled-sqlite"
+
+inherit autotools
+
+# Release 0.22 reveals bugs in g++ for thumb (g++ generates
+# relocations which the linker cannot represent)
+#FIXME: remove the following
+ARM_INSTRUCTION_SET = "arm"
+
+PR = "r0"
+
+SRC_URI = "http://venge.net/monotone/downloads/monotone-${PV}.tar.gz \
+ file://txt2c-cross-post-0.22.patch;patch=1 \
+ file://uclibc.database.hh.stdarg.patch;patch=1 \
+ file://configure.ac-no-sync-with-stdio-0.31.patch;patch=1 \
+ "
+do_compile_append() {
+ touch testsuite
+}
+
+# This makes the testsuite as a package and renames the monotone executable
+# to include the netsync suffix.
+do_install_append() {
+ install -d ${D}${tsd}
+ install -c -m 755 testsuite ${D}${tsd}/testsuite
+ cp -pPR tests ${D}${tsd}/tests
+}
+
+PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
+tsd = "/home/monotone/${PN}"
+FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
+RDEPENDS_${PN}-testsuite += "bash sed grep cvs patch perl perl-modules"
+