aboutsummaryrefslogtreecommitdiffstats
path: root/packages/lmbench
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/lmbench
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/lmbench')
-rw-r--r--packages/lmbench/lmbench_2.0.4.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/packages/lmbench/lmbench_2.0.4.bb b/packages/lmbench/lmbench_2.0.4.bb
index e69de29bb2..dfe8c82d13 100644
--- a/packages/lmbench/lmbench_2.0.4.bb
+++ b/packages/lmbench/lmbench_2.0.4.bb
@@ -0,0 +1,44 @@
+SECTION = "console/utils"
+DESCRIPTION = "Tools for performance analysis."
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+
+SRC_URI = "ftp://ftp.bitmover.com/lmbench/lmbench-${PV}.tgz \
+ file://debian.patch;patch=1 \
+ file://exe.patch;patch=1 \
+ file://lmbench-run"
+S = "${WORKDIR}/lmbench-${PV}"
+
+EXTRA_OEMAKE = '"CC=${CC}" "AR=${AR}" "CFLAGS=$CFLAGS" \
+ "LDFLAGS=${LDFLAGS}" "LD=${LD}" "OS=${TARGET_SYS}" \
+ "TARGET=${TARGET_OS}" "O=${S}/bin/${TARGET_SYS}"'
+
+python do_unpack () {
+ bb.build.exec_func('base_do_unpack', d)
+ bb.build.exec_func('byebk_do_unpack', d)
+}
+
+byebk_do_unpack () {
+ find ${S}/.. -name BitKeeper -o -name SCCS | xargs rm -rf
+}
+
+do_compile () {
+ . ${CONFIG_SITE}
+ if [ X"$ac_cv_uint" == X"yes" ]; then
+ CFLAGS="${CFLAGS} -DHAVE_uint"
+ fi
+ install -d ${S}/bin/${TARGET_SYS}
+ oe_runmake -C src exe
+ sed -i -e 's,^SHAREDIR=.*$,SHAREDIR=${datadir}/${PN},;' \
+ -e 's,^BINDIR=.*$,BINDIR=${libdir}/${PN},;' ${WORKDIR}/lmbench-run
+}
+
+do_install () {
+ oe_runmake 'PREFIX=${D}${prefix}' \
+ 'SHAREDIR=${D}${datadir}/${PN}' \
+ 'BINDIR=${D}${libdir}/lmbench' install
+ install -d ${D}${localstatedir}/lib/lmbench/config \
+ ${D}${localstatedir}/run/lmbench \
+ ${D}${bindir}
+ install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/
+}