aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-02-10 13:27:10 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-02-11 14:45:11 +0100
commitf9f6c12d70b42ce6ec3461ea993ff52d10bfbc00 (patch)
tree32d161073266b1b5c44fa0155218c0abac58aeeb
parent9fb968857de242f3d91ada7f17d9bee3ba0fe91a (diff)
downloadopenembedded-f9f6c12d70b42ce6ec3461ea993ff52d10bfbc00.tar.gz
python-gst: update python-path.patch
* py_prefix is used later for -L and without py_prefix set it tries to load libraries from buildhost instead of staging Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/python/python-gst/python-path.patch5
-rw-r--r--recipes/python/python-gst_0.10.17.bb2
2 files changed, 5 insertions, 2 deletions
diff --git a/recipes/python/python-gst/python-path.patch b/recipes/python/python-gst/python-path.patch
index 6cbad8cc5f..5256ddd0ec 100644
--- a/recipes/python/python-gst/python-path.patch
+++ b/recipes/python/python-gst/python-path.patch
@@ -2,7 +2,7 @@ Index: gst-python-0.10.10/acinclude.m4
===================================================================
--- gst-python-0.10.10.orig/acinclude.m4
+++ gst-python-0.10.10/acinclude.m4
-@@ -43,16 +43,20 @@ AC_DEFUN([AM_CHECK_PYTHON_HEADERS],
+@@ -43,16 +43,21 @@ AC_DEFUN([AM_CHECK_PYTHON_HEADERS],
[AC_REQUIRE([AM_PATH_PYTHON])
AC_MSG_CHECKING(for headers required to compile python extensions)
dnl deduce PYTHON_INCLUDES
@@ -15,6 +15,7 @@ Index: gst-python-0.10.10/acinclude.m4
+ [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
+if test x$py_exec_prefix != x; then
+ PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
++ py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
else
- PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
- if test "$py_prefix" != "$py_exec_prefix"; then
@@ -23,7 +24,7 @@ Index: gst-python-0.10.10/acinclude.m4
+ py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
+ py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
+ PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
-+if test "$py_prefix" != "$py_exec_prefix"; then
++ if test "$py_prefix" != "$py_exec_prefix"; then
+ PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
+ fi
fi
diff --git a/recipes/python/python-gst_0.10.17.bb b/recipes/python/python-gst_0.10.17.bb
index 6b3a147f14..b0b552b7e1 100644
--- a/recipes/python/python-gst_0.10.17.bb
+++ b/recipes/python/python-gst_0.10.17.bb
@@ -3,6 +3,8 @@ SECTION = "devel/python"
LICENSE = "LGPL"
DEPENDS = "gstreamer gst-plugins-base python-pygobject"
+PR = "r1"
+
SRC_URI = "\
http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
file://python-path.patch;patch=1 \