aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Zimmermann <ml@vdm-design.de>2009-11-26 21:36:30 +0000
committerKlaus Kurzmann <mok@fluxnetz.de>2009-11-27 07:34:36 +0100
commitf7d4b310b5ae61c2234c0f3aaccab17905bc2977 (patch)
tree83509365df8fb221257d179f4a18f5dcdcfe91f8
parentac7ca9c49d1648057f4de5984fd6dc097d14ef0d (diff)
downloadopenembedded-f7d4b310b5ae61c2234c0f3aaccab17905bc2977.tar.gz
babiloo: new recipe
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
-rw-r--r--conf/distro/include/sane-srcrevs.inc1
-rw-r--r--recipes/openmoko-3rdparty/babiloo-efl_bzr.bb40
2 files changed, 41 insertions, 0 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index cff2d4326e..3dee57ca73 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -20,6 +20,7 @@ SRCREV_pn-app-restarter ?= "4552"
SRCREV_pn-assassin ?= "268"
SRCREV_pn-assassin-thumbnail ?= "4690"
SRCREV_pn-aufs2-util ?= "f35ba2292fe40aa94aa83713e0b2719f35a25768"
+SRCREV_pn-babiloo-efl ?= "288"
SRCREV_pn-bfin-uclibc ?= "1857"
SRCREV_pn-blipomoko ?= "93295f36f7b45c691df247cb2a65227facf13654"
SRCREV_pn-bootchart-lite ?= "4"
diff --git a/recipes/openmoko-3rdparty/babiloo-efl_bzr.bb b/recipes/openmoko-3rdparty/babiloo-efl_bzr.bb
new file mode 100644
index 0000000000..da792df354
--- /dev/null
+++ b/recipes/openmoko-3rdparty/babiloo-efl_bzr.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "EFL Dictionary Viewer. It supports dictionaries in SDictionary and StarDict format."
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "Luca Vaudano <vaudano@gmail.com>"
+HOMEPAGE = "http://babiloo-project.org"
+RDEPENDS = "python-elementary python-compression python-misc python-netclient"
+
+PACKAGE_ARCH = "all"
+
+PV = "2.0.9-bzrr${SRCREV}"
+
+SRC_URI = "bzr://bazaar.launchpad.net/~vaudano/babiloo/efl"
+
+S = "${WORKDIR}/efl"
+
+do_install() {
+ install -d "${D}${datadir}/babiloo"
+ cp -a "${S}/core" "${D}${datadir}/babiloo/"
+ cp -a "${S}/efl" "${D}${datadir}/babiloo/"
+ cp -a "${S}/images" "${D}${datadir}/babiloo/"
+ cp -a "${S}/dicts" "${D}${datadir}/babiloo/"
+ install -m 0755 "${S}/run.py" "${D}${datadir}/babiloo/"
+ install -d "${D}${bindir}"
+ ln -s "${datadir}/babiloo/run.py" "${D}${bindir}/babiloo"
+ install -d "${D}${datadir}/pixmaps"
+ install -m 0644 "${S}/images/babiloo.png" "${D}${datadir}/pixmaps"
+ install -d "${D}${datadir}/applications"
+ install -m 0644 "${S}/babiloo.desktop" "${D}${datadir}/applications"
+
+ install -d "${D}${datadir}"
+ cp -a "${S}/locale" "${D}${datadir}/"
+ find ${D}${datadir}/locale -name *.po -exec rm {} \;
+ rm -f ${D}${datadir}/locale/babiloo.pot
+
+ install -d "${D}${datadir}/doc"
+ install -m 0644 "${S}/doc/efl/babiloo.pdf" "${D}${datadir}/doc/"
+}
+
+FILES_${PN} += "${datadir}/babiloo"