aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-24 10:34:01 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-24 10:37:32 +0100
commitf5476413f678774ecb308fbec7b924ef7697c902 (patch)
tree4fd2890a8bf422f46c26455aec2a77a2c214d2c8
parente3770d632b113c4febe54a7c8d4da277ffdfdeb4 (diff)
downloadopenembedded-f5476413f678774ecb308fbec7b924ef7697c902.tar.gz
gpe-icons: make merger less verbose and bump PR
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/gpe-icons/gpe-icons.inc8
-rw-r--r--recipes/gpe-icons/gpe-icons_0.25.bb2
-rw-r--r--recipes/gpe-icons/gpe-theme-neo_git.bb2
3 files changed, 6 insertions, 6 deletions
diff --git a/recipes/gpe-icons/gpe-icons.inc b/recipes/gpe-icons/gpe-icons.inc
index 613786ebc3..0c23814b41 100644
--- a/recipes/gpe-icons/gpe-icons.inc
+++ b/recipes/gpe-icons/gpe-icons.inc
@@ -3,6 +3,8 @@ RDEPENDS += "gdk-pixbuf-loader-png"
inherit update-alternatives
+INC_PR = "r3"
+
ALTERNATIVE_NAME = "gpe-pixmaps"
ALTERNATIVE_LINK = "${datadir}/gpe/pixmaps"
ALTERNATIVE_PATH = "${datadir}/gpe/pixmaps.${PN}"
@@ -25,11 +27,9 @@ pkg_postinst() {
fi
for pixmap in `find ${pixmap_dir}`; do
pixmap_target=`echo ${pixmap} | sed "s/${pixmap_dir}/pixmaps.${PN}/g"`;
- if [ -e ${pixmap_target} ] ; then
- echo "${pixmap_target} exists";
- else
- echo "${pixmap} merged";
+ if [ ! -e ${pixmap_target} ] ; then
cp -ra ${pixmap} ${pixmap_target};
+ echo "${pixmap} merged";
fi;
done
done
diff --git a/recipes/gpe-icons/gpe-icons_0.25.bb b/recipes/gpe-icons/gpe-icons_0.25.bb
index 42742d4ac1..ac1e9fccd4 100644
--- a/recipes/gpe-icons/gpe-icons_0.25.bb
+++ b/recipes/gpe-icons/gpe-icons_0.25.bb
@@ -7,7 +7,7 @@ RDEPENDS = "gdk-pixbuf-loader-png"
inherit gpe
-PR = "r2"
+PR = "${INC_PR}.0"
#only icons present in the package
PACKAGE_ARCH = "all"
diff --git a/recipes/gpe-icons/gpe-theme-neo_git.bb b/recipes/gpe-icons/gpe-theme-neo_git.bb
index 54ab120640..192c8a7d8e 100644
--- a/recipes/gpe-icons/gpe-theme-neo_git.bb
+++ b/recipes/gpe-icons/gpe-theme-neo_git.bb
@@ -7,7 +7,7 @@ RRECOMMENDS = "elementary-theme-neo e-wm-theme-illume-neo gtk-theme-neo libframe
LICENSE = "unknown"
PV = "0.2-${EFL_SRCREV}+gitr${SRCPV}"
-PR = "r2"
+PR = "${INC_PR}.0"
SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"