aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-12-21 13:44:15 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-12-21 13:44:15 +0000
commite2d67a374cfbbab009759febcab19423600a311a (patch)
tree805b479e719f97a44090971b5a2808e4303de656
parent79225707f088f8d68bdfe3884f6f9c28817462e9 (diff)
downloadopenembedded-e2d67a374cfbbab009759febcab19423600a311a.tar.gz
xfce4-panel: package and install mcs-plugins as well
-rw-r--r--packages/xfce4-panel/xfce4-panel.inc11
-rw-r--r--packages/xfce4-panel/xfce4-panel_4.2.2.bb1
2 files changed, 4 insertions, 8 deletions
diff --git a/packages/xfce4-panel/xfce4-panel.inc b/packages/xfce4-panel/xfce4-panel.inc
index 30473eea06..5510a13a09 100644
--- a/packages/xfce4-panel/xfce4-panel.inc
+++ b/packages/xfce4-panel/xfce4-panel.inc
@@ -10,20 +10,15 @@ inherit pkgconfig xfce
EXTRA_OECONF += " --enable-startup-notification"
-HEADERS="controls.h global.h icons.h main.h panel.h item.h \
- item_dialog.h plugins.h xfce_support.h xfce.h"
do_stage() {
- install -d ${STAGING_INCDIR}/xfce4/panel
-
- for file in ${HEADERS}; do
- install -m 644 ${S}/panel/$file ${STAGING_INCDIR}/xfce4/panel/$file
- done
+autotools_stage_all
}
do_install() {
oe_runmake DESTDIR=${D} install
}
-PACKAGES += "${PN}-plugins"
+PACKAGES += "${PN}-plugins ${PN}-mcs-plugins"
FILES_${PN}-plugins += "${libdir}/xfce4/panel-plugins/*.so*"
+FILES_${PN}-mcs-plugins += "${libdir}/xfce4/mcs-plugins/"
diff --git a/packages/xfce4-panel/xfce4-panel_4.2.2.bb b/packages/xfce4-panel/xfce4-panel_4.2.2.bb
index b04b92953d..36f4c49553 100644
--- a/packages/xfce4-panel/xfce4-panel_4.2.2.bb
+++ b/packages/xfce4-panel/xfce4-panel_4.2.2.bb
@@ -2,4 +2,5 @@
# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
# Released under the MIT license (see packages/COPYING)
+PR="r1"
include ${PN}.inc