aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngus Ainslie <nytowl@openmoko.org>2009-04-21 13:18:02 -0600
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-04-24 17:23:57 +0200
commitdf48726ac9dc66f910bf4c871f3de7094a726a77 (patch)
tree6a8f6662090a500ea66d8cb946d9f56af371951b
parent80c85e0af3865710a189ba536022d326fa996d26 (diff)
downloadopenembedded-df48726ac9dc66f910bf4c871f3de7094a726a77.tar.gz
fltk2: add an svn recipe for the beta version of fltk library
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/fltk/fltk2_svn.bb41
2 files changed, 45 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index fc2093b139..9cdf47af72 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -6102,6 +6102,10 @@ sha256=855a97e35da823f205253b865758715872cd2c7720e4dcf134a3b6dc18bfb96a
md5=e146fd264e1001b1313acfd41ef75552
sha256=facba5a97a20ca92b32504174474775c6b12fb67a6f646fa0de18db709c3edde
+[http://ftp.easysw.com/pub/fltk/snapshots/fltk-2.0.x-r6671.tar.bz2]
+md5=6bcef5fd51eb3bc4dd0702f3ae6da6ba
+sha256=4c9a67f0d32c05af92bf95d5feec8eb4a8d56bfbfe2cd4364b32009cfd609b54
+
[http://members.cheese.at/woody/fltk-chess/fltk-chess-0.5.tgz]
md5=ee34788a2dc9fdc088a6dc66c31eba34
sha256=c789b355d0ba03b018513c3904bba6d6fab01b3a83a460fbe1b20a79052f46a4
diff --git a/recipes/fltk/fltk2_svn.bb b/recipes/fltk/fltk2_svn.bb
new file mode 100644
index 0000000000..7cc5a06b74
--- /dev/null
+++ b/recipes/fltk/fltk2_svn.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "FLTK is a cross-platform C++ GUI toolkit"
+HOMEPAGE = "http://www.fltk.org"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "zlib jpeg libpng libxext libxft"
+
+SRC_URI = "http://ftp.easysw.com/pub/fltk/snapshots/fltk-2.0.x-r6671.tar.bz2"
+
+#S = "${WORKDIR}/fltk-${PV}"
+S = "${WORKDIR}/fltk-2.0.x-r6671"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "--enable-shared --enable-xdbe --enable-xft --enable-gl --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}"
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install () {
+ sed -i "s|^STRIP.*=.*$|STRIP = ${STRIP}|" makeinclude
+ sed -i "s|^bindir.*=.*$|bindir = ${D}${bindir}|" makeinclude
+ oe_runmake install \
+ prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ datadir="${STAGING_DATADIR}"
+}
+
+python populate_packages_prepend () {
+ if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
+ bb.data.setVar('PKG_${PN}', 'libfltk2${PV}', d)
+}
+
+LEAD_SONAME = "libfltk2.so"