aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-05-27 15:57:32 +0000
committerJohn Bowler <jbowler@nslu2-linux.org>2005-05-27 15:57:32 +0000
commitdb81f176add4d94b2348ea92d0e57ae31e1dd517 (patch)
treee5f52c13ad05780aa753f3389f688d3342ceb18c
parentba72365e84cf61c7c39f6b2d1414e31a1c2e507a (diff)
downloadopenembedded-db81f176add4d94b2348ea92d0e57ae31e1dd517.tar.gz
Image description changes: packages not required for a
bootable image have been moved to the openslug.conf file so that an image can be built without them (by overriding the OPENSLUG_EXTRA_RDEPENDS variable.) Image release name changed to 1.20-pre1 BKrev: 4297436cqk3HFrq4AoEgLcOBYWcbpw
-rw-r--r--conf/distro/openslug.conf23
-rw-r--r--packages/linux/openslug-kernel-2.6.11.2/defconfig10
-rw-r--r--packages/linux/openslug-kernel_2.6.11.2.bb2
-rw-r--r--packages/meta/openslug-image.bb11
-rw-r--r--packages/meta/openslug-packages.bb3
5 files changed, 30 insertions, 19 deletions
diff --git a/conf/distro/openslug.conf b/conf/distro/openslug.conf
index 59575f0810..5ab025e8f9 100644
--- a/conf/distro/openslug.conf
+++ b/conf/distro/openslug.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: OpenSlug Linux Distribution for the NSLU2
DISTRO_NAME = "OpenSlug"
-DISTRO_VERSION = "1.12-beta"
+DISTRO_VERSION = "1.20-pre1"
DISTRO_TYPE ?= "beta"
TARGET_FPU_local ?= "soft"
@@ -21,8 +21,18 @@ IMAGE_FSTYPES = "jffs2"
OPENSLUG_DEVICE_TABLE = "${@bb.which(bb.data.getVar('BBPATH', d, 1), 'files/device_table-openslug.txt')}"
EXTRA_IMAGECMD_jffs2 = "--pad --big-endian --eraseblock=0x20000 -D ${OPENSLUG_DEVICE_TABLE}"
-OPENSLUG_EXTRA_DEPENDS ?= ""
+OPENSLUG_EXTRA_DEPENDS ?= "e2fsprogs reiserfsprogs lrzsz"
+
+# Filesystem support modules are listed in here for easy removal,
+# as is the lrzsz serial package and other kernel modules which are
+# not absolutely required for boot.
+# NOTE: only jffs2 support is an absolute requirement of boot, even
+# the ext2/ext3 support is optional!
+OPENSLUG_EXT2_PROGS = "e2fsprogs-mke2fs e2fsprogs-fsck e2fsprogs-e2fsck"
+OPENSLUG_REISER_PROGS = "reiserfsprogs"
OPENSLUG_EXTRA_RDEPENDS ?= "\
+lrzsz \
+${OPENSLUG_EXT2_PROGS} ${OPENSLUG_REISER_PROGS} \
kernel-module-usbnet \
kernel-module-pegasus kernel-module-p8022 kernel-module-kaweth \
kernel-module-usbserial \
@@ -43,11 +53,14 @@ kernel-module-pl2303 kernel-module-ftdi-sio"
# boot (however you can do a simple flash file system boot - no
# attached disk - and install the nfs modules from ssh.)
OPENSLUG_EXTRA_FILESYSTEMS ?= "\
+kernel-module-ext2 \
+kernel-module-ext3 \
kernel-module-nfs \
kernel-module-vfat \
kernel-module-ntfs \
kernel-module-isofs \
kernel-module-udf \
+kernel-module-reiserfs \
kernel-module-nls-cp437 \
kernel-module-nls-utf8 \
"
@@ -58,14 +71,10 @@ kernel-module-nls-utf8 \
# kernel-module-msdos - mounts a FAT file system without long file names
# (use kernel-module-vfat, it shows the long names
# if present.)
-# kernel-module-reiserfs - support for the reiser file system
OPENSLUG_EXTRA_INSTALL ?= "${OPENSLUG_EXTRA_RDEPENDS} ${OPENSLUG_EXTRA_FILESYSTEMS}"
-# These lines are for backwards compatibility and will be removed soon.
-BOOTSTRAP_EXTRA_DEPENDS += "${OPENSLUG_EXTRA_DEPENDS}"
-BOOTSTRAP_EXTRA_RDEPENDS += "${OPENSLUG_EXTRA_RDEPENDS} ${OPENSLUG_EXTRA_FILESYSTEMS}"
-
+# Select the correct versions of the kernel and modules
PREFERRED_PROVIDER_virtual/kernel ?= "openslug-kernel"
PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}depmod:module-init-tools-cross"
diff --git a/packages/linux/openslug-kernel-2.6.11.2/defconfig b/packages/linux/openslug-kernel-2.6.11.2/defconfig
index 85d5f732e9..b8aed8ab07 100644
--- a/packages/linux/openslug-kernel-2.6.11.2/defconfig
+++ b/packages/linux/openslug-kernel-2.6.11.2/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.11.2
-# Fri Apr 8 14:02:10 2005
+# Thu May 26 13:35:59 2005
#
CONFIG_ARM=y
CONFIG_MMU=y
@@ -160,7 +160,7 @@ CONFIG_PM=y
# CONFIG_PREEMPT is not set
CONFIG_APM=y
# CONFIG_ARTHUR is not set
-CONFIG_CMDLINE="root=/dev/ram0 rw rootfstype=ext2,jffs2 initrd=0x01000000,10M init=/linuxrc mem=32M@0x00000000 console=ttyS0,115200n8"
+CONFIG_CMDLINE="root=/dev/mtdblock4 rw rootfstype=jffs2 mem=32M@0x00000000 init=/linuxrc console=ttyS0,115200n8"
CONFIG_ALIGNMENT_TRAP=y
#
@@ -885,11 +885,11 @@ CONFIG_VIDEO_DEV=m
#
# File systems
#
-CONFIG_EXT2_FS=y
+CONFIG_EXT2_FS=m
# CONFIG_EXT2_FS_XATTR is not set
-CONFIG_EXT3_FS=y
+CONFIG_EXT3_FS=m
# CONFIG_EXT3_FS_XATTR is not set
-CONFIG_JBD=y
+CONFIG_JBD=m
# CONFIG_JBD_DEBUG is not set
CONFIG_REISERFS_FS=m
# CONFIG_REISERFS_CHECK is not set
diff --git a/packages/linux/openslug-kernel_2.6.11.2.bb b/packages/linux/openslug-kernel_2.6.11.2.bb
index d91149dfd9..c77c5ce127 100644
--- a/packages/linux/openslug-kernel_2.6.11.2.bb
+++ b/packages/linux/openslug-kernel_2.6.11.2.bb
@@ -2,7 +2,7 @@ SECTION = "kernel"
DESCRIPTION = "Linux kernel for the Linksys NSLU2 device"
LICENSE = "GPL"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
-PR = "r9"
+PR = "r10"
KERNEL_SUFFIX = "openslug"
diff --git a/packages/meta/openslug-image.bb b/packages/meta/openslug-image.bb
index 8e50c1b40a..d2bf3bb7c3 100644
--- a/packages/meta/openslug-image.bb
+++ b/packages/meta/openslug-image.bb
@@ -1,4 +1,4 @@
-PR = "r11"
+PR = "r12"
IMAGE_BASENAME = "openslug"
@@ -10,11 +10,11 @@ OPENSLUG_HIDDEN_PACKAGES = "ipkg-native ipkg-utils-native fakeroot-native ${PATC
DEPENDS = "virtual/kernel base-files base-passwd \
busybox dropbear hotplug-ng initscripts netbase \
- sysvinit tinylogin lrzsz portmap \
+ sysvinit tinylogin portmap \
ixp4xx-csr ixp425-eth openslug-init \
module-init-tools modutils-initscripts \
ipkg-collateral ipkg ipkg-link diffutils \
- cpio findutils e2fsprogs mtd-utils \
+ cpio findutils mtd-utils \
${OPENSLUG_EXTRA_DEPENDS}"
# NOTE: file system kernel modules are defined in openslug.conf
@@ -22,12 +22,11 @@ DEPENDS = "virtual/kernel base-files base-passwd \
# kernel-module-af-packet must be in the image for DHCP to work
IPKG_INSTALL = "base-files base-passwd \
busybox dropbear hotplug-ng initscripts netbase \
- update-modules sysvinit tinylogin lrzsz portmap \
+ update-modules sysvinit tinylogin portmap \
ixp4xx-csr ixp425-eth openslug-init \
module-init-tools modutils-initscripts \
ipkg-collateral ipkg ipkg-link diffutils \
- cpio findutils e2fsprogs-mke2fs \
- e2fsprogs-fsck e2fsprogs-e2fsck \
+ cpio findutils \
kernel-module-af-packet \
kernel-module-netconsole \
${OPENSLUG_EXTRA_INSTALL}"
diff --git a/packages/meta/openslug-packages.bb b/packages/meta/openslug-packages.bb
index 9b51a78602..b538e5bba0 100644
--- a/packages/meta/openslug-packages.bb
+++ b/packages/meta/openslug-packages.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "Packages that are compatible with the OpenSlug firmware"
LICENSE = MIT
PR = "r3"
+INHIBIT_DEFAULT_DEPS = "1"
ALLOW_EMPTY = 1
PACKAGES = "${PN}"
@@ -55,12 +56,14 @@ OPENSLUG_PACKAGES = "\
db4 \
openldap \
ntp \
+ reiserfsprogs reiser4progs \
"
# These packages only build on TARGET_OS=linux, not
# TARGET_OS=linux-uclibc
OPENSLUG_PACKAGES_append_linux = "\
php \
+ libpam \
yp-tools ypbind ypserv \
"