aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-04-19 08:05:38 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-04-19 08:05:38 +0000
commitd91ca3e773f74313722d598ecacffd30457b873c (patch)
tree54138312ad5a896ca8977eb4843c270e8e6c6946
parentaf3ce66433eafa9a0102c4b5834b02c54177d514 (diff)
downloadopenembedded-d91ca3e773f74313722d598ecacffd30457b873c.tar.gz
gpgme_1.1.4.bb : version upgrade needed for a newer mutt
-rw-r--r--packages/gpgme/gpgme_1.1.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/gpgme/gpgme_1.1.4.bb b/packages/gpgme/gpgme_1.1.4.bb
new file mode 100644
index 0000000000..d78cc88cef
--- /dev/null
+++ b/packages/gpgme/gpgme_1.1.4.bb
@@ -0,0 +1,22 @@
+LICENSE = "GPL"
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2"
+PR = "r1"
+
+DEPENDS = "libgpg-error pth libassuan"
+
+EXTRA_OECONF = "--with-pth=${STAGING_DIR}/${HOST_SYS} --without-pth-test --with-gpg=${bindir}/gpg --without-gpgsm"
+
+inherit autotools binconfig
+
+do_stage() {
+ autotools_stage_includes
+
+ install -d ${STAGING_LIBDIR}
+ oe_libinstall -C gpgme -so libgpgme ${STAGING_LIBDIR}
+ oe_libinstall -C gpgme -so libgpgme-pth ${STAGING_LIBDIR}
+ oe_libinstall -C gpgme -so libgpgme-pthread ${STAGING_LIBDIR}
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 gpgme/gpgme.m4 ${STAGING_DATADIR}/aclocal/
+}
+