aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2009-12-17 10:48:24 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:08 +0200
commitbf6ecab934c08a9c40044287d3ab6a56aa949cc6 (patch)
tree69583e66d3751bf5123c93423682b180287f48d8
parent8e0a8bd8f275b214d592467f662812bc3b6b5e18 (diff)
downloadopenembedded-bf6ecab934c08a9c40044287d3ab6a56aa949cc6.tar.gz
freondemo, gstd: merge from arago repo
Signed-off-by: Koen Kooi <k-kooi@ti.com>
-rw-r--r--recipes/ti/freondemo/freondemo20
-rw-r--r--recipes/ti/freondemo/freondemo.init58
-rw-r--r--recipes/ti/freondemo_git.bb36
-rw-r--r--recipes/ti/gstd_git.bb31
4 files changed, 145 insertions, 0 deletions
diff --git a/recipes/ti/freondemo/freondemo b/recipes/ti/freondemo/freondemo
new file mode 100644
index 0000000000..80dd36e132
--- /dev/null
+++ b/recipes/ti/freondemo/freondemo
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+# We start a system wide gstd daemon
+gstd &
+
+amixer -q sset 'HP DAC' 127
+
+#If we detect a mouse, use it, otherwise configure the touchcreen
+if [ ! -c /dev/input/mice ] && [ ! -c /dev/input/mouse0 ] ; then
+ if [ -c /dev/input/touchscreen0 ] ; then
+ export TSLIB_TSDEVICE=/dev/input/touchscreen0
+ if [ ! -f /etc/pointercal ] ; then
+ # We need to calibrate the screen
+ ts_calibrate
+ fi
+ export QWS_MOUSE_PROTO=tslib
+ fi
+fi
+
+/usr/libexec/FreonDemo -qws &
diff --git a/recipes/ti/freondemo/freondemo.init b/recipes/ti/freondemo/freondemo.init
new file mode 100644
index 0000000000..5cb5281245
--- /dev/null
+++ b/recipes/ti/freondemo/freondemo.init
@@ -0,0 +1,58 @@
+#! /bin/sh
+
+set -e
+
+DAEMON=/usr/bin/freondemo
+NAME=freondemo
+PIDFILE=/var/run/freondemo/pid
+DESC="Freon Demo"
+PARAMS=""
+
+test -x $DAEMON || exit 0
+
+start_it_up()
+{
+ if [ -e $PIDFILE ]; then
+ PIDDIR=/proc/$(cat $PIDFILE)
+ if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
+ echo "$DESC already started; not starting."
+ else
+ echo "Removing stale PID file $PIDFILE."
+ rm -f $PIDFILE
+ fi
+ fi
+
+ source $SESSIONFILE
+ echo -n "Starting $DESC: "
+ start-stop-daemon --start --pidfile $PIDFILE \
+ --exec $DAEMON -- $PARAMS
+ echo "$NAME."
+}
+
+shut_it_down()
+{
+ echo -n "Stopping $DESC: "
+ start-stop-daemon --stop --oknodo --pidfile $PIDFILE
+ echo "$NAME."
+ rm -f $PIDFILE
+}
+
+case "$1" in
+ start)
+ start_it_up
+ ;;
+ stop)
+ shut_it_down
+ ;;
+ restart)
+ shut_it_down
+ sleep 1
+ start_it_up
+ ;;
+ *)
+ echo "Usage: /etc/init.d/$NAME {start|stop|restart}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/ti/freondemo_git.bb b/recipes/ti/freondemo_git.bb
new file mode 100644
index 0000000000..512ef08cfa
--- /dev/null
+++ b/recipes/ti/freondemo_git.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "FreonDemo: a QT based demo for OMAP L138 EVM board"
+HOMEPAGE = "http://sourceforge.net/projects/freondemo"
+MAINTAINER = "http://sourceforge.net/projects/freondemo"
+LICENSE = "BSD"
+SECTION = "multimedia"
+PRIORITY = "optional"
+
+DEPENDS = "dbus gstd"
+RDEPENDS_${PN} = "gstd alsa-utils-amixer"
+RRECOMMENDS_${PN} = "qt4-embedded-plugin-mousedriver-tslib"
+
+SRCREV = "ed01b199780912423644f3f05f9c796f66d9209f"
+
+PV = "1.0"
+PR = "r5"
+PR_append = "+gitr${SRCREV}"
+
+SRC_URI = "git://freondemo.git.sourceforge.net/gitroot/freondemo/freondemo;protocol=git \
+ file://freondemo \
+ file://freondemo.init \
+ "
+S = "${WORKDIR}/git"
+
+inherit qt4e update-rc.d
+
+do_install() {
+ install -d ${D}/${libexecdir}
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/FreonDemo ${D}/${libexecdir}
+ install -m 0755 ${WORKDIR}/freondemo ${D}/${bindir}
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/freondemo.init ${D}${sysconfdir}/init.d/freondemo
+}
+
+INITSCRIPT_NAME = "freondemo"
+INITSCRIPT_PARAMS = "defaults 99"
diff --git a/recipes/ti/gstd_git.bb b/recipes/ti/gstd_git.bb
new file mode 100644
index 0000000000..be4838e96c
--- /dev/null
+++ b/recipes/ti/gstd_git.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Gstd: a Gstreamer-based streaming server"
+HOMEPAGE = "http://sourceforge.net/projects/harrier/"
+MAINTAINER = "harrier-devel@lists.sourceforge.net"
+LICENSE = "BSD"
+SECTION = "multimedia"
+PRIORITY = "optional"
+
+DEPENDS = "dbus dbus-glib gstreamer"
+RDEPENDS = "gst-plugins-base"
+
+SRCREV = "88b4ae3fd9973a503a85e194f17f364cdf903fb3"
+
+PV = "1.0"
+PR = "r5"
+PR_append = "+gitr${SRCREV}"
+
+SRC_URI = "git://harrier.git.sourceforge.net/gitroot/harrier/harrier;protocol=git \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+# We don't want to run autoconf or automake, unless you have
+# automake > 1.11 with vala support
+do_configure() {
+ oe_runconf
+}
+
+FILES_${PN} += "${datadir}/dbus-1/*/*.service"
+FILES_${PN}-dev += "${datadir}/dbus-1/interfaces/*.xml"