aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-17 01:56:02 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-17 01:56:02 +0000
commitb9248dbbbe231d686944cd9854317c8d032c912d (patch)
tree5be7bccdb0db41cb4c65b8f72c5b1ea6082f0ee9
parent1348c62bd2f8bd92b404171bd8e370078940d26a (diff)
downloadopenembedded-b9248dbbbe231d686944cd9854317c8d032c912d.tar.gz
Add support for -p and -D options to install.
-rw-r--r--packages/install/files/install-sh13
-rw-r--r--packages/install/install-native_0.1.bb1
2 files changed, 13 insertions, 1 deletions
diff --git a/packages/install/files/install-sh b/packages/install/files/install-sh
index 0b65ee871d..8de386e4c7 100644
--- a/packages/install/files/install-sh
+++ b/packages/install/files/install-sh
@@ -67,6 +67,7 @@ mvcmd="$mvprog"
src=
dst=
dir_arg=
+preserve_arg=
dstarg=
no_target_directory=
@@ -81,10 +82,13 @@ In the 4th, create DIRECTORIES.
Options:
-c (ignored)
+-D (ignored)
-d create directories instead of installing files.
-g GROUP $chgrpprog installed files to GROUP.
-m MODE $chmodprog installed files to MODE.
-o USER $chownprog installed files to USER.
+-p apply access/modification times of SRCFILE files
+ to corresponding DSTFILE files
-s $stripprog installed files.
-t DIRECTORY install into DIRECTORY.
-T report an error if DSTFILE is a directory.
@@ -100,6 +104,9 @@ while test -n "$1"; do
-c) shift
continue;;
+ -D) shift
+ continue;;
+
-d) dir_arg=true
shift
continue;;
@@ -121,6 +128,10 @@ while test -n "$1"; do
shift
continue;;
+ -p) preserve_arg="-p"
+ shift
+ continue;;
+
-s) stripcmd=$stripprog
shift
continue;;
@@ -265,7 +276,7 @@ do
trap '(exit $?); exit' 1 2 13 15
# Copy the file name to the temp name.
- $doit $cpprog "$src" "$dsttmp" &&
+ $doit $cpprog $preserve_arg "$src" "$dsttmp" &&
# and set any options; do chmod last to preserve setuid bits.
#
diff --git a/packages/install/install-native_0.1.bb b/packages/install/install-native_0.1.bb
index 2ae7df615a..b912b2b65e 100644
--- a/packages/install/install-native_0.1.bb
+++ b/packages/install/install-native_0.1.bb
@@ -6,6 +6,7 @@ SECTION = "devel"
PRIORITY = "optional"
LICENSE = "MIT"
INHIBIT_DEFAULT_DEPS = "1"
+PR = "r1"
SRC_URI = "file://install-sh"