aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2010-01-21 16:23:37 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-26 15:00:04 +0100
commitb79cfa7c3daec7570e7ce2118c87729a9201fefb (patch)
tree881a4003c385160b3ea3313c50ea5faf48025cde
parent6a6ff1c4cb4138b2124157cac5ad9913b2f17c8e (diff)
downloadopenembedded-b79cfa7c3daec7570e7ce2118c87729a9201fefb.tar.gz
gst-plugins-good: add 0.10.17
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/gstreamer/gst-plugins-good/flvdemux-ecma.diff26
-rw-r--r--recipes/gstreamer/gst-plugins-good_0.10.17.bb14
3 files changed, 44 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index e797fd5c06..c68f419fe5 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -11342,6 +11342,10 @@ sha256=12205d01cb99900ed6f936a09ac31b5849f8a7ff3c9a93e5857a76dc3e30788a
md5=19bc6cc07951b3382d1ac8525b20e83f
sha256=831f450a0fa18c881b00ec50e8916ed66ca0fecb53cd1939f0abcc02930f9847
+[http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-0.10.17.tar.bz2]
+md5=833546cd2b8bbf86b8ed083b00897918
+sha256=4f41fbd325270416c9f55d900e470482a7d1e7efbdbb725ed03a085dec307ad6
+
[http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-0.10.2.tar.bz2]
md5=03d3d0b5f19014fe0065234a3ea65ee6
sha256=dd92993d08930cca071893b5d3f5cb40a4498f3ddaf12da98c0bbe8c27605e81
diff --git a/recipes/gstreamer/gst-plugins-good/flvdemux-ecma.diff b/recipes/gstreamer/gst-plugins-good/flvdemux-ecma.diff
new file mode 100644
index 0000000000..6def2e07fd
--- /dev/null
+++ b/recipes/gstreamer/gst-plugins-good/flvdemux-ecma.diff
@@ -0,0 +1,26 @@
+From dd82612340001e7ff821725ac257a0a36ab1fea7 Mon Sep 17 00:00:00 2001
+From: Jan UrbaƄski <wulczer@wulczer.org>
+Date: Mon, 09 Nov 2009 11:17:34 +0000
+Subject: flvmux: properly finish the ECMA array
+
+The ECMA array with the file index was missing a mandatory end marker.
+Fixes bug #601242.
+---
+diff --git a/gst/flv/gstflvmux.c b/gst/flv/gstflvmux.c
+index 89e8279..e1cb143 100644
+--- a/gst/flv/gstflvmux.c
++++ b/gst/flv/gstflvmux.c
+@@ -1060,6 +1060,11 @@ gst_flv_mux_write_index (GstFlvMux * mux)
+ }
+ script_tag = gst_buffer_join (script_tag, tmp);
+
++ tmp = gst_buffer_new_and_alloc (3);
++ data = GST_BUFFER_DATA (tmp);
++ GST_WRITE_UINT24_BE (data, 9); /* finish the ECMA array */
++ script_tag = gst_buffer_join (script_tag, tmp);
++
+ tmp = gst_buffer_new_and_alloc (4);
+ data = GST_BUFFER_DATA (tmp);
+ GST_WRITE_UINT32_BE (data, GST_BUFFER_SIZE (script_tag));
+--
+cgit v0.8.3-6-g21f6
diff --git a/recipes/gstreamer/gst-plugins-good_0.10.17.bb b/recipes/gstreamer/gst-plugins-good_0.10.17.bb
new file mode 100644
index 0000000000..78191f9715
--- /dev/null
+++ b/recipes/gstreamer/gst-plugins-good_0.10.17.bb
@@ -0,0 +1,14 @@
+require gst-plugins.inc
+
+SRC_URI += "file://flvdemux-ecma.diff;patch=1 \
+"
+
+PR = "r1"
+
+inherit gconf
+
+DEPENDS += "libsoup-2.4 flac gst-plugins-base openssl popt esound"
+
+PACKAGES =+ "gst-plugin-gconfelements"
+FILES_gst-plugin-gconfelements += "${sysconfdir}/gconf"
+