aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-10-12 06:55:02 -0700
committerTom Rini <tom_rini@mentor.com>2010-10-12 06:58:34 -0700
commitb6e9c76028d1efdef616af2e22bf9dc80a5a1080 (patch)
treed8bf7b372a753735fbd21a2efbec8b21fd7b6bae
parent0946177ef3e91cbb6dd1c62063911a2bb68d3c4f (diff)
downloadopenembedded-b6e9c76028d1efdef616af2e22bf9dc80a5a1080.tar.gz
freetype: Add 2.4.3
This fixes a number of security issues over previous versions including CVE-2010-3054 and CVE-2010-3311 Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/freetype/freetype-2.4.3/fix-configure.patch13
-rw-r--r--recipes/freetype/freetype-2.4.3/libtool-tag.patch20
-rw-r--r--recipes/freetype/freetype_2.4.3.bb40
3 files changed, 73 insertions, 0 deletions
diff --git a/recipes/freetype/freetype-2.4.3/fix-configure.patch b/recipes/freetype/freetype-2.4.3/fix-configure.patch
new file mode 100644
index 0000000000..ecd96738d4
--- /dev/null
+++ b/recipes/freetype/freetype-2.4.3/fix-configure.patch
@@ -0,0 +1,13 @@
+Index: freetype-2.3.6/builds/unix/configure.ac
+===================================================================
+--- freetype-2.3.6.orig/builds/unix/configure.ac
++++ freetype-2.3.6/builds/unix/configure.ac
+@@ -506,8 +506,6 @@ AC_SUBST([FT2_EXTRA_LIBS])
+ AC_SUBST([SYSTEM_ZLIB])
+
+
+-LT_INIT(win32-dll)
+-
+ AC_SUBST([hardcode_libdir_flag_spec])
+ AC_SUBST([wl])
+ AC_SUBST([build_libtool_libs])
diff --git a/recipes/freetype/freetype-2.4.3/libtool-tag.patch b/recipes/freetype/freetype-2.4.3/libtool-tag.patch
new file mode 100644
index 0000000000..2f096cdd46
--- /dev/null
+++ b/recipes/freetype/freetype-2.4.3/libtool-tag.patch
@@ -0,0 +1,20 @@
+--- freetype-2.3.6/builds/unix/unix-cc.in
++++ freetype-2.3.6/builds/unix/unix-cc.in
+@@ -88,7 +88,7 @@
+ #
+ #
+ CCraw := $(CC)
+-CC := $(LIBTOOL) --mode=compile $(CCraw)
++CC := $(LIBTOOL) --tag=CC --mode=compile $(CCraw)
+
+ # Linker flags.
+ #
+@@ -105,7 +105,7 @@
+
+ # Library linking
+ #
+-LINK_LIBRARY = $(LIBTOOL) --mode=link $(CCraw) -o $@ $(OBJECTS_LIST) \
++LINK_LIBRARY = $(LIBTOOL) --tag=CC --mode=link $(CCraw) -o $@ $(OBJECTS_LIST) \
+ -rpath $(libdir) -version-info $(version_info) \
+ $(LDFLAGS) -no-undefined \
+ # -export-symbols $(EXPORTS_LIST)
diff --git a/recipes/freetype/freetype_2.4.3.bb b/recipes/freetype/freetype_2.4.3.bb
new file mode 100644
index 0000000000..90a0fe8c49
--- /dev/null
+++ b/recipes/freetype/freetype_2.4.3.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Freetype font rendering library"
+SECTION = "libs"
+LICENSE = "freetype GPLv2"
+PR = "r0"
+DEPENDS = "zlib"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
+ file://no-hardcode.patch \
+ file://fix-configure.patch \
+ file://libtool-tag.patch \
+"
+S = "${WORKDIR}/freetype-${PV}"
+
+SRC_URI[md5sum] = "75ac7082bde7b3805dc5d6bc806fa045"
+SRC_URI[sha256sum] = "b4e626db62fd1b4549ff5d57f5eca3a41631fd6066adf8a31c11879b51249afc"
+
+inherit autotools pkgconfig binconfig
+
+LIBTOOL = "${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
+
+do_configure() {
+ cd builds/unix
+ libtoolize --force --copy
+ gnu-configize --force
+ aclocal -I .
+ autoconf
+ cd ${S}
+ oe_runconf
+}
+
+do_compile_prepend() {
+ ${BUILD_CC} -o objs/apinames src/tools/apinames.c
+}
+
+BBCLASSEXTEND = "native"
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}"