aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-10-11 20:50:06 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-11 20:50:06 +0000
commitb3b8929c730b91d68f4a90dc5305c504bcd11bd4 (patch)
tree28831bb0a9c6d9790f3067e3149c180b1b877768
parente48bde5b27f910fc432e55fbb5c19eea678272fa (diff)
downloadopenembedded-b3b8929c730b91d68f4a90dc5305c504bcd11bd4.tar.gz
add python-pygame 1.7.1, closes bug #387
-rw-r--r--packages/python/python-pygame-1.7.1/.mtn2git_empty0
-rw-r--r--packages/python/python-pygame-1.7.1/Setup57
-rw-r--r--packages/python/python-pygame-1.7.1/qpe.patch37
-rw-r--r--packages/python/python-pygame_1.7.1.bb20
4 files changed, 114 insertions, 0 deletions
diff --git a/packages/python/python-pygame-1.7.1/.mtn2git_empty b/packages/python/python-pygame-1.7.1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-pygame-1.7.1/.mtn2git_empty
diff --git a/packages/python/python-pygame-1.7.1/Setup b/packages/python/python-pygame-1.7.1/Setup
new file mode 100644
index 0000000000..c4558b39bb
--- /dev/null
+++ b/packages/python/python-pygame-1.7.1/Setup
@@ -0,0 +1,57 @@
+#This Setup file is used by the setup.py script to configure the
+#python extensions. You will likely use the "config.py" which will
+#build a correct Setup file for you based on your system settings.
+#If not, the format is simple enough to edit by hand. First change
+#the needed commandline flags for each dependency, then comment out
+#any unavailable optional modules in the first optional section.
+
+#SDL = ???
+
+FONT = -lSDL_ttf-2.0
+IMAGE = -lSDL_image-1.2
+MIXER = -lSDL_mixer-1.2
+SMPEG = -lsmpeg $(SDL)
+NUMERIC = -I.
+
+
+
+#the following modules are optional. you will want to compile
+#everything you can, but you can ignore ones you don't have
+#dependencies for, just comment them out
+
+imageext src/imageext.c $(SDL) $(IMAGE)
+font src/font.c $(SDL) $(FONT)
+mixer src/mixer.c $(SDL) $(MIXER)
+mixer_music src/music.c $(SDL) $(MIXER)
+movie src/movie.c $(SDL) $(SMPEG)
+surfarray src/surfarray.c $(SDL) $(NUMERIC)
+sndarray src/sndarray.c $(SDL) $(NUMERIC) $(MIXER)
+
+
+
+#these modules are required for pygame to run. they only require
+#SDL as a dependency. these should not be altered
+
+base src/base.c $(SDL)
+cdrom src/cdrom.c $(SDL)
+constants src/constants.c $(SDL)
+display src/display.c $(SDL)
+event src/event.c $(SDL)
+key src/key.c $(SDL)
+mouse src/mouse.c $(SDL)
+rect src/rect.c $(SDL)
+rwobject src/rwobject.c $(SDL)
+surface src/surface.c src/alphablit.c $(SDL)
+surflock src/surflock.c $(SDL)
+time src/time.c $(SDL)
+joystick src/joystick.c $(SDL)
+draw src/draw.c $(SDL)
+image src/image.c $(SDL)
+transform src/transform.c src/rotozoom.c src/scale2x.c $(SDL)
+
+
+#the following are placeholders. setup.py can use them to help
+#auto-copy needed DLLs into the pygame installation folder.
+#you can simply ignore these lines under non-windows, no need to
+#comment out.
+COPYLIB_smpeg $(SDL) $(SMPEG)
diff --git a/packages/python/python-pygame-1.7.1/qpe.patch b/packages/python/python-pygame-1.7.1/qpe.patch
new file mode 100644
index 0000000000..b4d3c01a2f
--- /dev/null
+++ b/packages/python/python-pygame-1.7.1/qpe.patch
@@ -0,0 +1,37 @@
+--- ./src/base.c~qpe.patch 2003-10-16 15:43:22.000000000 +0930
++++ ./src/base.c 2004-05-11 02:09:14.000000000 +0930
+@@ -37,6 +37,12 @@
+ #include<windows.h>
+ extern int SDL_RegisterApp(char*, Uint32, void*);
+ #endif
++#ifdef QWS
++
++int SDL_main(int argc, char *argv[]) { return 0; };
++
++extern void initQCop(int argc, char *argv[]);
++#endif
+
+ #if defined(macintosh)
+ #if(!defined(__MWERKS__) && !TARGET_API_MAC_CARBON)
+@@ -691,7 +697,10 @@
+ {
+ PyObject *module, *dict, *apiobj;
+ static void* c_api[PYGAMEAPI_BASE_NUMSLOTS];
+-
++#ifdef QWS
++ char *args[] = {"pygame", NULL};
++#endif
++
+ /* create the module */
+ module = Py_InitModule3("base", init__builtins__, doc_pygame_MODULE);
+ dict = PyModule_GetDict(module);
+@@ -722,6 +731,9 @@
+ /*some intiialization*/
+ Py_AtExit(atexit_quit);
+ install_parachute();
++#ifdef QWS
++ initQCop(1, args);
++#endif
+ #ifdef MS_WIN32
+ SDL_RegisterApp("pygame", 0, GetModuleHandle(NULL));
+ #endif
diff --git a/packages/python/python-pygame_1.7.1.bb b/packages/python/python-pygame_1.7.1.bb
new file mode 100644
index 0000000000..429ae6fdf8
--- /dev/null
+++ b/packages/python/python-pygame_1.7.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Python libSDL Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "LGPL"
+RDEPENDS = "python-core python-numeric libsdl-x11"
+DEPENDS = "virtual/libsdl libsdl-image libsdl-mixer libsdl-net libsdl-ttf smpeg python-numeric"
+SRCNAME = "pygame"
+
+SRC_URI = "http://www.pygame.org/ftp/${SRCNAME}-${PV}release.tar.gz \
+ file://qpe.patch;patch=1 \
+ file://Setup"
+S = "${WORKDIR}/${SRCNAME}-${PV}release"
+
+inherit distutils
+
+do_configure_prepend() {
+ SDL="`sdl-config --cflags` `sdl-config --libs`"; echo "SDL=$SDL" >Setup
+ cat ${WORKDIR}/Setup >>Setup
+}