aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Heinold <h.heinold@tarent.de>2011-03-14 17:12:45 +0100
committerSteffen Sledz <sledz@dresearch-fe.de>2011-04-29 14:08:22 +0200
commitb018efaf367f2be1cf2eee43e01d2b7664d9e7b5 (patch)
tree627ea33cadc7cb985bb42f012270a12dc42985cc
parent1d665487ebff2803f2f1403572fbf2f195fc3003 (diff)
downloadopenembedded-b018efaf367f2be1cf2eee43e01d2b7664d9e7b5.tar.gz
openjdk: use qemu now for the awt sizer binary too
* bump INC_PR Signed-off-by: Henning Heinold <h.heinold@tarent.de> Signed-off-by: Stefan Schmidt <stefan@buglabs.net>
-rw-r--r--recipes/openjdk/openjdk-6-6b18-1.8/icedtea-crosscompile-fix.patch24
-rw-r--r--recipes/openjdk/openjdk-6-common.inc8
2 files changed, 14 insertions, 18 deletions
diff --git a/recipes/openjdk/openjdk-6-6b18-1.8/icedtea-crosscompile-fix.patch b/recipes/openjdk/openjdk-6-6b18-1.8/icedtea-crosscompile-fix.patch
index ec0f259e8c..652f7ac180 100644
--- a/recipes/openjdk/openjdk-6-6b18-1.8/icedtea-crosscompile-fix.patch
+++ b/recipes/openjdk/openjdk-6-6b18-1.8/icedtea-crosscompile-fix.patch
@@ -73,17 +73,6 @@ Index: openjdk/jdk/make/sun/xawt/Makefile
endif
ifeq ($(PLATFORM), solaris)
-@@ -237,7 +238,9 @@
- $(BOOT_JAVA_CMD) -cp $(WRAPPER_GENERATOR_TEMPDIR) WrapperGenerator \
- $(SIZER_DIR) $(XLIBTYPES) "sizer" $(subst .,,$(suffix $(basename $@)))
-
--$(SIZES): $(SIZERS)
-+#$(SIZES): $(SIZERS)
-+# Prevent binaries being created. Instead take what is available.
-+$(SIZES):
- @if [ "$(DOHACK)$@" = "true$(PREDEFINED_SIZES)" ]; then \
- $(ECHO) COPYING $(PREDEFINED_SIZES_TMPL) into $@; \
- $(CP) $(PREDEFINED_SIZES_TMPL) $@; \
Index: openjdk/hotspot/make/linux/makefiles/vm.make
===================================================================
--- openjdk.orig/hotspot/make/linux/makefiles/vm.make 2009-01-24 17:54:57.000000000 +0100
@@ -212,3 +201,16 @@ Index: openjdk/hotspot/make/linux/makefiles/launcher.make
LIBS_LAUNCHER += -l$(JVM) $(LIBS) -lstdc++
endif
+Index: icedtea6-1.8.5/build/openjdk/jdk/make/sun/xawt/Makefile
+===================================================================
+--- openjdk/jdk/make/sun/xawt/Makefile 2011-03-14 14:17:03.926207269 +0100
++++ openjdk/jdk/make/sun/xawt/Makefile 2011-03-14 14:30:11.956186631 +0100
+@@ -245,7 +245,7 @@
+ $(CHMOD) +w $@;\
+ else \
+ $(ECHO) GENERATING $@; \
+- $(WRAPPER_GENERATOR_DIR)/sizer$(suffix $@) > $@; \
++ $(QEMU) $(WRAPPER_GENERATOR_DIR)/sizer$(suffix $@) > $@; \
+ fi
+ @if [ "$(DOCOMPARE)$(suffix $@)" = "true.64" ]; then \
+ $(ECHO) COMPARING $@ and $(STORED_SIZES_TMPL_$(PLATFORM)_$(LIBARCH)); \
diff --git a/recipes/openjdk/openjdk-6-common.inc b/recipes/openjdk/openjdk-6-common.inc
index f04800b0b4..54c45f84de 100644
--- a/recipes/openjdk/openjdk-6-common.inc
+++ b/recipes/openjdk/openjdk-6-common.inc
@@ -10,7 +10,7 @@ ICEDTEA = "NEEDS TO BE SET"
S = "${WORKDIR}/${ICEDTEA}"
B = "${S}/build"
-INC_PR = "r10"
+INC_PR = "r11"
SRC_URI = "\
${ICEDTEA_URI} \
@@ -288,12 +288,6 @@ addtask compilestepone after do_configure before do_compilesteptwo
do_compilesteptwo() {
echo "2/3 Building bootstrap JDK"
- # Take pre-generated binaries from -native build
- install -d generated/sun/awt/X11/generator
- ln -sf ${STAGING_LIBDIR_JVM_NATIVE}/icedtea6-native/generated/sizer.32 generated/sun/awt/X11/generator/sizer.32
- install -d openjdk/${BUILD_DIR}/gensrc/sun/awt/X11/generator
- ln -sf ${STAGING_LIBDIR_JVM_NATIVE}/icedtea6-native/generated/sizer.32 openjdk/${BUILD_DIR}/gensrc/sun/awt/X11/generator/sizer.32
-
# Now cross-compile bootstrap JDK
rm stamps/icedtea-against-ecj.stamp stamps/icedtea-ecj.stamp || true
oe_runmake icedtea-against-ecj