aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-03-28 13:34:36 +0100
committerKoen Kooi <koen@openembedded.org>2009-03-28 13:34:36 +0100
commitadc3749d8ca13c9983f3a0706092b62c6c52c0ab (patch)
treede2543c27d947a528606daee27cd14167c5f65b1
parent5b6bb392f249d2d9fe6b3f8a2a5d29d507eb8e49 (diff)
downloadopenembedded-adc3749d8ca13c9983f3a0706092b62c6c52c0ab.tar.gz
webkit-gtk: bump SRCREV
* runtime tested on beagleboard with midori and epiphany
-rw-r--r--conf/distro/include/sane-srcrevs.inc2
-rw-r--r--recipes/webkit/webkit-gtk/GNUmakefile.am42
-rw-r--r--recipes/webkit/webkit-gtk/configure.ac3
-rw-r--r--recipes/webkit/webkit-gtk_svn.bb2
4 files changed, 33 insertions, 16 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index 9e185a6279..53a39637dc 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -233,7 +233,7 @@ SRCREV_pn-uclibc-initial ?= "25712"
SRCREV_pn-usbpath ?= "3172"
SRCREV_pn-usbpath-native ?= "3172"
SRCREV_pn-vala-terminal ?= "94117f453ce884e9c30b611fae6fc19f85f98f2b"
-SRCREV_pn-webkit-gtk ?= "41827"
+SRCREV_pn-webkit-gtk ?= "42069"
SRCREV_pn-wlan-ng-modules ?= "1859"
SRCREV_pn-wlan-ng-utils ?= "1859"
SRCREV_pn-wmiconfig ?= "4522"
diff --git a/recipes/webkit/webkit-gtk/GNUmakefile.am b/recipes/webkit/webkit-gtk/GNUmakefile.am
index 9e97e67387..13cf5eefa1 100644
--- a/recipes/webkit/webkit-gtk/GNUmakefile.am
+++ b/recipes/webkit/webkit-gtk/GNUmakefile.am
@@ -47,6 +47,8 @@ lib_LIBRARIES :=
IDL_BINDINGS :=
+TEST_PROGS :=
+
# Global flags to CPP
global_cppflags :=
@@ -463,29 +465,43 @@ include JavaScriptCore/GNUmakefile.am
include WebCore/GNUmakefile.am
include WebKitTools/GNUmakefile.am
-# Build unit test
-noinst_PROGRAMS += Programs/UnitTests
-Programs_UnitTests_CPPFLAGS = \
- -I$(srcdir)/WebKit/gtk \
- -I$(top_builddir)/WebKit/gtk \
- $(global_cppflags) \
- $(javascriptcore_cppflags)
-
-Programs_UnitTests_SOURCES = \
- WebKit/gtk/tests/main.c
+# Build unit tests
+noinst_PROGRAMS += $(TEST_PROGS)
-Programs_UnitTests_CFLAGS = \
+webkit_tests_cflags = \
-fno-strict-aliasing \
-O2 \
+ -I$(srcdir)/JavaScriptCore/ForwardingHeaders \
+ -I$(srcdir)/WebKit/gtk \
+ -I$(top_builddir)/WebKit/gtk \
$(global_cflags) \
$(GLIB_CFLAGS) \
$(GTK_CFLAGS) \
$(LIBSOUP_CFLAGS)
-Programs_UnitTests_LDADD = \
+webkit_tests_ldadd = \
libwebkit-1.0.la \
$(GTK_LIBS) \
- $(GLIB_LIBS)
+ $(GLIB_LIBS) \
+ $(LIBSOUP_LIBS)
+
+TEST_PROGS += Programs/unittests/testwebframe \
+ Programs/unittests/testwebbackforwardlist \
+ Programs/unittests/testwebhistoryitem
+
+# Add additional tests here
+Programs_unittests_testwebframe_SOURCES = WebKit/gtk/tests/testwebframe.c
+Programs_unittests_testwebframe_CFLAGS = $(webkit_tests_cflags)
+Programs_unittests_testwebframe_LDADD = $(webkit_tests_ldadd)
+
+Programs_unittests_testwebbackforwardlist_SOURCES = WebKit/gtk/tests/testwebbackforwardlist.c
+Programs_unittests_testwebbackforwardlist_CFLAGS = $(webkit_tests_cflags)
+Programs_unittests_testwebbackforwardlist_LDADD = $(webkit_tests_ldadd)
+
+Programs_unittests_testwebhistoryitem_SOURCES = WebKit/gtk/tests/testwebhistoryitem.c
+Programs_unittests_testwebhistoryitem_CFLAGS = $(webkit_tests_cflags)
+Programs_unittests_testwebhistoryitem_LDADD = $(webkit_tests_ldadd)
+
# Autogenerated sources
BUILT_SOURCES := \
diff --git a/recipes/webkit/webkit-gtk/configure.ac b/recipes/webkit/webkit-gtk/configure.ac
index 2535c3181f..ad13dea585 100644
--- a/recipes/webkit/webkit-gtk/configure.ac
+++ b/recipes/webkit/webkit-gtk/configure.ac
@@ -190,6 +190,7 @@ LIBSOUP_REQUIRED_VERSION=2.25.91
LIBXSLT_REQUIRED_VERSION=1.1.7
SQLITE_REQUIRED_VERSION=3.0
GSTREAMER_REQUIRED_VERSION=0.10
+GNOME_KEYRING_REQUIRED_VERSION=2.26.0
# Available modules
#
@@ -529,7 +530,7 @@ AC_SUBST([LIBSOUP_LIBS])
if test "$enable_gnomekeyring" = "yes"; then
PKG_CHECK_MODULES([GNOMEKEYRING],
- [gnome-keyring-1])
+ [gnome-keyring-1 >= $GNOME_KEYRING_REQUIRED_VERSION])
AC_SUBST([GNOMEKEYRING_CFLAGS])
AC_SUBST([GNOMEKEYRING_LIBS])
fi
diff --git a/recipes/webkit/webkit-gtk_svn.bb b/recipes/webkit/webkit-gtk_svn.bb
index 729011515e..49b1590733 100644
--- a/recipes/webkit/webkit-gtk_svn.bb
+++ b/recipes/webkit/webkit-gtk_svn.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "WebKit browser engine, GTK+ edition"
-DEPENDS = "libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs bison-native flex-native gperf-native perl-native sqlite3"
+DEPENDS = "gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs bison-native flex-native gperf-native perl-native sqlite3"
SRCREV_FORMAT = "webcore-rwebkit"