aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-02-20 08:30:44 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-02-20 08:30:44 +0000
commitab1479e869a7e78602c39487542556040d90d8d0 (patch)
tree38c3ee4bd865c5e51b54cd681de51bd74cbf6ed4
parentfbf5bf61ecfeb8c868945dcfb02a74f612eb59a4 (diff)
downloadopenembedded-ab1479e869a7e78602c39487542556040d90d8d0.tar.gz
bash: unified, bumped PR
-rw-r--r--packages/bash/bash.inc26
-rw-r--r--packages/bash/bash_3.0.bb29
-rw-r--r--packages/bash/bash_3.2.bb28
3 files changed, 30 insertions, 53 deletions
diff --git a/packages/bash/bash.inc b/packages/bash/bash.inc
new file mode 100644
index 0000000000..80aedfa1c8
--- /dev/null
+++ b/packages/bash/bash.inc
@@ -0,0 +1,26 @@
+DESCRIPTION = "An sh-compatible command language interpreter."
+HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+DEPENDS = "ncurses"
+SECTION = "base/shell"
+LICENSE = "GPL"
+
+inherit autotools gettext
+
+PARALLEL_MAKE = ""
+
+bindir = "/bin"
+sbindir = "/sbin"
+
+EXTRA_OECONF = "--with-ncurses"
+export CC_FOR_BUILD = "${BUILD_CC}"
+
+do_configure () {
+ gnu-configize
+ oe_runconf
+}
+
+pkg_postinst () {
+ touch ${sysconfdir}/shells
+ grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
+ grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
+}
diff --git a/packages/bash/bash_3.0.bb b/packages/bash/bash_3.0.bb
index 2a8e0ee951..b4fb26a60f 100644
--- a/packages/bash/bash_3.0.bb
+++ b/packages/bash/bash_3.0.bb
@@ -1,31 +1,6 @@
-DESCRIPTION = "An sh-compatible command language interpreter."
-HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-DEPENDS = "ncurses"
-SECTION = "base/shell"
-LICENSE = "GPL"
-PR = "r7"
+require bash.inc
+PR = "r8"
SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
file://bash-3.0-fixes.patch;patch=1 \
file://signames-mipsel.diff;patch=1"
-
-inherit autotools gettext
-
-PARALLEL_MAKE = ""
-
-bindir = "/bin"
-sbindir = "/sbin"
-
-EXTRA_OECONF = "--with-ncurses"
-export CC_FOR_BUILD = "${BUILD_CC}"
-
-do_configure () {
- gnu-configize
- oe_runconf
-}
-
-pkg_postinst () {
- touch ${sysconfdir}/shells
- grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
- grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
-}
diff --git a/packages/bash/bash_3.2.bb b/packages/bash/bash_3.2.bb
index fd59b846ed..8e0293e001 100644
--- a/packages/bash/bash_3.2.bb
+++ b/packages/bash/bash_3.2.bb
@@ -1,29 +1,5 @@
-DESCRIPTION = "An sh-compatible command language interpreter."
-HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-DEPENDS = "ncurses"
-SECTION = "base/shell"
-LICENSE = "GPL"
+require bash.inc
+PR = "r1"
SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
file://001-005.patch;patch=1"
-
-inherit autotools gettext
-
-PARALLEL_MAKE = ""
-
-bindir = "/bin"
-sbindir = "/sbin"
-
-EXTRA_OECONF = "--with-ncurses"
-export CC_FOR_BUILD = "${BUILD_CC}"
-
-do_configure () {
- gnu-configize
- oe_runconf
-}
-
-pkg_postinst () {
- touch ${sysconfdir}/shells
- grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
- grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
-}