aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-10-15 10:26:32 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-10-15 10:26:32 +0000
commita26698073274f809944440567063402a5f81bd5e (patch)
treec1e3ef420599fb85efbbc60eb8bf000f648b135f
parent880a9136bf136a6d76086a68d711e7f3b310eb10 (diff)
downloadopenembedded-a26698073274f809944440567063402a5f81bd5e.tar.gz
packages/usbpath/* : add usbpath library and add is as DEPENDS to
dfu-util
-rw-r--r--packages/dfu-util/dfu-util-native_svn.bb2
-rw-r--r--packages/dfu-util/dfu-util_svn.bb2
-rw-r--r--packages/usbpath/.mtn2git_empty0
-rw-r--r--packages/usbpath/usbpath-native_svn.bb7
-rw-r--r--packages/usbpath/usbpath_svn.bb17
5 files changed, 26 insertions, 2 deletions
diff --git a/packages/dfu-util/dfu-util-native_svn.bb b/packages/dfu-util/dfu-util-native_svn.bb
index 9bfe4bae2c..457094df9e 100644
--- a/packages/dfu-util/dfu-util-native_svn.bb
+++ b/packages/dfu-util/dfu-util-native_svn.bb
@@ -2,7 +2,7 @@ require dfu-util_${PV}.bb
inherit native
-DEPENDS = "libusb-native"
+DEPENDS = "libusb-native usbpath-native"
do_stage() {
install -d ${STAGING_BINDIR_NATIVE}
diff --git a/packages/dfu-util/dfu-util_svn.bb b/packages/dfu-util/dfu-util_svn.bb
index 9be5b92979..1f34a5bc24 100644
--- a/packages/dfu-util/dfu-util_svn.bb
+++ b/packages/dfu-util/dfu-util_svn.bb
@@ -5,7 +5,7 @@ LICENSE = "GPL"
PV = "0.1+svnr${SRCREV}"
PR = "r0"
-DEPENDS = "libusb"
+DEPENDS = "libusb usbpath"
SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=dfu-util;proto=http"
S = "${WORKDIR}/dfu-util"
diff --git a/packages/usbpath/.mtn2git_empty b/packages/usbpath/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/usbpath/.mtn2git_empty
diff --git a/packages/usbpath/usbpath-native_svn.bb b/packages/usbpath/usbpath-native_svn.bb
new file mode 100644
index 0000000000..0cfafa2942
--- /dev/null
+++ b/packages/usbpath/usbpath-native_svn.bb
@@ -0,0 +1,7 @@
+require usbpath_svn.bb
+inherit native
+
+do_stage () {
+ autotools_stage_all
+}
+
diff --git a/packages/usbpath/usbpath_svn.bb b/packages/usbpath/usbpath_svn.bb
new file mode 100644
index 0000000000..95c02c94ef
--- /dev/null
+++ b/packages/usbpath/usbpath_svn.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Convert the physical locations of a USB device to/from its number"
+AUTHOR = "Werner Almesberger <werner@openmoko.org>"
+SECTION = "console/utils"
+LICENSE = "GPL"
+
+PV = "0.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/host;module=usbpath;proto=http"
+
+S = "${WORKDIR}/usbpath"
+
+inherit autotools
+
+do_stage () {
+ autotools_stage_all
+}
+