aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-01-05 20:30:04 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-05 20:30:04 +0000
commit9e71feca7b3463548d69d4644f859c329f579a33 (patch)
treece64287a9891526c30ecdf0a722fabc7ba65c207
parentb411fb71cc81218b0c94a73e24ee50e242e3b031 (diff)
downloadopenembedded-9e71feca7b3463548d69d4644f859c329f579a33.tar.gz
pcre: revert deletion of do_stage() applied in b50ac951745a042a4a00f8e7b81e7e785ca22851. fixes Bug #575.
-rw-r--r--packages/pcre/pcre_4.4.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/packages/pcre/pcre_4.4.bb b/packages/pcre/pcre_4.4.bb
index 3724f46f09..a3deda5da7 100644
--- a/packages/pcre/pcre_4.4.bb
+++ b/packages/pcre/pcre_4.4.bb
@@ -5,7 +5,7 @@ provides a POSIX calling interface to PCRE; the regular expressions \
themselves still follow Perl syntax and semantics. The header file for \
the POSIX-style functions is called pcreposix.h."
SECTION = "devel"
-PR = "r3"
+PR = "r4"
LICENSE = "BSD"
SRC_URI = "ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-${PV}.tar.bz2"
S = "${WORKDIR}/pcre-${PV}"
@@ -27,7 +27,10 @@ do_compile () {
}
do_stage () {
- autotools_stage_all
+ oe_libinstall -a -so libpcre ${STAGING_LIBDIR}
+ oe_libinstall -a -so libpcreposix ${STAGING_LIBDIR}
+ install -m 0644 pcre.h ${STAGING_INCDIR}/
+ install -m 0644 pcreposix.h ${STAGING_INCDIR}/
}
FILES_${PN} = "${libdir}/lib*.so*"