aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-05-30 11:33:08 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-05-30 11:33:08 +0000
commit9c510c394d3df7a8c1570af057a35c24dc0d4e0a (patch)
tree8fd4b8979229b01119cd30332503950cd4c4f927
parent036cda450a113e5c31c36517d4e9dec37d5efcfd (diff)
parent22ca208912f284149115e93658210cb3954ce42c (diff)
downloadopenembedded-9c510c394d3df7a8c1570af057a35c24dc0d4e0a.tar.gz
merge of '3b2a4c2d157c55e28c1c710b49f9431e03679512'
and '4181e4eed80d3a599e70d00eb9af3049382b8f62'
-rw-r--r--conf/machine/db1200.conf1
-rw-r--r--packages/webkit/webkit_svn.bb32
2 files changed, 25 insertions, 8 deletions
diff --git a/conf/machine/db1200.conf b/conf/machine/db1200.conf
index 5fafb0cd56..cbde602824 100644
--- a/conf/machine/db1200.conf
+++ b/conf/machine/db1200.conf
@@ -1,7 +1,6 @@
# Alchemy db1200
TARGET_ARCH = "mipsel"
-PACKAGE_ARCHS = "${TARGET_ARCH} ${MACHINE}"
PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}depmod:module-init-tools-cross"
diff --git a/packages/webkit/webkit_svn.bb b/packages/webkit/webkit_svn.bb
index 7e221f4113..bf3efb3034 100644
--- a/packages/webkit/webkit_svn.bb
+++ b/packages/webkit/webkit_svn.bb
@@ -1,9 +1,9 @@
-DEPENDS = "flex-native icu uicmoc4-native qmake2-native libxml2 sqlite3 cairo gtk+"
+DEPENDS = "flex-native gperf-native gperf perl-native curl icu uicmoc4-native qmake2-native libxml2 sqlite3 cairo gtk+"
# Yes, this is wrong...
PV = "0.0+svn${SRCDATE}"
-inherit qmake
+inherit qmake pkgconfig
SRC_URI = "\
svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
@@ -22,14 +22,32 @@ SRC_URI = "\
S = "${WORKDIR}/"
-do_configure() {
- qmake2 CONFIG+=gdk-port CONFIG-=qt CONFIG-=release CONFIG+=debug
+do_configure_append() {
+ qmake2 -spec ${QMAKESPEC} CONFIG+=gdk-port CONFIG-=qt CONFIG-=release CONFIG+=debug
mkdir -p WebKitBuilds/Debug
cd WebKitBuilds/Debug
- PWD=`pwd` qmake2 -r OUTPUT_DIR=$PWD/ CONFIG-=qt CONFIG+=gdk-port $PWD/../../WebKit.pro
+ PWD=`pwd` qmake2 -spec ${QMAKESPEC} -r OUTPUT_DIR=$PWD/ CONFIG-=qt CONFIG+=gdk-port $PWD/../../WebKit.pro
}
-do_compile() {
+do_compile_prepend() {
cd ${S}/WebKitBuilds/Debug
- oe_runmake
}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${libdir}
+ install -d ${D}${libdir}/pkgconfig
+
+ install -m 0755 ${S}/WebKitBuilds/Debug/WebKitTools/GdkLauncher/GdkLauncher ${D}${bindir}
+ cp WebKitBuilds/Debug/lib/*.so* ${D}${libdir}
+ cp WebKitBuilds/Debug/lib/*.pc ${D}${libdir}/pkgconfig/
+}
+
+
+PACKAGES =+ "webkit-gdklauncher-dbg webkit-gdklauncher"
+
+FILES_webkit-gdklauncher = "${bindir}/GdkLauncher"
+FILES_webkit-gdklauncher-dbg = "${bindir}/.debug/GdkLauncher"
+
+
+