aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Dietze <martin@the-little-red-haired-girl.org>2009-05-23 13:29:57 +0200
committerMartin Dietze <mdietze@gmail.com>2013-03-02 17:26:11 +0100
commit9ab75c72fb6497cd5e96b5ba011114db0db5007c (patch)
tree88515827fe83e81fe8587a34acca07f92500d2eb
parentb1dd28eeee473e69f46ac0de6eca602e993e37b1 (diff)
downloadopenembedded-9ab75c72fb6497cd5e96b5ba011114db0db5007c.tar.gz
perl-native: removed settings clashing with gcc 3 for nylon * Config_heavy.pl and config.sh contained the gcc flag `-Wdeclaration-after-statement' which broke the build with gcc 3, this is disabled for nylon now
-rw-r--r--recipes/perl/perl-native_5.8.8.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index e3d73845fc..57e9e1c394 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -85,5 +85,11 @@ do_stage_append() {
install $i ${STAGING_LIBDIR_NATIVE}/perl/${PV}/CORE
done
}
+do_stage_append_nylon() {
+ # get rid of definitions not supported by the gcc version we use for nylon...
+ for i in ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy.pl ${STAGING_DIR_HOST}/perl/config.sh; do
+ perl -pi -e 's/-Wdeclaration-after-statement //g' ${i}
+ done
+}
PARALLEL_MAKE = ""