aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2012-01-12 08:21:12 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2012-01-12 08:27:13 +0100
commit9231b084bbef8457a7eddd8c1df17ebfba0866cf (patch)
tree6f0b6a8dbe528c9e5697dab4c6afb35f933aa72d
parent8e7ed36b56020efed907f6c369ef8831d11545bb (diff)
downloadopenembedded-9231b084bbef8457a7eddd8c1df17ebfba0866cf.tar.gz
ntpclient: updated to 2010_365 version
Changes since ntpclient_2007_365: -- fixed type of sa_xmit_len, thanks vapier -- dropped underscores in spelling of adjtimex(2), might make uClibc happier -- include netdb.h and always define _BSD_SOURCE to get prototype for herror -- minor formatting to align with Nilsson's fork -- add -fno-strict-aliasing as needed by traditional network coding style The 2nd -- also implies our local patch is not needed any more Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
-rw-r--r--recipes/ntpclient/ntpclient_2010_365.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes/ntpclient/ntpclient_2010_365.bb b/recipes/ntpclient/ntpclient_2010_365.bb
new file mode 100644
index 0000000000..379348def7
--- /dev/null
+++ b/recipes/ntpclient/ntpclient_2010_365.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "NTP (RFC-1305) client for unix-alike computers"
+HOMEPAGE = "http://doolittle.icarus.com/ntpclient"
+AUTHOR = "Larry Doolittle <larry@doolittle.boa.org>"
+RDEPENDS_${PN} = "busybox"
+SECTION = "admin"
+LICENSE = "GPLv2"
+PR = "r0"
+# The ntpclient package uses version numbers that include an underscore :(
+PV = "2010_365"
+# ntpclient unpacks into a directory that doesn't include version info :(
+S = "${WORKDIR}/${PN}-2010"
+
+SRC_URI = "http://doolittle.icarus.com/ntpclient/ntpclient_${PV}.tar.gz \
+ file://init \
+ "
+
+INITSCRIPT_NAME = "ntpclient"
+INITSCRIPT_PARAMS = "defaults 65"
+inherit update-rc.d
+
+LDFLAGS += " -lrt "
+
+do_compile() {
+ oe_runmake ntpclient
+ oe_runmake adjtimex
+}
+
+do_install () {
+ # Install the binary and tools
+ install -D -m 0755 ${S}/ntpclient ${D}${base_sbindir}/ntpclient
+ install -D -m 0755 ${S}/adjtimex ${D}${base_sbindir}/adjtimex.${PN}
+ install -D -m 0755 ${S}/rate.awk ${D}${sbindir}/ntpclient-drift-rate.awk
+ install -D -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ntpclient
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_sbindir}/adjtimex adjtimex adjtimex.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove adjtimex adjtimex.${PN}
+}
+
+SRC_URI[md5sum] = "a64689398f2df8933ee0d8da246e9eaa"
+SRC_URI[sha256sum] = "9ad9b028385082fb804167f464e2db0a0b3d33780acd399327e64898b8fcfddd"