aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-02-28 02:55:40 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-02-28 02:55:40 +0100
commit8a013c3930d253b298da2dfb3194768f4228f735 (patch)
tree0e5eacc8615f0a0ce319a0b02ca5867fef78a21b
parentbdca7e76ccdb11216381e72d158d502bbc536155 (diff)
downloadopenembedded-8a013c3930d253b298da2dfb3194768f4228f735.tar.gz
dtn: fix packaging and constrain arm instruction set
-rw-r--r--packages/dtnrg/dtn_2.5.0.bb16
1 files changed, 13 insertions, 3 deletions
diff --git a/packages/dtnrg/dtn_2.5.0.bb b/packages/dtnrg/dtn_2.5.0.bb
index eff2e2e5b9..7dc6fc5af8 100644
--- a/packages/dtnrg/dtn_2.5.0.bb
+++ b/packages/dtnrg/dtn_2.5.0.bb
@@ -3,7 +3,10 @@ HOMEPAGE = "http://www.dtnrg.org/wiki"
SECTION = "libs"
DEPENDS = "db openssl python-native xerces-c"
LICENSE = "Apache"
-PR = "r4"
+PR = "r5"
+
+# thread code atomic ops do not play with thumb
+ARM_INSTRUCTION_SET = "arm"
SRC_URI = "\
http://www.dtnrg.org/docs/code/dtn_${PV}.tgz \
@@ -51,7 +54,14 @@ PACKAGES =+ "${PN}-lib"
FILES_${PN}-lib = "${libdir}/*.so*"
PACKAGES += "python-dtn"
DESCRIPTION_python-dtn = "Python bindings to the DTN API"
-PR_python-dtn = "ml3"
+PR_python-dtn = "ml4"
FILES_python-dtn = "${libdir}/${PYTHON_DIR}"
RDEPENDS_python-dtn = "python-core dtn-lib"
-FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/${PYTHON_DIR}/site-packages/.debug \
+ ${libdir}/.debug \
+ ${bindir}/.debug \
+"
+
+FILES_${PN} += "${sysconfdir}"