aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2010-02-01 12:06:36 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:16 +0200
commit88f198bb5ff7cfe1e87f822071d89aa966519a20 (patch)
treea33b31e1d719eb2b3cd3178bb88d1806cb670db4
parentc1d9b392a36f53d0d4e5e55d2d29614afce95c92 (diff)
downloadopenembedded-88f198bb5ff7cfe1e87f822071d89aa966519a20.tar.gz
meta-toolchain-dvsdk: start protoyping a 'dvsdk' style ARM toolchain + DSP toolchain
* start merging in arago dvsdk bits * convert to SOC_FAMILY * attempt to work in new package naming Signed-off-by: Koen Kooi <k-kooi@ti.com>
-rw-r--r--recipes/ti/meta-toolchain-dvsdk.bb74
-rw-r--r--recipes/ti/task-toolchain-dvsdk-host9
-rw-r--r--recipes/ti/task-toolchain-dvsdk-target21
-rw-r--r--recipes/ti/ti-staging.inc3
4 files changed, 107 insertions, 0 deletions
diff --git a/recipes/ti/meta-toolchain-dvsdk.bb b/recipes/ti/meta-toolchain-dvsdk.bb
new file mode 100644
index 0000000000..77e04aa276
--- /dev/null
+++ b/recipes/ti/meta-toolchain-dvsdk.bb
@@ -0,0 +1,74 @@
+PR = "r10"
+
+TOOLCHAIN_HOST_TASK = "task-toolchain-dvsdk-host"
+TOOLCHAIN_TARGET_TASK = "task-toolchain-dvsdk-target"
+
+require ../meta/meta-toolchain-arago.bb
+require ti-paths.inc
+
+# If we start including kernels we should change SOC_FAMILY to MACHINE_ARCH
+SDK_SUFFIX = "toolchain-dvsdk-${SOC_FAMILY}-${BUILD_ARCH}"
+
+DVSDK_TARGET_EXCLUDE_dm355 = "\
+ ti-linuxutils \
+ ti-dm355mm-module \
+ ti-codec-combo-dm355 \
+ ti-dmai-apps \
+ "
+
+DVSDK_TARGET_EXCLUDE_dm365 = "\
+ ti-linuxutils \
+ ti-dm365mm-module \
+ ti-codec-combo-dm365 \
+ ti-dmai-apps \
+ "
+
+DVSDK_TARGET_EXCLUDE_dm6446 = "\
+ ti-linuxutils \
+ ti-dsplink-module \
+ ti-codec-combo-dm6446 \
+ ti-dmai-apps \
+ "
+
+DVSDK_TARGET_EXCLUDE_dm6467 = "\
+ ti-dm355mm-module \
+ ti-dmai-apps \
+ "
+
+
+DVSDK_TARGET_EXCLUDE_omap3 = "\
+ ti-linuxutils \
+ ti-dsplink-module \
+ ti-lpm-module \
+ ti-codec-combo-omap3530 \
+ ti-dmai-apps \
+ "
+
+TOOLCHAIN_TARGET_EXCLUDE += "\
+ ${DVSDK_TARGET_EXCLUDE} \
+ "
+
+# Need to sed s/staging/sdksysroot/g
+do_populate_sdk_append() {
+ script = "${SDK_OUTPUT}/${SDKPATH}/environment-setup"
+ touch $script
+ echo 'export CODEC_INSTALL_DIR=${CODEC_INSTALL_DIR}' >> $script
+ echo 'export CODEGEN_INSTALL_DIR=${CODEGEN_INSTALL_DIR}' >> $script
+ echo 'export XDC_INSTALL_DIR=${XDC_INSTALL_DIR}' >> $script
+ echo 'export XDAIS_INSTALL_DIR=${XDAIS_INSTALL_DIR}' >> $script
+ echo 'export BIOS_INSTALL_DIR=${BIOS_INSTALL_DIR}' >> $script
+ echo 'export BIOSUTILS_INSTALL_DIR=${BIOSUTILS_INSTALL_DIR}' >> $script
+ echo 'export FC_INSTALL_DIR=${FC_INSTALL_DIR}' >> $script
+ echo 'export CE_INSTALL_DIR=${CE_INSTALL_DIR}' >> $script
+ echo 'export EDMA3_LLD_INSTALL_DIR=${EDMA3_LLD_INSTALL_DIR}' >> $script
+ echo 'export LINUXUTILS_INSTALL_DIR=${LINUXUTILS_INSTALL_DIR}' >> $script
+ echo 'export CMEM_INSTALL_DIR=${CMEM_INSTALL_DIR}' >> $script
+ echo 'export LINK_INSTALL_DIR=${LINK_INSTALL_DIR}' >> $script
+ echo 'export LPM_INSTALL_DIR=${LPM_INSTALL_DIR}' >> $script
+ echo 'export DMAI_INSTALL_DIR=${DMAI_INSTALL_DIR}' >> $script
+
+ # Repack SDK with new environment-setup
+ cd ${SDK_OUTPUT}
+ fakeroot tar cfj ${SDK_DEPLOY}/${TOOLCHAIN_OUTPUTNAME}.tar.bz2 .
+}
+
diff --git a/recipes/ti/task-toolchain-dvsdk-host b/recipes/ti/task-toolchain-dvsdk-host
new file mode 100644
index 0000000000..a4e91cc48b
--- /dev/null
+++ b/recipes/ti/task-toolchain-dvsdk-host
@@ -0,0 +1,9 @@
+require ../tasks/task-sdk-host.bb
+
+PR = "r2"
+
+DESCRIPTION = "Host packages for TI DVSDK"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+
+RDEPENDS_${PN} += ""
diff --git a/recipes/ti/task-toolchain-dvsdk-target b/recipes/ti/task-toolchain-dvsdk-target
new file mode 100644
index 0000000000..3b1eedb521
--- /dev/null
+++ b/recipes/ti/task-toolchain-dvsdk-target
@@ -0,0 +1,21 @@
+DESCRIPTION = "Target packages for TI DVSDK"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+
+PR = "r1"
+
+RDEPENDS_${PN} += " \
+ task-sdk-bare \
+ gstreamer-ti-dev \
+ ti-biosutils-sdk \
+ ti-cgt6x-sdk \
+ ti-codec-engine-sdk \
+ ti-dmai-sdk \
+ ti-dspbios-sdk \
+ ti-dsplink-module-sdk \
+ ti-framework-components-sdk \
+ ti-linuxutils-sdk \
+ ti-xdais-sdk \
+ ti-xdctools-sdk \
+ "
+
diff --git a/recipes/ti/ti-staging.inc b/recipes/ti/ti-staging.inc
index 726c0d455f..947c3835b2 100644
--- a/recipes/ti/ti-staging.inc
+++ b/recipes/ti/ti-staging.inc
@@ -2,6 +2,9 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
BASEPKG_HOST_SYS = "${MULTIMACH_HOST_SYS}"
INHIBIT_PACKAGE_STRIP = "1"
+ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY_${PN}-dev = "1"
+
PACKAGES =+ "${PN}-sdk"
FILES_${PN}-sdk = "${installdir}/*-tree"
INSANE_SKIP_${PN}-sdk = "True"