aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2007-08-08 23:07:18 +0000
committerPhilip Balister <philip@balister.org>2007-08-08 23:07:18 +0000
commit8546864754d38a632194f52d15a554c33728a554 (patch)
tree7ada4b176484b37048f70466cbefd95f4819f3cb
parentfe54cefe6eb9875b1c7db019bd3528d4398fbebc (diff)
downloadopenembedded-8546864754d38a632194f52d15a554c33728a554.tar.gz
exmap-console : Update from Poky. Builds now.
-rw-r--r--packages/exmap-console/exmap-console.inc46
-rw-r--r--packages/exmap-console/exmap-console_0.4.1.bb (renamed from packages/exmap-console/exmap-console_0.4.bb)1
-rw-r--r--packages/exmap-console/exmap-console_svn.bb5
3 files changed, 27 insertions, 25 deletions
diff --git a/packages/exmap-console/exmap-console.inc b/packages/exmap-console/exmap-console.inc
index 4c107d5f07..6744aed49f 100644
--- a/packages/exmap-console/exmap-console.inc
+++ b/packages/exmap-console/exmap-console.inc
@@ -2,60 +2,60 @@ DESCRIPTION = "Console based version of exmap, a memory usage analysis tool"
HOMEPAGE = "http://projects.o-hand.com/exmap-console"
SECTION = "devel"
LICENSE = "GPL"
-DEPENDS = "virtual/kernel"
+DEPENDS = "virtual/kernel readline"
SRC_URI = "http://projects.o-hand.com/sources/exmap-console/exmap-console-${PV}.tgz"
+TEMPPACKAGE_ARCH := "${PACKAGE_ARCH}"
+
inherit module-base
inherit autotools
MYPV := "${PV}"
+PACKAGE_ARCH = "${TEMPPACKAGE_ARCH}"
-PACKAGES += "exmap-server kernel-module-exmap"
+PACKAGES =+ "exmap-server kernel-module-exmap"
FILES_exmap-console = "${bindir}/exmap ${bindir}/exmapd"
-PACKAGE_ARCH_exmap-console = "${TARGET_ARCH}"
RDEPENDS_exmap-console += "kernel-module-exmap"
FILES_exmap-server = "${bindir}/exmapserver"
-PACKAGE_ARCH_exmap-server = "${TARGET_ARCH}"
RDEPENDS_exmap-server += "kernel-module-exmap"
FILES_kernel-module-exmap = "${base_libdir}"
PACKAGE_ARCH_kernel-module-exmap = "${MACHINE_ARCH}"
PV_kernel-module-exmap = "${MYPV}-${KERNEL_VERSION}"
-RDEPENDS_kernel-module-exmap += "kernel (${KERNEL_VERSION})"
+RDEPENDS_kernel-module-exmap += "update-modules kernel-image-${KERNEL_VERSION}"
S = "${WORKDIR}/exmap-console-${PV}"
export MODULE_PATH="${D}${base_libdir}/modules/${KERNEL_VERSION}"
do_compile() {
- cd ${S}/src
- make
-
- cd ${S}/kernel
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \
- KERNEL_SRC=${STAGING_KERNEL_DIR} \
- KERNEL_VERSION=${KERNEL_VERSION} \
- CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
- ${MAKE_TARGETS}
+ cd ${S}/src
+ make
+
+ cd ${S}/kernel
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \
+ KERNEL_SRC=${STAGING_KERNEL_DIR} \
+ KERNEL_VERSION=${KERNEL_VERSION} \
+ CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
+ ${MAKE_TARGETS}
}
do_install() {
- oe_runmake 'DESTDIR=${D}' 'DEPMOD=/bin/true' install
+ oe_runmake 'DESTDIR=${D}' 'DEPMOD=/bin/true' install
}
pkg_postinst_append_kernel-module-exmap () {
- if [ -n "$D" ]; then
- exit 1
- fi
- depmod -a
- update-modules || true
+ if [ -n "$D" ]; then
+ exit 1
+ fi
+ depmod -a
+ update-modules || true
}
pkg_postrm_append_kernel-module-exmap () {
- update-modules || true
+ update-modules || true
}
-
diff --git a/packages/exmap-console/exmap-console_0.4.bb b/packages/exmap-console/exmap-console_0.4.1.bb
index 5d89f04937..17703321e8 100644
--- a/packages/exmap-console/exmap-console_0.4.bb
+++ b/packages/exmap-console/exmap-console_0.4.1.bb
@@ -1,2 +1,3 @@
require exmap-console.inc
+PR = "r4"
diff --git a/packages/exmap-console/exmap-console_svn.bb b/packages/exmap-console/exmap-console_svn.bb
index 9e6ca80dc0..7c21222d84 100644
--- a/packages/exmap-console/exmap-console_svn.bb
+++ b/packages/exmap-console/exmap-console_svn.bb
@@ -1,5 +1,7 @@
-PR = "r10"
+require exmap-console.inc
+
PV = "0.4+svn${SRCDATE}"
+PR = "r14"
SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=exmap-console;proto=http"
@@ -7,4 +9,3 @@ S = "${WORKDIR}/exmap-console"
MYPV := "${PV}"
PV_kernel-module-exmap = "${MYPV}-${KERNEL_VERSION}"
-