aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-09-23 05:17:34 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-09-23 05:17:34 +0000
commit814166e827f34d1f94e5923b1deefe019bdeb78e (patch)
tree3583077865a4e1a18915063fb5cbf07d96ab2707
parent825f0a09e14818a2421c7b8d7a01e00c004d0d2b (diff)
downloadopenembedded-814166e827f34d1f94e5923b1deefe019bdeb78e.tar.gz
openredalert: Add patch to fix compilation with GCC 4.3.
-rw-r--r--packages/cnc/openredalert/gcc43-fix.patch13
-rw-r--r--packages/cnc/openredalert_r438.bb3
2 files changed, 16 insertions, 0 deletions
diff --git a/packages/cnc/openredalert/gcc43-fix.patch b/packages/cnc/openredalert/gcc43-fix.patch
new file mode 100644
index 0000000000..aa99d991b7
--- /dev/null
+++ b/packages/cnc/openredalert/gcc43-fix.patch
@@ -0,0 +1,13 @@
+Index: openredalert-0.0+svnr438-r0/src/misc/Compression.h
+===================================================================
+--- openredalert-0.0+svnr438-r0.orig/src/misc/Compression.h 2008-09-21 15:20:33.000000000 +0200
++++ openredalert-0.0+svnr438-r0/src/misc/Compression.h 2008-09-21 15:21:10.000000000 +0200
+@@ -20,6 +20,8 @@
+
+ #include "SDL/SDL_types.h"
+
++#include <cstring>
++
+ /**
+ * Various decompression routines for format80, format40, and
+ * format20 type graphics
diff --git a/packages/cnc/openredalert_r438.bb b/packages/cnc/openredalert_r438.bb
index 4da245614a..098f293b2e 100644
--- a/packages/cnc/openredalert_r438.bb
+++ b/packages/cnc/openredalert_r438.bb
@@ -4,8 +4,11 @@ LICENSE = "GPLv2"
DEPENDS = "virtual/libsdl libsdl-mixer"
SRC_URI = "http://openredalert.googlecode.com/files/openredalert-${PV}-src.tar.gz \
+ file://gcc43-fix.patch;patch=1 \
file://openredalert-launcher"
+PR = "r1"
+
S = "${WORKDIR}"
CFLAGS_append = " -I. -I${STAGING_INCDIR}"