aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2008-03-19 17:07:56 +0000
committerRichard Purdie <rpurdie@rpsys.net>2008-03-19 17:07:56 +0000
commit72684fc28d9e417bfeb35afcb7d7757769f6855a (patch)
tree946e0c7d1c7a12c8a41dccc4c41ddc2a6e793405
parent70ea14f38a343e24c2ab685044ec3c508bfa53cc (diff)
downloadopenembedded-72684fc28d9e417bfeb35afcb7d7757769f6855a.tar.gz
libxslt: Remove Koen's gross hack and replace with a proper patch
-rw-r--r--packages/libxslt/files/pkgconfig_fix.patch22
-rw-r--r--packages/libxslt/libxslt_1.1.22.bb11
2 files changed, 25 insertions, 8 deletions
diff --git a/packages/libxslt/files/pkgconfig_fix.patch b/packages/libxslt/files/pkgconfig_fix.patch
new file mode 100644
index 0000000000..5e4a38f0b2
--- /dev/null
+++ b/packages/libxslt/files/pkgconfig_fix.patch
@@ -0,0 +1,22 @@
+Index: libxslt-1.1.22/libexslt.pc.in
+===================================================================
+--- libxslt-1.1.22.orig/libexslt.pc.in 2008-03-19 16:52:20.000000000 +0000
++++ libxslt-1.1.22/libexslt.pc.in 2008-03-19 16:55:49.000000000 +0000
+@@ -8,5 +8,5 @@
+ Version: @LIBEXSLT_VERSION@
+ Description: EXSLT Extension library
+ Requires: libxml-2.0
+-Libs: @EXSLT_LIBDIR@ @EXSLT_LIBS@
++Libs: -lxslt @EXSLT_LIBDIR@ @M_LIBS@
+ Cflags: @EXSLT_INCLUDEDIR@
+Index: libxslt-1.1.22/libxslt.pc.in
+===================================================================
+--- libxslt-1.1.22.orig/libxslt.pc.in 2008-03-19 16:52:20.000000000 +0000
++++ libxslt-1.1.22/libxslt.pc.in 2008-03-19 16:55:38.000000000 +0000
+@@ -8,5 +8,5 @@
+ Version: @VERSION@
+ Description: XSLT library version 2.
+ Requires: libxml-2.0
+-Libs: @XSLT_LIBDIR@ @XSLT_LIBS@
++Libs: -lxslt @XSLT_LIBDIR@ @M_LIBS@
+ Cflags: @XSLT_INCLUDEDIR@
diff --git a/packages/libxslt/libxslt_1.1.22.bb b/packages/libxslt/libxslt_1.1.22.bb
index 53348becc9..86fe70dff2 100644
--- a/packages/libxslt/libxslt_1.1.22.bb
+++ b/packages/libxslt/libxslt_1.1.22.bb
@@ -3,21 +3,16 @@ SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "libxml2 (>=2.6.27)"
LICENSE = "MIT"
+PR = "r1"
-SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz"
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz \
+ file://pkgconfig_fix.patch;patch=1"
S = "${WORKDIR}/libxslt-${PV}"
inherit autotools pkgconfig
EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
-# Something is wrong inside configure.ac, so we need to resort to sed in this stage :(
-# Koen - 20080305
-do_compile_append() {
- sed -i -e s:-L${STAGING_LIBDIR}::g libexslt.pc
- sed -i -e s:-L${STAGING_LIBDIR}::g libxslt.pc
-}
-
do_stage () {
autotools_stage_all
}