aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-05-19 16:05:47 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-05-30 14:48:45 +0200
commit6d00367cc479993c552cf4cbfc5577653b833602 (patch)
tree11393a3676d49417ed853baa307aae6ac9cff8ce
parentbe18751e5ca081f1c21ede8e5b979d580f54c3e7 (diff)
downloadopenembedded-6d00367cc479993c552cf4cbfc5577653b833602.tar.gz
cornucopia: depend on libfso-glib and switch to INC_PR
-rw-r--r--recipes/freesmartphone/cornucopia.inc14
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb4
-rw-r--r--recipes/freesmartphone/fsogsmd_git.bb4
-rw-r--r--recipes/freesmartphone/libfsoframework_git.bb5
-rw-r--r--recipes/freesmartphone/libfsotransport_git.bb6
5 files changed, 33 insertions, 0 deletions
diff --git a/recipes/freesmartphone/cornucopia.inc b/recipes/freesmartphone/cornucopia.inc
new file mode 100644
index 0000000000..41d6f33084
--- /dev/null
+++ b/recipes/freesmartphone/cornucopia.inc
@@ -0,0 +1,14 @@
+DESCRIPTION = "The freesmartphone.org API reference implementation (FSO 2.0)"
+AUTHOR = "Team FSO"
+LICENSE = "LGPL"
+SECTION = "devel"
+DEPENDS = "vala-native glib-2.0 dbus dbus-glib libfso-glib"
+PV = "0.0.0.0+gitr${SRCREV}"
+INC_PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia;protocol=git;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
+inherit autotools_stage pkgconfig vala
+
+FILES_${PN} += "${sysconfdir} ${datadir}/${PN}"
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
new file mode 100644
index 0000000000..f7e12e9d63
--- /dev/null
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -0,0 +1,4 @@
+require cornucopia.inc
+inherit fso-plugin
+PR = "${INC_PR}.0"
+
diff --git a/recipes/freesmartphone/fsogsmd_git.bb b/recipes/freesmartphone/fsogsmd_git.bb
new file mode 100644
index 0000000000..f7e12e9d63
--- /dev/null
+++ b/recipes/freesmartphone/fsogsmd_git.bb
@@ -0,0 +1,4 @@
+require cornucopia.inc
+inherit fso-plugin
+PR = "${INC_PR}.0"
+
diff --git a/recipes/freesmartphone/libfsoframework_git.bb b/recipes/freesmartphone/libfsoframework_git.bb
new file mode 100644
index 0000000000..c8c9543cdc
--- /dev/null
+++ b/recipes/freesmartphone/libfsoframework_git.bb
@@ -0,0 +1,5 @@
+require cornucopia.inc
+DESCRIPTION = "freesmartphone.org support library"
+PV = "0.1.0.0+gitr${SRCREV}"
+PR = "${INC_PR}.0"
+
diff --git a/recipes/freesmartphone/libfsotransport_git.bb b/recipes/freesmartphone/libfsotransport_git.bb
new file mode 100644
index 0000000000..45abf86281
--- /dev/null
+++ b/recipes/freesmartphone/libfsotransport_git.bb
@@ -0,0 +1,6 @@
+require cornucopia.inc
+DESCRIPTION = "freesmartphone.org transport library"
+# we need posixextra.vapi
+DEPENDS += "libfsoframework"
+PV = "0.9.3+gitr${SRCREV}"
+PR = "${INC_PR}.0"