aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-02-23 21:07:19 +0000
committerTom Rini <tom_rini@mentor.com>2011-02-23 14:08:25 -0700
commit65fa94664ff9a20364f8954f7cac8a799ccf5b19 (patch)
treea0ab1b7e12583b24bb5a015be34325b388db665a
parent4f76c0e2e440f090300197a86a94f6ec2c4922d0 (diff)
downloadopenembedded-65fa94664ff9a20364f8954f7cac8a799ccf5b19.tar.gz
syslinux: add isolinux and chain packages
This syncs the package recipe with the O.S. Systems tree adding more packages and fixing GNU_HASH issues. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/syslinux/syslinux_3.82.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/recipes/syslinux/syslinux_3.82.bb b/recipes/syslinux/syslinux_3.82.bb
index f899d9f9e2..fcb066d696 100644
--- a/recipes/syslinux/syslinux_3.82.bb
+++ b/recipes/syslinux/syslinux_3.82.bb
@@ -1,5 +1,5 @@
# syslinux OE build file
-# Copyright (C) 2009, O.S. Systems Software Ltda. All Rights Reserved
+# Copyright (C) 2009, 2011, O.S. Systems Software Ltda. All Rights Reserved
# Released under the MIT license (see packages/COPYING)
DESCRIPTION = "A multi-purpose linux bootloader"
@@ -7,7 +7,7 @@ HOMEPAGE = "http://syslinux.zytor.com/"
LICENSE = "GPL"
DEPENDS = "nasm-native"
RRECOMMENDS_${PN} = "mtools"
-PR = "r0"
+PR = "r3"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
@@ -27,17 +27,20 @@ do_configure() {
do_compile() {
# Rebuild only the installer; keep precompiled bootloaders
# as per author's request (doc/distrib.txt)
- oe_runmake CC="${CC}" installer
+ oe_runmake CC="${CC}" LDFLAGS="${LDFLAGS}" installer
}
do_install() {
oe_runmake install INSTALLROOT="${D}"
}
-PACKAGES =+ "${PN}-extlinux ${PN}-mbr"
+PACKAGES =+ "${PN}-extlinux ${PN}-mbr ${PN}-chain ${PN}-pxelinux ${PN}-isolinux"
FILES_${PN} = "${bindir}/syslinux"
FILES_${PN}-extlinux = "${base_sbindir}/extlinux"
FILES_${PN}-mbr = "${datadir}/${PN}/mbr.bin"
+FILES_${PN}-chain = "${datadir}/${PN}/chain.c32"
+FILES_${PN}-isolinux = "${datadir}/${PN}/isolinux.bin"
+FILES_${PN}-pxelinux = "${datadir}/${PN}/pxelinux.0"
FILES_${PN}-dev += "${datadir}/${PN}/com32"
SRC_URI[md5sum] = "c9f4e73e385c86b3a8faf9b615a04836"