aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-09-15 17:46:17 +0000
committerKoen Kooi <koen@openembedded.org>2007-09-15 17:46:17 +0000
commit651a118bdabb0ee8f6838a7f87276e37c9ea60c2 (patch)
tree251442672bc449b402757c86ca653641d0f2a0aa
parentc9e9333ccb5a77e0966f3ef7ed716782435b55a5 (diff)
downloadopenembedded-651a118bdabb0ee8f6838a7f87276e37c9ea60c2.tar.gz
linux-ezx: more a1200 and rokre6 tweaks, also remove size check since boot_usb can handle 1MB images quite well nowadays and blob2 can flash like 1.3MB to mtd4
-rwxr-xr-xpackages/linux/linux-ezx-2.6.21/a1200/defconfig4
-rwxr-xr-xpackages/linux/linux-ezx-2.6.21/rokre6/defconfig6
-rw-r--r--packages/linux/linux-ezx_2.6.21.bb4
3 files changed, 7 insertions, 7 deletions
diff --git a/packages/linux/linux-ezx-2.6.21/a1200/defconfig b/packages/linux/linux-ezx-2.6.21/a1200/defconfig
index 3e8cba081b..3cf42ac8b1 100755
--- a/packages/linux/linux-ezx-2.6.21/a1200/defconfig
+++ b/packages/linux/linux-ezx-2.6.21/a1200/defconfig
@@ -590,9 +590,9 @@ CONFIG_MTD_PHYSMAP_BANKWIDTH=2
# CONFIG_MTD_ARM_INTEGRATOR is not set
# CONFIG_MTD_SHARP_SL is not set
CONFIG_MTD_EZX=y
-# CONFIG_MTD_EZX_A780 is not set
+CONFIG_MTD_EZX_A780=y
# CONFIG_MTD_EZX_A780_ALTERNATE is not set
-CONFIG_MTD_EZX_A1200=y
+# CONFIG_MTD_EZX_A120 is not set
# CONFIG_MTD_EZX_E2 is not set
# CONFIG_MTD_EZX_E6 is not set
# CONFIG_MTD_PLATRAM is not set
diff --git a/packages/linux/linux-ezx-2.6.21/rokre6/defconfig b/packages/linux/linux-ezx-2.6.21/rokre6/defconfig
index 10c1207f1e..7a203fa0a7 100755
--- a/packages/linux/linux-ezx-2.6.21/rokre6/defconfig
+++ b/packages/linux/linux-ezx-2.6.21/rokre6/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.21.4
-# Sat Sep 15 18:27:06 2007
+# Sat Sep 15 19:35:32 2007
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -590,11 +590,11 @@ CONFIG_MTD_PHYSMAP_BANKWIDTH=2
# CONFIG_MTD_ARM_INTEGRATOR is not set
# CONFIG_MTD_SHARP_SL is not set
CONFIG_MTD_EZX=y
-# CONFIG_MTD_EZX_A780 is not set
+CONFIG_MTD_EZX_A780=y
# CONFIG_MTD_EZX_A780_ALTERNATE is not set
# CONFIG_MTD_EZX_A1200 is not set
# CONFIG_MTD_EZX_E2 is not set
-CONFIG_MTD_EZX_E6=y
+# CONFIG_MTD_EZX_E6 is not set
# CONFIG_MTD_PLATRAM is not set
#
diff --git a/packages/linux/linux-ezx_2.6.21.bb b/packages/linux/linux-ezx_2.6.21.bb
index 7a2d3a47dd..cf0f246ecc 100644
--- a/packages/linux/linux-ezx_2.6.21.bb
+++ b/packages/linux/linux-ezx_2.6.21.bb
@@ -4,7 +4,7 @@ AUTHOR = "Harald Welte and the OpenEZX Team <openezx-devel@lists.openezx.org>"
HOMEPAGE = "http://www.openezx.org"
LICENSE = "GPL"
EZX = "ezxdev"
-PR = "${EZX}-r14"
+PR = "${EZX}-r15"
inherit kernel
@@ -105,7 +105,7 @@ CMDLINE = "${CMDLINE_CON} ${CMDLINE_ROOT} ${CMDLINE_IP} ${CMDLINE_ROTATE} ${CMDL
do_compile_append() {
size=`ls -l arch/${ARCH}/boot/${KERNEL_IMAGETYPE} | awk '{ print $5}'`
if [ $size -ge 1294336 ]; then
- rm arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
+ #rm arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
echo "Size is $size"
echo "This kernel is too big for your EZX Phone. Please reduce the size of the kernel by making more of it modular."
fi