aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2007-04-08 04:26:58 +0000
committerMike Westerhof <mwester@dls.net>2007-04-08 04:26:58 +0000
commit5e75001f1c266439ce726d9b748a46b8b13107ec (patch)
tree6ba1c68caf63cb60613fe2886090864397adbaa9
parent1ce6ac86a2d0568b6522a850a41816abdf56e82b (diff)
downloadopenembedded-5e75001f1c266439ce726d9b748a46b8b13107ec.tar.gz
autofs: Fix funky (and unnecessary) sort option in the auto.net script,
and add support for SlugOS to the init.d/autofs script.
-rw-r--r--packages/autofs/autofs-4.1.4/auto.net-sort-option-fix.patch11
-rw-r--r--packages/autofs/autofs-4.1.4/autofs-additional-distros.patch12
-rw-r--r--packages/autofs/autofs_4.1.4.bb6
3 files changed, 28 insertions, 1 deletions
diff --git a/packages/autofs/autofs-4.1.4/auto.net-sort-option-fix.patch b/packages/autofs/autofs-4.1.4/auto.net-sort-option-fix.patch
new file mode 100644
index 0000000000..680e6ce4fc
--- /dev/null
+++ b/packages/autofs/autofs-4.1.4/auto.net-sort-option-fix.patch
@@ -0,0 +1,11 @@
+--- autofs-4.1.4/samples/auto.net~ 2005-04-05 08:02:09.000000000 -0500
++++ autofs-4.1.4/samples/auto.net 2007-04-07 14:41:19.000000000 -0500
+@@ -37,7 +37,7 @@
+ # Newer distributions get this right
+ SHOWMOUNT="$SMNT --no-headers -e $key"
+
+-$SHOWMOUNT | LC_ALL=C sort +0 | \
++$SHOWMOUNT | LC_ALL=C sort | \
+ awk -v key="$key" -v opts="$opts" -- '
+ BEGIN { ORS=""; first=1 }
+ { if (first) { print opts; first=0 }; print " \\\n\t" $1, key ":" $1 }
diff --git a/packages/autofs/autofs-4.1.4/autofs-additional-distros.patch b/packages/autofs/autofs-4.1.4/autofs-additional-distros.patch
new file mode 100644
index 0000000000..2b1af584b3
--- /dev/null
+++ b/packages/autofs/autofs-4.1.4/autofs-additional-distros.patch
@@ -0,0 +1,12 @@
+--- autofs-4.1.4/samples/rc.autofs.in~ 2005-04-11 06:30:54.000000000 -0500
++++ autofs-4.1.4/samples/rc.autofs.in 2007-04-07 13:18:44.000000000 -0500
+@@ -43,6 +43,9 @@
+ system=debian
+ elif [ -f /etc/redhat-release ]; then
+ system=redhat
++elif [ -f /etc/issue ] && grep -q "^SlugOS" /etc/issue ; then
++ # SlugOS behaves like Debian, at least for autofs purposes.
++ system=debian
+ else
+ echo "$0: Unknown system, please port and contact autofs@linux.kernel.org" 1>&2
+ exit 1
diff --git a/packages/autofs/autofs_4.1.4.bb b/packages/autofs/autofs_4.1.4.bb
index 128c24e296..ab2bacedb7 100644
--- a/packages/autofs/autofs_4.1.4.bb
+++ b/packages/autofs/autofs_4.1.4.bb
@@ -2,13 +2,17 @@ DESCRIPTION = "Kernel based automounter for linux."
SECTION = "base"
LICENSE = "GPL"
+PR = "r1"
+
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2 \
${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-multi-parse-fix.patch;patch=1 \
${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-non-replicated-ping.patch;patch=1 \
file://cross.patch;patch=1 \
file://Makefile.rules-cross.patch;patch=1 \
- file://install.patch;patch=1"
+ file://install.patch;patch=1 \
+ file://auto.net-sort-option-fix.patch;patch=1 \
+ file://autofs-additional-distros.patch;patch=1"
inherit autotools