aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning <h.heinold@tarent.de>2011-03-27 13:41:28 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-03-27 23:05:16 +0200
commit56fe6f80d47500fb31c90a5abf1c4ecf4ba4f395 (patch)
treeb556363edc9c8f725fa4bc14f7ba5c413af75be5
parent85a0a9773d4b31f621a115ec03c49a7dbc5f53a9 (diff)
downloadopenembedded-56fe6f80d47500fb31c90a5abf1c4ecf4ba4f395.tar.gz
ecj-bootstrap: try 5 times to compile the classes
* that is an easy fix to workaround the aborts and segfaults of cacao and jamvm * bump PR
-rw-r--r--recipes/ecj/ecj-bootstrap-native.bb2
-rwxr-xr-xrecipes/ecj/files/ecj.in14
2 files changed, 14 insertions, 2 deletions
diff --git a/recipes/ecj/ecj-bootstrap-native.bb b/recipes/ecj/ecj-bootstrap-native.bb
index bdb9797d92..a11ba74baf 100644
--- a/recipes/ecj/ecj-bootstrap-native.bb
+++ b/recipes/ecj/ecj-bootstrap-native.bb
@@ -17,7 +17,7 @@ SRC_URI = "file://ecj.in"
S = "${WORKDIR}"
-PR = "r3"
+PR = "r4"
JAR = "ecj-bootstrap.jar"
diff --git a/recipes/ecj/files/ecj.in b/recipes/ecj/files/ecj.in
index 2cff2593d5..0fd4a65cdc 100755
--- a/recipes/ecj/files/ecj.in
+++ b/recipes/ecj/files/ecj.in
@@ -1 +1,13 @@
-${RUNTIME} -Xmx1024m -cp ${ECJ_JAR} org.eclipse.jdt.internal.compiler.batch.Main ${1+"$@"}
+ARGS=${1+"$@"}
+COUNT=5
+END=0
+
+while test "${COUNT}" -gt "${END}"
+do
+ ${RUNTIME} -Xmx1024m -cp ${ECJ_JAR} org.eclipse.jdt.internal.compiler.batch.Main ${ARGS}
+ if test "${?}" -eq "${END}"
+ then
+ break
+ fi
+ COUNT=$(($COUNT-1))
+done