aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-05-12 10:15:33 +0000
committerKoen Kooi <koen@openembedded.org>2008-05-12 10:15:33 +0000
commit563b7f68d00564f31e1e1154639af3072198a481 (patch)
tree3f1bb7870b3ee7ae9d0acaa2b316fd4cca90cc34
parent7b50ceffdbf4f9bc220c7b0a734dfa96b349d266 (diff)
downloadopenembedded-563b7f68d00564f31e1e1154639af3072198a481.tar.gz
gcc 4.3.0: add symlink hack to get the right includes to glibc
-rw-r--r--packages/gcc/gcc-cross-initial_4.3.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross-initial_4.3.0.bb b/packages/gcc/gcc-cross-initial_4.3.0.bb
index fe326d304b..7060d46758 100644
--- a/packages/gcc/gcc-cross-initial_4.3.0.bb
+++ b/packages/gcc/gcc-cross-initial_4.3.0.bb
@@ -3,3 +3,9 @@ require gcc-cross-initial.inc
EXTRA_OECONF += "--disable-libmudflap --disable-libgomp \
--disable-libssp"
+
+# Hack till we fix *libc properly
+do_stage_append() {
+ ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
+}
+