aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-07-09 07:04:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-09 07:04:37 +0000
commit5250bc5cdc7fa69df0e74e1d6c5edf9989335d71 (patch)
tree77752cf3c90576a0aa3a4836cbef2e28545050c6
parent24b19c060d6b9d1471c918b50d5dd5dae80e7fe0 (diff)
downloadopenembedded-5250bc5cdc7fa69df0e74e1d6c5edf9989335d71.tar.gz
memtester: Added patch to Makefile to change no-longer-supported 'head -1' syntax to 'head -n 1'.
-rw-r--r--packages/memtester/files/.mtn2git_empty0
-rw-r--r--packages/memtester/files/Makefile.patch15
-rw-r--r--packages/memtester/memtester_4.0.5.bb3
3 files changed, 18 insertions, 0 deletions
diff --git a/packages/memtester/files/.mtn2git_empty b/packages/memtester/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/memtester/files/.mtn2git_empty
diff --git a/packages/memtester/files/Makefile.patch b/packages/memtester/files/Makefile.patch
new file mode 100644
index 0000000000..57a04642a6
--- /dev/null
+++ b/packages/memtester/files/Makefile.patch
@@ -0,0 +1,15 @@
+Index: memtester-4.0.5/Makefile
+===================================================================
+--- memtester-4.0.5.orig/Makefile 2005-03-14 06:02:30.000000000 -0800
++++ memtester-4.0.5/Makefile 2006-07-08 23:53:42.000000000 -0700
+@@ -24,8 +24,8 @@
+ auto-ccld.sh: \
+ conf-cc conf-ld warn-auto.sh
+ ( cat warn-auto.sh; \
+- echo CC=\'`head -1 conf-cc`\'; \
+- echo LD=\'`head -1 conf-ld`\' \
++ echo CC=\'`head -n 1 conf-cc`\'; \
++ echo LD=\'`head -n 1 conf-ld`\' \
+ ) > auto-ccld.sh
+
+ compile: \
diff --git a/packages/memtester/memtester_4.0.5.bb b/packages/memtester/memtester_4.0.5.bb
index a33f6f5b33..3a45690a95 100644
--- a/packages/memtester/memtester_4.0.5.bb
+++ b/packages/memtester/memtester_4.0.5.bb
@@ -2,8 +2,11 @@ SECTION = "console/utils"
DESCRIPTION = "Utility to test for faulty memory subsystem"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
LICENSE = "GPLv2"
+PR = "r1"
SRC_URI = "http://pyropus.ca/software/memtester/memtester-${PV}.tar.gz"
+SRC_URI += "file://Makefile.patch;patch=1"
+
S = "${WORKDIR}/memtester-${PV}"
do_compile () {