aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2008-08-02 08:53:25 +0000
committerPhil Blundell <philb@gnu.org>2008-08-02 08:53:25 +0000
commit51736105a6c9705469589743ab05444cbd3c16f0 (patch)
treed8ed11fbb2e811c16acc83c0865cb7520e98932d
parent46ce2bde311b159bcd01fa3bbf48c0e34d95fa22 (diff)
downloadopenembedded-51736105a6c9705469589743ab05444cbd3c16f0.tar.gz
lrzsz: straighten out alternatives, patch from martyn.welch@gefanuc.com
-rw-r--r--packages/lrzsz/lrzsz_0.12.20.bb12
1 files changed, 9 insertions, 3 deletions
diff --git a/packages/lrzsz/lrzsz_0.12.20.bb b/packages/lrzsz/lrzsz_0.12.20.bb
index 0a194f9a05..b44945e35f 100644
--- a/packages/lrzsz/lrzsz_0.12.20.bb
+++ b/packages/lrzsz/lrzsz_0.12.20.bb
@@ -3,7 +3,7 @@ SECTION = "console/network"
PRIORITY = "standard"
DESCRIPTION = "Tools for zmodem/xmodem/ymodem file transfer"
DEPENDS = ""
-PR = "r3"
+PR = "r4"
SRC_URI = "http://www.ohse.de/uwe/releases/lrzsz-${PV}.tar.gz \
file://autotools.patch;patch=1 \
@@ -18,13 +18,19 @@ do_install() {
}
pkg_postinst() {
- for util in rz rx rb sz sx sb; do
+ for util in rz rx rb; do
update-alternatives --install ${bindir}/$util $util lrz 100
done
+ for util in sz sx sb; do
+ update-alternatives --install ${bindir}/$util $util lsz 100
+ done
}
pkg_postrm() {
- for util in rz rx rb sz sx sb; do
+ for util in rz rx rb; do
update-alternatives --remove $util ${bindir}/lrz
done
+ for util in sz sx sb; do
+ update-alternatives --remove $util ${bindir}/lsz
+ done
} \ No newline at end of file