aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-05-17 03:15:07 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-05-17 03:15:07 +0000
commit4ecdf75489db4f447420ebf293912c50a9ea7437 (patch)
treeeb34e3d602aaa2850711faba304d1eab8e4dad83
parent16ece46b049659d5fa1a9be61c955afa714fcb7a (diff)
downloadopenembedded-4ecdf75489db4f447420ebf293912c50a9ea7437.tar.gz
blueprobe 0.18: Fix for uclibc. Termios speed above 115k are not supported,
so check for the defintion of the faster speeds before trying to use them.
-rw-r--r--packages/blueprobe/blueprobe-0.18/uclibc-fix.patch30
-rw-r--r--packages/blueprobe/blueprobe_0.18.bb5
2 files changed, 33 insertions, 2 deletions
diff --git a/packages/blueprobe/blueprobe-0.18/uclibc-fix.patch b/packages/blueprobe/blueprobe-0.18/uclibc-fix.patch
new file mode 100644
index 0000000000..34a1711e60
--- /dev/null
+++ b/packages/blueprobe/blueprobe-0.18/uclibc-fix.patch
@@ -0,0 +1,30 @@
+Uclibc doesn't define or support speeds above 115200. So check the existence
+of the defines before allowing them to actually be used.
+
+Index: blueprobe-0.18/blueprobe.c
+===================================================================
+--- blueprobe-0.18.orig/blueprobe.c 2006-10-12 20:33:01.000000000 +1000
++++ blueprobe-0.18/blueprobe.c 2007-05-17 12:29:20.000000000 +1000
+@@ -25,14 +25,22 @@
+ return B57600;
+ case 115200:
+ return B115200;
++#ifdef B230400
+ case 230400:
+ return B230400;
++#endif
++#ifdef B460800
+ case 460800:
+ return B460800;
++#endif
++#ifdef B921600
+ case 921600:
+ return B921600;
++#endif
++#ifdef B1000000
+ case 1000000:
+ return B1000000;
++#endif
+ default:
+ return B57600;
+ }
diff --git a/packages/blueprobe/blueprobe_0.18.bb b/packages/blueprobe/blueprobe_0.18.bb
index ca455401e0..5db1bc4337 100644
--- a/packages/blueprobe/blueprobe_0.18.bb
+++ b/packages/blueprobe/blueprobe_0.18.bb
@@ -1,5 +1,6 @@
require blueprobe.inc
-PR = "r1"
+PR = "r2"
-SRC_URI += "file://h4000.patch;patch=1"
+SRC_URI += "file://h4000.patch;patch=1 \
+ file://uclibc-fix.patch;patch=1"