aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-05-03 01:54:17 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-05-03 01:54:17 +0000
commit491d0361fbfaa63f825dcea8cd947622f5794b9a (patch)
treef2f20506b0f6fbad92d0bd40732f570e8ef88230
parent2ba78102aee0b6edfebafdb509684843f92a1604 (diff)
downloadopenembedded-491d0361fbfaa63f825dcea8cd947622f5794b9a.tar.gz
libxsettings-client: commit forgotten .inc file
-rw-r--r--packages/libxsettings-client/libxsettings-client.inc22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/libxsettings-client/libxsettings-client.inc b/packages/libxsettings-client/libxsettings-client.inc
new file mode 100644
index 0000000000..319a4f192d
--- /dev/null
+++ b/packages/libxsettings-client/libxsettings-client.inc
@@ -0,0 +1,22 @@
+SECTION = "gpe/libs"
+LICENSE = "BSD-X"
+PRIORITY = "optional"
+DEPENDS = "libxsettings virtual/libx11 libxt"
+# libxt is required to stop configure breaking builds by
+# including system paths to find it if it isn't present.
+
+GPE_TARBALL_SUFFIX = "bz2"
+inherit autotools pkgconfig gpe
+
+SRC_URI = "${GPE_MIRROR}/libxsettings-client-${PV}.tar.bz2 \
+ file://Makefile-am.patch;patch=1"
+
+headers = "xsettings-client.h xsettings-common.h"
+do_stage () {
+ oe_libinstall -so libXsettings-client ${STAGING_LIBDIR}
+ mkdir -p ${STAGING_INCDIR}
+ for h in ${headers}; do
+ install -m 0644 ${S}/$h ${STAGING_INCDIR}/$h
+ done
+}
+