aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2008-03-25 03:07:20 +0000
committerGraeme Gregory <dp@xora.org.uk>2008-03-25 03:07:20 +0000
commit45d016c3f9258d087688d2888e15ae89bbced832 (patch)
treee2f5f8fe5b7fe0697357131baf3edecfa0978c89
parent5974b53400d03b7b7640172bead99aad3905ba37 (diff)
downloadopenembedded-45d016c3f9258d087688d2888e15ae89bbced832.tar.gz
gtkhtml-3.8_3.12.3.bb : update gtkhtml with patch stolen from debian for
glib API changes
-rw-r--r--packages/gtkhtml/gtkhtml-3.8/.mtn2git_empty0
-rw-r--r--packages/gtkhtml/gtkhtml-3.8/60_glib-2.15-g-gnuc-function.patch39
-rw-r--r--packages/gtkhtml/gtkhtml-3.8_3.12.3.bb29
3 files changed, 68 insertions, 0 deletions
diff --git a/packages/gtkhtml/gtkhtml-3.8/.mtn2git_empty b/packages/gtkhtml/gtkhtml-3.8/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gtkhtml/gtkhtml-3.8/.mtn2git_empty
diff --git a/packages/gtkhtml/gtkhtml-3.8/60_glib-2.15-g-gnuc-function.patch b/packages/gtkhtml/gtkhtml-3.8/60_glib-2.15-g-gnuc-function.patch
new file mode 100644
index 0000000000..60e46488cf
--- /dev/null
+++ b/packages/gtkhtml/gtkhtml-3.8/60_glib-2.15-g-gnuc-function.patch
@@ -0,0 +1,39 @@
+diff -Nur gtkhtml3.8-3.12.3/src/htmlengine-edit-clueflowstyle.c gtkhtml3.8-3.12.3.new/src/htmlengine-edit-clueflowstyle.c
+--- gtkhtml3.8-3.12.3/src/htmlengine-edit-clueflowstyle.c 2007-01-29 10:50:59.000000000 +0100
++++ gtkhtml3.8-3.12.3.new/src/htmlengine-edit-clueflowstyle.c 2008-02-15 10:07:22.000000000 +0100
+@@ -175,7 +175,7 @@
+ while (p != NULL) {
+ if (HTML_OBJECT_TYPE (obj->parent) != HTML_TYPE_CLUEFLOW) {
+ g_warning ("(%s:%s) Eeeek! Unknown parent type `%s'.",
+- __FILE__, G_GNUC_FUNCTION,
++ __FILE__, G_STRFUNC,
+ html_type_name (HTML_OBJECT_TYPE (obj->parent)));
+ break;
+ }
+@@ -209,7 +209,7 @@
+ /* This should not happen. */
+ g_warning ("(%s:%s) There were not enough paragraphs for "
+ "setting the paragraph style.",
+- __FILE__, G_GNUC_FUNCTION);
++ __FILE__, G_STRFUNC);
+ break;
+ }
+ } while (obj != NULL && HTML_CLUEFLOW (obj->parent) == clueflow);
+@@ -217,7 +217,7 @@
+
+ if (prop_list == NULL) {
+ /* This should not happen. */
+- g_warning ("%s:%s Eeek! Nothing done?", __FILE__, G_GNUC_FUNCTION);
++ g_warning ("%s:%s Eeek! Nothing done?", __FILE__, G_STRFUNC);
+ return;
+ }
+
+@@ -280,7 +280,7 @@
+ while (p != NULL) {
+ if (HTML_OBJECT_TYPE (p->parent) != HTML_TYPE_CLUEFLOW) {
+ g_warning ("(%s:%s) Eeeek! Unknown parent type `%s'.",
+- __FILE__, G_GNUC_FUNCTION,
++ __FILE__, G_STRFUNC,
+ html_type_name (HTML_OBJECT_TYPE (p->parent)));
+ break;
+ }
diff --git a/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb b/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb
new file mode 100644
index 0000000000..e8727bd0dc
--- /dev/null
+++ b/packages/gtkhtml/gtkhtml-3.8_3.12.3.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "HTML rendering/editing library"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+ gail libbonoboui libgnomeprintui libgnomeui"
+
+SRC_URI = "${GNOME_MIRROR}/gtkhtml/3.12/gtkhtml-${PV}.tar.bz2 \
+ file://60_glib-2.15-g-gnuc-function.patch;patch=1"
+
+S = "${WORKDIR}/gtkhtml-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+ORBIT_IDL = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I${prefix}/include':'-I.':g
+ find ${S} -name Makefile | xargs sed -i 's|ORBIT_IDL =.*|ORBIT_IDL = ${ORBIT_IDL}|'
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/gtkhtml-3.8"
+