aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-02-06 19:35:13 +0100
committerKoen Kooi <koen@openembedded.org>2009-02-06 19:35:13 +0100
commit445938a38d965ac7cfaf23dc2bdb6bfaa6a2e294 (patch)
treeca7a173ffd4257c57f5080e8285fc9b1e2bc8f3b
parent1a4a35664c61707a7187968fd87f1f0f980c0e0e (diff)
downloadopenembedded-445938a38d965ac7cfaf23dc2bdb6bfaa6a2e294.tar.gz
apr-util: fix most libtool problems
-rw-r--r--packages/apr/apr-util/configure_fixes.patch20
-rw-r--r--packages/apr/apr-util_1.2.12.bb12
2 files changed, 25 insertions, 7 deletions
diff --git a/packages/apr/apr-util/configure_fixes.patch b/packages/apr/apr-util/configure_fixes.patch
index 16f88b3bba..7c6fa6a4d2 100644
--- a/packages/apr/apr-util/configure_fixes.patch
+++ b/packages/apr/apr-util/configure_fixes.patch
@@ -1,7 +1,5 @@
-Index: apr-util-1.2.12/configure.in
-===================================================================
---- apr-util-1.2.12.orig/configure.in 2008-03-08 19:15:00.000000000 +0000
-+++ apr-util-1.2.12/configure.in 2008-03-08 19:15:13.000000000 +0000
+--- /tmp/configure.in 2009-02-06 16:34:14.000000000 +0100
++++ apr-util-1.2.12/configure.in 2009-02-06 16:34:38.000000000 +0100
@@ -8,13 +8,13 @@
AC_CONFIG_HEADER(include/private/apu_config.h)
AC_CONFIG_AUX_DIR(build)
@@ -23,3 +21,17 @@ Index: apr-util-1.2.12/configure.in
dnl Generate ./config.nice for reproducing runs of configure
dnl
+@@ -45,10 +45,10 @@
+ # against installed versions of libapr instead of those just
+ # built.
+ case $host in
+-*-apple-darwin*) LT_NO_INSTALL="" ;;
+-*) LT_NO_INSTALL="-no-install" ;;
++*-apple-darwin*) LV_NO_INSTALL="" ;;
++*) LV_NO_INSTALL="-no-install" ;;
+ esac
+-AC_SUBST(LT_NO_INSTALL)
++AC_SUBST(LV_NO_INSTALL)
+
+ dnl
+ dnl compute the top directory of the build
diff --git a/packages/apr/apr-util_1.2.12.bb b/packages/apr/apr-util_1.2.12.bb
index 64f6bcbcf8..6613ab99a8 100644
--- a/packages/apr/apr-util_1.2.12.bb
+++ b/packages/apr/apr-util_1.2.12.bb
@@ -3,7 +3,9 @@ SECTION = "libs"
DEPENDS = "apr expat gdbm"
LICENSE = "Apache License, Version 2.0"
-PR = "r2"
+PR = "r3"
+
+inherit autotools lib_package binconfig
# apache mirrors?
SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
@@ -16,12 +18,16 @@ EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
--with-expat=${STAGING_DIR_HOST}${layout_prefix}"
-inherit autotools lib_package binconfig
-
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+EXTRA_OEMAKE = " LIBTOOL=\"${S}/${TARGET_PREFIX}libtool\" "
+
+export LIBTOOL="${S}/${TARGET_PREFIX}libtool"
do_configure_prepend() {
+ cp ${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool ${S}/
cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+ echo "AC_PROG_LIBTOOL" >> ${S}/configure.in
+ libtoolize --force
}
do_stage() {