aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@beagleboard.org>2010-12-19 15:30:09 +0100
committerKoen Kooi <koen@openembedded.org>2010-12-20 14:39:55 +0100
commit41156f69433b0abfa72157475c93d212068340c6 (patch)
tree99c2f6a777495231066e1a2300fbb9752fb03eec
parent228b78ecc25fe6c41432b8191b8f4b158c46bb68 (diff)
downloadopenembedded-41156f69433b0abfa72157475c93d212068340c6.tar.gz
linux-omap 2.6.37rc: bump to rc6
Signed-off-by: Koen Kooi Koen Kooi <koen@beagleboard.org>
-rw-r--r--recipes/linux/linux-omap-2.6.37rc/0001-ARM-OMAP-Power-on-EHCI-serial-camera-and-DVI-on-beag.patch25
-rw-r--r--recipes/linux/linux-omap-2.6.37rc/0002-omap-Beagle-detect-new-xM-revision-B.patch4
-rw-r--r--recipes/linux/linux-omap-2.6.37rc/0003-ARM-OMAP-beagleboard-Add-infrastructure-to-do-fixups.patch14
-rw-r--r--recipes/linux/linux-omap-2.6.37rc/0004-ARM-OMAP-beagleboard-pre-export-GPIOs-to-userspace-w.patch6
-rw-r--r--recipes/linux/linux-omap-2.6.37rc/0005-modedb.c-add-proper-720p60-mode.patch4
-rw-r--r--recipes/linux/linux-omap-2.6.37rc/0006-mmc-don-t-display-single-block-read-console-messages.patch2
-rw-r--r--recipes/linux/linux-omap-2.6.37rc/0007-MTD-silence-ecc-errors-on-mtdblock0.patch2
-rw-r--r--recipes/linux/linux-omap-2.6.37rc/0008-Miracle-patch.patch2
-rw-r--r--recipes/linux/linux-omap-2.6.37rc/0009-ARM-OMAP-add-omap_rev_-macros.patch2
-rw-r--r--recipes/linux/linux-omap-2.6.37rc/0010-OMAP-DSS2-enable-hsclk-in-dsi_pll_init-for-OMAP36XX.patch2
-rw-r--r--recipes/linux/linux-omap-2.6.37rc/0011-AM37x-Switch-SGX-clocks-to-200MHz.patch4
-rw-r--r--recipes/linux/linux-omap_2.6.37rc.bb6
12 files changed, 40 insertions, 33 deletions
diff --git a/recipes/linux/linux-omap-2.6.37rc/0001-ARM-OMAP-Power-on-EHCI-serial-camera-and-DVI-on-beag.patch b/recipes/linux/linux-omap-2.6.37rc/0001-ARM-OMAP-Power-on-EHCI-serial-camera-and-DVI-on-beag.patch
index 8518d79742..265711fff4 100644
--- a/recipes/linux/linux-omap-2.6.37rc/0001-ARM-OMAP-Power-on-EHCI-serial-camera-and-DVI-on-beag.patch
+++ b/recipes/linux/linux-omap-2.6.37rc/0001-ARM-OMAP-Power-on-EHCI-serial-camera-and-DVI-on-beag.patch
@@ -1,18 +1,23 @@
-From c403de48a5a02e58aabf82f14a068a056fa891f3 Mon Sep 17 00:00:00 2001
+From d48c64139caa1e374fffe10141068df04f3b0536 Mon Sep 17 00:00:00 2001
From: Koen Kooi <koen@dominion.thruhere.net>
Date: Thu, 7 Oct 2010 09:25:45 +0200
-Subject: [PATCH 01/11] ARM: OMAP: Power on EHCI, serial, camera and DVI on beagleboard-xM
+Subject: [PATCH v2] ARM: OMAP: Power on EHCI, serial, camera and DVI on beagleboard-xM
Signed-off-by: Koen Kooi <koen@beagleboard.org>
+
---
- arch/arm/mach-omap2/board-omap3beagle.c | 27 +++++++++++++++++++++++----
- 1 files changed, 23 insertions(+), 4 deletions(-)
+
+Changes since v1:
+ * Reenable the PMU stat LED
+
+ arch/arm/mach-omap2/board-omap3beagle.c | 26 ++++++++++++++++++++++++--
+ 1 files changed, 24 insertions(+), 2 deletions(-)
diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c
-index f1a8ede..9c9bd96 100644
+index f1a8ede..4756ac7 100644
--- a/arch/arm/mach-omap2/board-omap3beagle.c
+++ b/arch/arm/mach-omap2/board-omap3beagle.c
-@@ -297,12 +297,31 @@ static int beagle_twl_gpio_setup(struct device *dev,
+@@ -297,13 +297,35 @@ static int beagle_twl_gpio_setup(struct device *dev,
gpio_request(gpio + 1, "EHCI_nOC");
gpio_direction_input(gpio + 1);
@@ -38,16 +43,18 @@ index f1a8ede..9c9bd96 100644
+ gpio_direction_output(gpio + 1, 0);
+ }
-- /* TWL4030_GPIO_MAX + 1 == ledB, PMU_STAT (out, active low LED) */
-- gpio_leds[2].gpio = gpio + TWL4030_GPIO_MAX + 1;
+ /* TWL4030_GPIO_MAX + 1 == ledB, PMU_STAT (out, active low LED) */
+ gpio_leds[2].gpio = gpio + TWL4030_GPIO_MAX + 1;
+
+ /* Power on camera interface on P7/P8 or DVI on A2 and beyond */
+ if (omap3_beagle_get_rev() == OMAP3BEAGLE_BOARD_XM) {
+ gpio_request(gpio + 2, "CAM_EN");
+ gpio_direction_output(gpio + 2, 1);
+ }
-
++
return 0;
}
+
--
1.6.6.1
diff --git a/recipes/linux/linux-omap-2.6.37rc/0002-omap-Beagle-detect-new-xM-revision-B.patch b/recipes/linux/linux-omap-2.6.37rc/0002-omap-Beagle-detect-new-xM-revision-B.patch
index 89694c6d96..7450bec6c3 100644
--- a/recipes/linux/linux-omap-2.6.37rc/0002-omap-Beagle-detect-new-xM-revision-B.patch
+++ b/recipes/linux/linux-omap-2.6.37rc/0002-omap-Beagle-detect-new-xM-revision-B.patch
@@ -1,4 +1,4 @@
-From c10787108ac19e36cf8d8f15c3c93edff94a9f10 Mon Sep 17 00:00:00 2001
+From 4ff497659816b4f6d558a2fb96e3f9bfe10c05ff Mon Sep 17 00:00:00 2001
From: Robert Nelson <robertcnelson@gmail.com>
Date: Tue, 9 Nov 2010 08:34:55 -0600
Subject: [PATCH 02/11] omap: Beagle: detect new xM revision B
@@ -12,7 +12,7 @@ Signed-off-by: Koen Kooi <koen@beagleboard.org>
1 files changed, 7 insertions(+), 2 deletions(-)
diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c
-index 9c9bd96..159d81b 100644
+index 4756ac7..2ad28c9 100644
--- a/arch/arm/mach-omap2/board-omap3beagle.c
+++ b/arch/arm/mach-omap2/board-omap3beagle.c
@@ -58,7 +58,8 @@
diff --git a/recipes/linux/linux-omap-2.6.37rc/0003-ARM-OMAP-beagleboard-Add-infrastructure-to-do-fixups.patch b/recipes/linux/linux-omap-2.6.37rc/0003-ARM-OMAP-beagleboard-Add-infrastructure-to-do-fixups.patch
index b713d80098..8b49db1144 100644
--- a/recipes/linux/linux-omap-2.6.37rc/0003-ARM-OMAP-beagleboard-Add-infrastructure-to-do-fixups.patch
+++ b/recipes/linux/linux-omap-2.6.37rc/0003-ARM-OMAP-beagleboard-Add-infrastructure-to-do-fixups.patch
@@ -1,4 +1,4 @@
-From ea4d9ef8f8550985ee062d5f186efa02bbdb53d1 Mon Sep 17 00:00:00 2001
+From be8aed2c51dec505bcf4cacf2a805268740200b2 Mon Sep 17 00:00:00 2001
From: Koen Kooi <koen@dominion.thruhere.net>
Date: Wed, 6 Oct 2010 10:19:34 +0200
Subject: [PATCH 03/11] ARM: OMAP: beagleboard: Add infrastructure to do fixups based on expansionboard name passed by u-boot
@@ -11,7 +11,7 @@ Signed-off-by: Koen Kooi <koen@beagleboard.org>
1 files changed, 139 insertions(+), 3 deletions(-)
diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c
-index 159d81b..030ab32 100644
+index 2ad28c9..bb13ca2 100644
--- a/arch/arm/mach-omap2/board-omap3beagle.c
+++ b/arch/arm/mach-omap2/board-omap3beagle.c
@@ -21,6 +21,7 @@
@@ -128,7 +128,7 @@ index 159d81b..030ab32 100644
{} /* Terminator */
};
-@@ -428,7 +521,7 @@ static struct twl4030_platform_data beagle_twldata = {
+@@ -431,7 +524,7 @@ static struct twl4030_platform_data beagle_twldata = {
.vpll2 = &beagle_vpll2,
};
@@ -137,7 +137,7 @@ index 159d81b..030ab32 100644
{
I2C_BOARD_INFO("twl4030", 0x48),
.flags = I2C_CLIENT_WAKE,
-@@ -443,10 +536,24 @@ static struct i2c_board_info __initdata beagle_i2c_eeprom[] = {
+@@ -446,10 +539,24 @@ static struct i2c_board_info __initdata beagle_i2c_eeprom[] = {
},
};
@@ -164,7 +164,7 @@ index 159d81b..030ab32 100644
/* Bus 3 is attached to the DVI port where devices like the pico DLP
* projector don't work reliably with 400kHz */
omap_register_i2c_bus(3, 100, beagle_i2c_eeprom, ARRAY_SIZE(beagle_i2c_eeprom));
-@@ -579,6 +686,15 @@ static struct omap_musb_board_data musb_board_data = {
+@@ -582,6 +689,15 @@ static struct omap_musb_board_data musb_board_data = {
.power = 100,
};
@@ -180,7 +180,7 @@ index 159d81b..030ab32 100644
static void __init omap3_beagle_init(void)
{
omap3_mux_init(board_mux, OMAP_PACKAGE_CBB);
-@@ -593,6 +709,24 @@ static void __init omap3_beagle_init(void)
+@@ -596,6 +712,24 @@ static void __init omap3_beagle_init(void)
/* REVISIT leave DVI powered down until it's needed ... */
gpio_direction_output(170, true);
@@ -205,7 +205,7 @@ index 159d81b..030ab32 100644
usb_musb_init(&musb_board_data);
usb_ehci_init(&ehci_pdata);
omap3beagle_flash_init();
-@@ -604,6 +738,8 @@ static void __init omap3_beagle_init(void)
+@@ -607,6 +741,8 @@ static void __init omap3_beagle_init(void)
beagle_display_init();
}
diff --git a/recipes/linux/linux-omap-2.6.37rc/0004-ARM-OMAP-beagleboard-pre-export-GPIOs-to-userspace-w.patch b/recipes/linux/linux-omap-2.6.37rc/0004-ARM-OMAP-beagleboard-pre-export-GPIOs-to-userspace-w.patch
index 3d1f6eecdc..50909760e0 100644
--- a/recipes/linux/linux-omap-2.6.37rc/0004-ARM-OMAP-beagleboard-pre-export-GPIOs-to-userspace-w.patch
+++ b/recipes/linux/linux-omap-2.6.37rc/0004-ARM-OMAP-beagleboard-pre-export-GPIOs-to-userspace-w.patch
@@ -1,4 +1,4 @@
-From 9d5908876b85482b55ec36d3dc9970bc43a9b331 Mon Sep 17 00:00:00 2001
+From 7525475b1a7799035b69c2c039eeea9c14a986ef Mon Sep 17 00:00:00 2001
From: Koen Kooi <koen@dominion.thruhere.net>
Date: Sun, 5 Dec 2010 13:25:00 +0100
Subject: [PATCH 04/11] ARM: OMAP: beagleboard: pre-export GPIOs to userspace when using a Tincantools trainerboard
@@ -11,10 +11,10 @@ Signed-off-by: Koen Kooi <koen@beagleboard.org>
1 files changed, 31 insertions(+), 0 deletions(-)
diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c
-index 030ab32..c78cdc1 100644
+index bb13ca2..074d138 100644
--- a/arch/arm/mach-omap2/board-omap3beagle.c
+++ b/arch/arm/mach-omap2/board-omap3beagle.c
-@@ -727,6 +727,37 @@ static void __init omap3_beagle_init(void)
+@@ -730,6 +730,37 @@ static void __init omap3_beagle_init(void)
mmc[1].gpio_cd = 162;
}
diff --git a/recipes/linux/linux-omap-2.6.37rc/0005-modedb.c-add-proper-720p60-mode.patch b/recipes/linux/linux-omap-2.6.37rc/0005-modedb.c-add-proper-720p60-mode.patch
index edbfaa9de1..dbdf9511b0 100644
--- a/recipes/linux/linux-omap-2.6.37rc/0005-modedb.c-add-proper-720p60-mode.patch
+++ b/recipes/linux/linux-omap-2.6.37rc/0005-modedb.c-add-proper-720p60-mode.patch
@@ -1,4 +1,4 @@
-From 2963f2663b0b2457bd0a02eaa2d72d20390af4aa Mon Sep 17 00:00:00 2001
+From f4ad137e2db56975adb534d40cac148cf3cc3fea Mon Sep 17 00:00:00 2001
From: Koen Kooi <koen@dominion.thruhere.net>
Date: Mon, 8 Mar 2010 14:38:31 +0100
Subject: [PATCH 05/11] modedb.c: add proper 720p60 mode
@@ -9,7 +9,7 @@ Signed-off-by: Koen Kooi <koen@beagleboard.org>
1 files changed, 4 insertions(+), 0 deletions(-)
diff --git a/drivers/video/modedb.c b/drivers/video/modedb.c
-index 0a4dbdc..53edf81 100644
+index de450c1..1cd8153 100644
--- a/drivers/video/modedb.c
+++ b/drivers/video/modedb.c
@@ -46,6 +46,10 @@ static const struct fb_videomode modedb[] = {
diff --git a/recipes/linux/linux-omap-2.6.37rc/0006-mmc-don-t-display-single-block-read-console-messages.patch b/recipes/linux/linux-omap-2.6.37rc/0006-mmc-don-t-display-single-block-read-console-messages.patch
index 643ea40539..b1812535e9 100644
--- a/recipes/linux/linux-omap-2.6.37rc/0006-mmc-don-t-display-single-block-read-console-messages.patch
+++ b/recipes/linux/linux-omap-2.6.37rc/0006-mmc-don-t-display-single-block-read-console-messages.patch
@@ -1,4 +1,4 @@
-From c0f7625ced4a0aa2cc0f0317ec2f1ef5a63b79e1 Mon Sep 17 00:00:00 2001
+From c0da6149be97cfe2924395534312844575c16e90 Mon Sep 17 00:00:00 2001
From: Steve Sakoman <steve@sakoman.com>
Date: Mon, 4 Jan 2010 19:20:25 -0800
Subject: [PATCH 06/11] mmc: don't display single block read console messages
diff --git a/recipes/linux/linux-omap-2.6.37rc/0007-MTD-silence-ecc-errors-on-mtdblock0.patch b/recipes/linux/linux-omap-2.6.37rc/0007-MTD-silence-ecc-errors-on-mtdblock0.patch
index 7327a41efe..bf4428489b 100644
--- a/recipes/linux/linux-omap-2.6.37rc/0007-MTD-silence-ecc-errors-on-mtdblock0.patch
+++ b/recipes/linux/linux-omap-2.6.37rc/0007-MTD-silence-ecc-errors-on-mtdblock0.patch
@@ -1,4 +1,4 @@
-From 82fc365dde8758566ac3817c8a037711724b56b1 Mon Sep 17 00:00:00 2001
+From 74b66c1642ad0840472e7de4023284b15dc815ff Mon Sep 17 00:00:00 2001
From: Steve Sakoman <steve@sakoman.com>
Date: Mon, 26 Apr 2010 11:17:26 -0700
Subject: [PATCH 07/11] MTD: silence ecc errors on mtdblock0
diff --git a/recipes/linux/linux-omap-2.6.37rc/0008-Miracle-patch.patch b/recipes/linux/linux-omap-2.6.37rc/0008-Miracle-patch.patch
index d8e4c741fa..637c714b81 100644
--- a/recipes/linux/linux-omap-2.6.37rc/0008-Miracle-patch.patch
+++ b/recipes/linux/linux-omap-2.6.37rc/0008-Miracle-patch.patch
@@ -1,4 +1,4 @@
-From f7410950ad86e2b70fca1b02e4c4097fe9280bef Mon Sep 17 00:00:00 2001
+From ab08efe84b1362ffda7afb929fdb299bb00a55a2 Mon Sep 17 00:00:00 2001
From: Mike Galbraith <efault@gmx.de>
Date: Fri, 19 Nov 2010 12:52:42 +0100
Subject: [PATCH 08/11] Miracle patch
diff --git a/recipes/linux/linux-omap-2.6.37rc/0009-ARM-OMAP-add-omap_rev_-macros.patch b/recipes/linux/linux-omap-2.6.37rc/0009-ARM-OMAP-add-omap_rev_-macros.patch
index 405e30c03b..fac32c4434 100644
--- a/recipes/linux/linux-omap-2.6.37rc/0009-ARM-OMAP-add-omap_rev_-macros.patch
+++ b/recipes/linux/linux-omap-2.6.37rc/0009-ARM-OMAP-add-omap_rev_-macros.patch
@@ -1,4 +1,4 @@
-From 85ea664bbf0410eb8132be8427874761113457bc Mon Sep 17 00:00:00 2001
+From 09cd8d4547576b788461de5254d53c83171bebe5 Mon Sep 17 00:00:00 2001
From: Koen Kooi <koen@dominion.thruhere.net>
Date: Tue, 23 Nov 2010 11:40:20 +0100
Subject: [PATCH 09/11] ARM: OMAP: add omap_rev_* macros
diff --git a/recipes/linux/linux-omap-2.6.37rc/0010-OMAP-DSS2-enable-hsclk-in-dsi_pll_init-for-OMAP36XX.patch b/recipes/linux/linux-omap-2.6.37rc/0010-OMAP-DSS2-enable-hsclk-in-dsi_pll_init-for-OMAP36XX.patch
index 7594c0309a..a4a6029666 100644
--- a/recipes/linux/linux-omap-2.6.37rc/0010-OMAP-DSS2-enable-hsclk-in-dsi_pll_init-for-OMAP36XX.patch
+++ b/recipes/linux/linux-omap-2.6.37rc/0010-OMAP-DSS2-enable-hsclk-in-dsi_pll_init-for-OMAP36XX.patch
@@ -1,4 +1,4 @@
-From 99db14dd71d9681b52647edaffefd5dd951b1672 Mon Sep 17 00:00:00 2001
+From 919babbcde4fa8d5224ccf35c6bb68c3c97f7f76 Mon Sep 17 00:00:00 2001
From: Steve Sakoman <steve@sakoman.com>
Date: Mon, 10 May 2010 20:44:09 -0700
Subject: [PATCH 10/11] OMAP: DSS2: enable hsclk in dsi_pll_init for OMAP36XX
diff --git a/recipes/linux/linux-omap-2.6.37rc/0011-AM37x-Switch-SGX-clocks-to-200MHz.patch b/recipes/linux/linux-omap-2.6.37rc/0011-AM37x-Switch-SGX-clocks-to-200MHz.patch
index e4bfc63138..8adf6aa37f 100644
--- a/recipes/linux/linux-omap-2.6.37rc/0011-AM37x-Switch-SGX-clocks-to-200MHz.patch
+++ b/recipes/linux/linux-omap-2.6.37rc/0011-AM37x-Switch-SGX-clocks-to-200MHz.patch
@@ -1,4 +1,4 @@
-From f98795ac746eb6681738e56fc8df0f126bfd5f2f Mon Sep 17 00:00:00 2001
+From 169f78033b2700b787dc03080094004aabab836c Mon Sep 17 00:00:00 2001
From: Prabindh Sundareson <prabu@ti.com>
Date: Thu, 3 Jun 2010 11:20:57 +0530
Subject: [PATCH 11/11] AM37x: Switch SGX clocks to 200MHz
@@ -10,7 +10,7 @@ Signed-off-by: Koen Kooi <koen@beagleboard.org>
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm/mach-omap2/clock3xxx_data.c b/arch/arm/mach-omap2/clock3xxx_data.c
-index 0579604..f394b4f 100644
+index c16253f..9e0582d 100644
--- a/arch/arm/mach-omap2/clock3xxx_data.c
+++ b/arch/arm/mach-omap2/clock3xxx_data.c
@@ -3267,8 +3267,8 @@ static struct omap_clk omap3xxx_clks[] = {
diff --git a/recipes/linux/linux-omap_2.6.37rc.bb b/recipes/linux/linux-omap_2.6.37rc.bb
index c9598fdfc0..390de6c0a1 100644
--- a/recipes/linux/linux-omap_2.6.37rc.bb
+++ b/recipes/linux/linux-omap_2.6.37rc.bb
@@ -6,9 +6,9 @@ KERNEL_IMAGETYPE = "uImage"
COMPATIBLE_MACHINE = "beagleboard"
# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
-PV = "2.6.36+2.6.37-rc5"
-MACHINE_KERNEL_PR_append = "c+gitr${SRCREV}"
-SRCREV = "2fc4a8a62495f4f72d91c62340443e409be8f448"
+PV = "2.6.36+2.6.37-rc6"
+MACHINE_KERNEL_PR_append = "a+gitr${SRCREV}"
+SRCREV = "5ec5d855170a705b6c79be32709671fd3b8240cb"
FILESPATHPKG_prepend = "linux-omap-2.6.37rc:"