aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2011-08-01 10:29:20 -0400
committerPhilip Balister <philip@balister.org>2011-08-01 10:29:20 -0400
commit3b1fa9d1f31d2b8573dba0ef1ea935366bda0497 (patch)
treedbfb2d44d47e63018473c244c19c7ed51856247d
parent0b521d7bcfbb6f26bb2d3ad55add6a3f677a199d (diff)
parente8fe215d2c3b59b4272980535a950b4bc48fdab5 (diff)
downloadopenembedded-3b1fa9d1f31d2b8573dba0ef1ea935366bda0497.tar.gz
Merge branch 'uhd-updates'
-rw-r--r--recipes/uhd/uhd-firmware.inc3
-rw-r--r--recipes/uhd/uhd-firmware_003.001.000.bb7
-rw-r--r--recipes/uhd/uhd-firmware_003.002.001.bb7
-rw-r--r--recipes/uhd/uhd.inc6
-rw-r--r--recipes/uhd/uhd_git.bb4
5 files changed, 15 insertions, 12 deletions
diff --git a/recipes/uhd/uhd-firmware.inc b/recipes/uhd/uhd-firmware.inc
index b3c24ae7f6..bdb68bdef1 100644
--- a/recipes/uhd/uhd-firmware.inc
+++ b/recipes/uhd/uhd-firmware.inc
@@ -14,6 +14,9 @@ S = ${WORKDIR}/UHD-images-${PV}
do_install() {
install -d ${D}${datadir}/uhd/images
+ install -d ${D}${datadir}/uhd/images/bit
+ install -m 0644 ${S}/share/uhd/images/bit/* ${D}${datadir}/uhd/images/bit
+ rm -rf ${S}/share/uhd/images/bit
install -m 0644 ${S}/share/uhd/images/* ${D}${datadir}/uhd/images
}
diff --git a/recipes/uhd/uhd-firmware_003.001.000.bb b/recipes/uhd/uhd-firmware_003.001.000.bb
deleted file mode 100644
index 5d30806798..0000000000
--- a/recipes/uhd/uhd-firmware_003.001.000.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require recipes/uhd/uhd-firmware.inc
-
-PR = "${INC_PR}.0"
-
-SRC_URI[md5sum] = "0d6a6792c6b98e9163d67cb62bf29dce"
-SRC_URI[sha256sum] = "3b25726946026c6d25061403e3343d72b34cc41e7e44026b272510379d01233a"
-
diff --git a/recipes/uhd/uhd-firmware_003.002.001.bb b/recipes/uhd/uhd-firmware_003.002.001.bb
new file mode 100644
index 0000000000..654336b538
--- /dev/null
+++ b/recipes/uhd/uhd-firmware_003.002.001.bb
@@ -0,0 +1,7 @@
+require recipes/uhd/uhd-firmware.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "1894391da027884e5eed474606250be9"
+SRC_URI[sha256sum] = "c194d9e30bb02225de623400bdba9be9200f70a57c6220506bc0b051eed8fae8"
+
diff --git a/recipes/uhd/uhd.inc b/recipes/uhd/uhd.inc
index 43bf038b58..8712ef6ae5 100644
--- a/recipes/uhd/uhd.inc
+++ b/recipes/uhd/uhd.inc
@@ -2,10 +2,10 @@ DESCRIPTION = "Universal Hardware Driver for Ettus Research products."
HOMEPAGE = "http://www.ettus.com"
LICENSE = "GPLV3+"
-DEPENDS = "git-native python-cheetah-native boost libusb1 uhd-firmware"
+DEPENDS = "git-native python-cheetah-native boost libusb1 uhd-firmware orc-native"
RDEPENDS_${PN} += "uhd-firmware"
-INC_PR = "r5"
+INC_PR = "r6"
inherit cmake
@@ -24,6 +24,6 @@ FILES_${PN}-examples = "${datadir}/uhd/examples/*"
OECMAKE_BUILDPATH = "${S}/build"
OECMAKE_SOURCEPATH = "${S}"
-EXTRA_OECMAKE = "-DENABLE_USRP_E100=TRUE -DENABLE_USRP_E_UTILS=TRUE"
+EXTRA_OECMAKE = "-DENABLE_E100=TRUE -DENABLE_USRP_E_UTILS=TRUE"
EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
diff --git a/recipes/uhd/uhd_git.bb b/recipes/uhd/uhd_git.bb
index 80f32b78f5..e1d2e99b28 100644
--- a/recipes/uhd/uhd_git.bb
+++ b/recipes/uhd/uhd_git.bb
@@ -1,8 +1,8 @@
require recipes/uhd/uhd.inc
-PR = "${INC_PR}.4"
+PR = "${INC_PR}.5"
SRC_URI = "git://ettus.sourcerepo.com/ettus/uhd.git;protocol=git"
S = "${WORKDIR}/git/host"
-SRCREV = "0aff497dacc9cc4eba5d800cc46343da083cfdf1"
+SRCREV = "fc349d30507620baca935e75e68a9554b40d427c"