aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-02-23 21:07:13 +0000
committerTom Rini <tom_rini@mentor.com>2011-02-23 14:08:19 -0700
commit36a46e9db88398855a7ef96c8dae54d73b3c88fe (patch)
tree5754c2a0aea6e61df32960ebf123a20e193212e2
parent459110a17e59594c4fd9183a5684413ffa1479dd (diff)
downloadopenembedded-36a46e9db88398855a7ef96c8dae54d73b3c88fe.tar.gz
cmake: drop 2.6.4 as it is not used by any distro
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/cmake/cmake-2.6.4/fix_fortify_source_compilation.patch32
-rw-r--r--recipes/cmake/cmake-native_2.6.4.bb10
-rw-r--r--recipes/cmake/cmake_2.6.4.bb11
3 files changed, 0 insertions, 53 deletions
diff --git a/recipes/cmake/cmake-2.6.4/fix_fortify_source_compilation.patch b/recipes/cmake/cmake-2.6.4/fix_fortify_source_compilation.patch
deleted file mode 100644
index 316ab0c061..0000000000
--- a/recipes/cmake/cmake-2.6.4/fix_fortify_source_compilation.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-upstream: http://public.kitware.com/mantis/view.php?id=9267
-status: pending
-origin: http://sisyphus.ru/ru/srpm/Sisyphus/cmake/patches/0
-comment: fix cmake building when FORTIFY_SOURCE is enabled
---- a/Source/kwsys/SystemInformation.cxx
-+++ b/Source/kwsys/SystemInformation.cxx
-@@ -1896,9 +1896,14 @@
- case 5: sprintf (this->ChipID.ProcessorName,"Pentium II (0.25 micron)"); break;
- case 6: sprintf (this->ChipID.ProcessorName,"Pentium II With On-Die L2 Cache"); break;
- case 7: sprintf (this->ChipID.ProcessorName,"Pentium III (0.25 micron)"); break;
-+/*
- case 8: sprintf (this->ChipID.ProcessorName,"Pentium III (0.18 micron) With 256 KB On-Die L2 Cache "); break;
- case 0xa: sprintf (this->ChipID.ProcessorName,"Pentium III (0.18 micron) With 1 Or 2 MB On-Die L2 Cache "); break;
- case 0xb: sprintf (this->ChipID.ProcessorName,"Pentium III (0.13 micron) With 256 Or 512 KB On-Die L2 Cache "); break;
-+*/
-+ case 8: sprintf (this->ChipID.ProcessorName,"Pentium III (0.18 micron) With 256 KB L2 Cache "); break;
-+ case 0xa: sprintf (this->ChipID.ProcessorName,"Pentium III (0.18 micron), 1/2 MB L2 Cache "); break;
-+ case 0xb: sprintf (this->ChipID.ProcessorName,"Pentium III (0.13 micron), 256/512 KB L2 Cache "); break;
- default: sprintf (this->ChipID.ProcessorName,"Unknown P6 family"); return false;
- }
- break;
---- a/Utilities/cmtar/encode.c
-+++ b/Utilities/cmtar/encode.c
-@@ -32,7 +32,7 @@ th_finish(TAR *t)
- int i, sum = 0;
-
- if (t->options & TAR_GNU)
-- strncpy(t->th_buf.magic, "ustar ", 8);
-+ memcpy(t->th_buf.magic, "ustar ", 8);
- else
- {
- strncpy(t->th_buf.version, TVERSION, TVERSLEN);
diff --git a/recipes/cmake/cmake-native_2.6.4.bb b/recipes/cmake/cmake-native_2.6.4.bb
deleted file mode 100644
index aab6b62a0c..0000000000
--- a/recipes/cmake/cmake-native_2.6.4.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-inherit native
-require cmake.inc
-
-do_install() {
- oe_runmake install
-}
-
-SRC_URI += "file://fix_fortify_source_compilation.patch"
-SRC_URI[md5sum] = "50f387d0436696c4a68b5512a72c9cde"
-SRC_URI[sha256sum] = "9cdd2152e37b05d0d40d334a1bb2dfc0250021797360f971c6ea3d457ac9fdf2"
diff --git a/recipes/cmake/cmake_2.6.4.bb b/recipes/cmake/cmake_2.6.4.bb
deleted file mode 100644
index b5a47a88f0..0000000000
--- a/recipes/cmake/cmake_2.6.4.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-require cmake.inc
-
-inherit cmake
-
-do_configure_append() {
- sed -i -e 's,HAVE_GLIBC_STRERROR_R__TRYRUN_OUTPUT-ADVANCED:INTERNAL=1,HAVE_GLIBC_STRERROR_R__TRYRUN_OUTPUT-ADVANCED:INTERNAL=0,' CMakeCache.txt
-}
-
-SRC_URI += "file://fix_fortify_source_compilation.patch"
-SRC_URI[md5sum] = "50f387d0436696c4a68b5512a72c9cde"
-SRC_URI[sha256sum] = "9cdd2152e37b05d0d40d334a1bb2dfc0250021797360f971c6ea3d457ac9fdf2"