aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-07-27 15:27:04 +0000
committerKoen Kooi <koen@openembedded.org>2006-07-27 15:27:04 +0000
commit3680c502f9d9df9bc465e79a4c387022dde5b062 (patch)
treee53cedcb9711f9edc0329b2f2a7312b508fc8d16
parent9f5db45a0b3c5efddf695d0fe7d919f3636e1804 (diff)
downloadopenembedded-3680c502f9d9df9bc465e79a4c387022dde5b062.tar.gz
gdal: add 1.3.2, doesn't stage anything yet.
And don't look inside, you might go blind...
-rw-r--r--packages/gdal/.mtn2git_empty0
-rw-r--r--packages/gdal/gdal_1.3.2.bb38
2 files changed, 38 insertions, 0 deletions
diff --git a/packages/gdal/.mtn2git_empty b/packages/gdal/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gdal/.mtn2git_empty
diff --git a/packages/gdal/gdal_1.3.2.bb b/packages/gdal/gdal_1.3.2.bb
new file mode 100644
index 0000000000..c445cd1274
--- /dev/null
+++ b/packages/gdal/gdal_1.3.2.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "GDAL is a translator library for raster geospatial data formats"
+HOMEPAGE = "http://www.gdal.org/"
+LICENSE = "MIT"
+DEPENDS = "zlib"
+
+SRC_URI = "http://www.gdal.org/dl/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = "--without-perl \
+ --without-python \
+ --without-php \
+ --without-ruby \
+ --with-libz=internal \
+ --with-png=internal \
+ --with-jpeg=internal \
+ --with-libtiff=internal \
+ "
+
+do_configure_append() {
+ sed -i s:/usr/lib:${D}${libdir}: GDALmake.opt
+ sed -i s:/usr/bin:${D}${bindir}: GDALmake.opt
+ sed -i s:/usr/share:${D}${datadir}: GDALmake.opt
+ sed -i s:/usr/include:${D}${includedir}: GDALmake.opt
+}
+
+do_compile() {
+ oe_runmake default
+}
+
+
+do_package_prepend() {
+ # the brokenness....
+ os.system('cp -a ${D}${D}* ${D}../')
+}
+