aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <bluelightning@bluelightning.org>2008-06-07 17:11:48 +0000
committerPaul Eggleton <bluelightning@bluelightning.org>2008-06-07 17:11:48 +0000
commit3374a6d1e18d71db6e1a0fd7a485474cb003e65a (patch)
tree550ec719357e02a01e91a9e440c42aacfed19598
parent3596eaa64f0fb0508bac711f6a45b6e77a120192 (diff)
downloadopenembedded-3374a6d1e18d71db6e1a0fd7a485474cb003e65a.tar.gz
libopie/qte: fix cursor key rotation for iPAQs. Should resolve 3678.
-rw-r--r--packages/libopie/libopie2/remove_h2200_rotate_fix.patch15
-rw-r--r--packages/libopie/libopie2_1.2.3.bb4
-rw-r--r--packages/qte/qte-2.3.10/disable-dup-rotation.patch14
-rw-r--r--packages/qte/qte-mt_2.3.10.bb2
4 files changed, 10 insertions, 25 deletions
diff --git a/packages/libopie/libopie2/remove_h2200_rotate_fix.patch b/packages/libopie/libopie2/remove_h2200_rotate_fix.patch
deleted file mode 100644
index cef436f2f7..0000000000
--- a/packages/libopie/libopie2/remove_h2200_rotate_fix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- libopie2/opiecore/device/odevice_ipaq.cpp 25 Jul 2007 10:49:20 -0000 1.32
-+++ libopie2/opiecore/device/odevice_ipaq.cpp 17 Mar 2007 22:08:43 -0000 1.30
-@@ -330,12 +330,6 @@
- case Rot180: quarters = 1/*270deg*/; break;
- case Rot270: quarters = 0/*270deg*/; break;
- }
-- if( d->m_model == Model_iPAQ_H22xx ) {
-- // FIXME: there's something screwed with the keycodes being sent on h2200. I have
-- // added a temporary workaround for this here, but the bug should be fixed properly
-- // later in the right place. - Paul Eggleton 25/07/2007
-- quarters = 0;
-- }
- newkeycode = Key_Left + ( keycode - Key_Left + quarters ) % 4;
- break;
- }
diff --git a/packages/libopie/libopie2_1.2.3.bb b/packages/libopie/libopie2_1.2.3.bb
index dc378d0646..288b689d52 100644
--- a/packages/libopie/libopie2_1.2.3.bb
+++ b/packages/libopie/libopie2_1.2.3.bb
@@ -1,11 +1,11 @@
require ${PN}.inc
-PR = "r3"
+PR = "r4"
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/libopie2 \
file://include.pro \
file://gcc-syntax-fix.patch;patch=1 \
file://h4000_and_default_rot.patch;patch=1 \
- file://remove_h2200_rotate_fix.patch;patch=1"
+ file://ipaq_rotate_fix.patch;patch=1"
SRC_URI_append_poodle = " file://poodle-2.6-hotkeys.patch;patch=1"
diff --git a/packages/qte/qte-2.3.10/disable-dup-rotation.patch b/packages/qte/qte-2.3.10/disable-dup-rotation.patch
index ae2332c5f0..8a2a02240d 100644
--- a/packages/qte/qte-2.3.10/disable-dup-rotation.patch
+++ b/packages/qte/qte-2.3.10/disable-dup-rotation.patch
@@ -1,13 +1,13 @@
---- qte/src/kernel/kernelkeyboard.cpp 2008-04-04 11:07:42.000000000 +0100
-+++ qte/src/kernel/kernelkeyboard.cpp 2008-04-04 11:07:45.000000000 +0100
-@@ -627,8 +627,8 @@
+--- qte/src/kernel/kernelkeyboard.cpp 2008-05-26 16:25:23.000000000 +0100
++++ qte/src/kernel/kernelkeyboard.cpp 2008-05-26 16:27:52.000000000 +0100
+@@ -627,8 +627,10 @@
case Qt::Key_Down:
unicode = 0xffff;
mod_key = false;
-- if (qt_screen->isTransformed())
-- qtKeyCode = static_cast<Qt::Key>( xform_dirkey(static_cast<int>( qtKeyCode ) ) );
-+// if (qt_screen->isTransformed())
-+// qtKeyCode = static_cast<Qt::Key>( xform_dirkey(static_cast<int>( qtKeyCode ) ) );
++#if defined(QT_QWS_IPAQ) || defined(QT_QWS_SL5XXX)
+ if (qt_screen->isTransformed())
+ qtKeyCode = static_cast<Qt::Key>( xform_dirkey(static_cast<int>( qtKeyCode ) ) );
++#endif
break;
/*
* handle lock, we don't handle scroll lock!
diff --git a/packages/qte/qte-mt_2.3.10.bb b/packages/qte/qte-mt_2.3.10.bb
index 9e3ee5c584..32afeda271 100644
--- a/packages/qte/qte-mt_2.3.10.bb
+++ b/packages/qte/qte-mt_2.3.10.bb
@@ -1,5 +1,5 @@
require qte-common_${PV}.inc
-PR = "r26"
+PR = "r27"
EXTRA_OECONF += "-thread"