aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2008-12-04 13:22:41 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-12-04 13:49:01 +0100
commit332d82817630bcdfd964544ca84607c2b2ed9108 (patch)
tree574120b9f2699013a024a81406a5eecb94502ccc
parent3d048c670dc93d9e9663e17b8bc8e5ce78cb50d3 (diff)
downloadopenembedded-332d82817630bcdfd964544ca84607c2b2ed9108.tar.gz
coreutils: Build and package df of coreutils
- df can only be build if one of the many statvfs,fsusage was is present. These tests work by executing a test application and that is obviously not working out when cross compiling - all linux (glibc, eglibc, uclibc) should have the bsize in the struct statvfs... and this will enable the build of df.
-rw-r--r--packages/coreutils/coreutils_5.3.0.bb4
-rw-r--r--packages/coreutils/coreutils_6.0.bb4
-rw-r--r--site/common-linux4
3 files changed, 9 insertions, 3 deletions
diff --git a/packages/coreutils/coreutils_5.3.0.bb b/packages/coreutils/coreutils_5.3.0.bb
index 42ac2c15af..2a9b09196f 100644
--- a/packages/coreutils/coreutils_5.3.0.bb
+++ b/packages/coreutils/coreutils_5.3.0.bb
@@ -1,6 +1,6 @@
require coreutils.inc
-PR = "r2"
+PR = "r3"
SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
file://install-cross.patch;patch=1;pnum=0 \
@@ -10,7 +10,7 @@ SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
file://futimens.patch;patch=1"
# [ gets a special treatment and is not included in this
-bindir_progs = "basename cksum comm csplit cut dir dircolors dirname du \
+bindir_progs = "basename cksum comm csplit cut df dir dircolors dirname du \
env expand expr factor fmt fold groups head hostid id install \
join link logname md5sum mkfifo nice nl nohup od paste pathchk \
pinky pr printenv printf ptx readlink seq sha1sum shred sort \
diff --git a/packages/coreutils/coreutils_6.0.bb b/packages/coreutils/coreutils_6.0.bb
index 59afd67bfb..57a6864617 100644
--- a/packages/coreutils/coreutils_6.0.bb
+++ b/packages/coreutils/coreutils_6.0.bb
@@ -1,5 +1,7 @@
require coreutils.inc
+PR = "r1"
+
DEFAULT_PREFERENCE = "-1"
SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
@@ -8,7 +10,7 @@ SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
file://onceonly.m4"
# [ gets a special treatment and is not included in this
-bindir_progs = "basename cksum comm csplit cut dir dircolors dirname du \
+bindir_progs = "basename cksum comm csplit cut df dir dircolors dirname du \
env expand expr factor fmt fold groups head hostid id install \
join link logname md5sum mkfifo nice nl nohup od paste pathchk \
pinky pr printenv printf ptx readlink seq sha1sum shred sort \
diff --git a/site/common-linux b/site/common-linux
index 1465b5fbc8..8d915d0018 100644
--- a/site/common-linux
+++ b/site/common-linux
@@ -6,3 +6,7 @@ samba_cv_HAVE_IFACE_AIX=${samba_cv_HAVE_IFACE_AIX=no}
samba_cv_HAVE_IFACE_IFCONF=${samba_cv_HAVE_IFACE_IFCONF=yes}
samba_cv_HAVE_IFACE_IFREQ=${samba_cv_HAVE_IFACE_IFREQ=yes}
samba_cv_HAVE_IRIX_SPECIFIC_CAPABILITIES=${samba_cv_HAVE_IRIX_SPECIFIC_CAPABILITIES=no}
+
+# coreutils
+fu_cv_sys_stat_statfs2_bsize=${fu_cv_sys_stat_statfs2_bsize=yes}
+