aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2007-02-21 17:59:52 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2007-02-21 17:59:52 +0000
commit3221b4f9308ad3a53b7785e07194fafda8bc24dd (patch)
tree913342a6a4d928183c0f65d9b92d787cc0e630ae
parenta7993804a3fadfda834e2fc23314648d0211eb8a (diff)
downloadopenembedded-3221b4f9308ad3a53b7785e07194fafda8bc24dd.tar.gz
soundserver: Work around libtool breakage.
-rw-r--r--packages/gpephone/soundserver/.mtn2git_empty0
-rw-r--r--packages/gpephone/soundserver/libtool.patch10
-rw-r--r--packages/gpephone/soundserver_1.0.bb11
3 files changed, 20 insertions, 1 deletions
diff --git a/packages/gpephone/soundserver/.mtn2git_empty b/packages/gpephone/soundserver/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gpephone/soundserver/.mtn2git_empty
diff --git a/packages/gpephone/soundserver/libtool.patch b/packages/gpephone/soundserver/libtool.patch
new file mode 100644
index 0000000000..6ae60d9288
--- /dev/null
+++ b/packages/gpephone/soundserver/libtool.patch
@@ -0,0 +1,10 @@
+--- soundserver-1.0/configure.ac.orig 2007-02-21 18:51:48.000000000 +0100
++++ soundserver-1.0/configure.ac 2007-02-21 18:52:03.000000000 +0100
+@@ -9,7 +9,6 @@
+
+ # Checks for programs.
+ AC_PROG_CC
+-AC_PROG_LIBTOOL
+
+ # Localization
+ AH_TEMPLATE([GETTEXT_PACKAGE], [Package name for gettext])
diff --git a/packages/gpephone/soundserver_1.0.bb b/packages/gpephone/soundserver_1.0.bb
index 5d47d9a370..17e3c6b6b1 100644
--- a/packages/gpephone/soundserver_1.0.bb
+++ b/packages/gpephone/soundserver_1.0.bb
@@ -2,16 +2,25 @@ LICENSE = "LiPS"
DESCRIPTION = "Cellphone alarm daemon"
SECTION = "gpe"
PRIORITY = "optional"
-PR = "r0"
+PR = "r1"
DEPENDS = "glib-2.0 libiac gstreamer"
GPE_TARBALL_SUFFIX = "bz2"
inherit gpephone autotools
+SRC_URI += " file://libtool.patch;patch=1"
+
EXTRA_OECONF="--disable-osc8k"
+LDFLAGS += " -L${STAGING_LIBDIR}"
+
do_configure () {
export PKG_CONFIG=${STAGING_BINDIR_NATIVE}/pkg-config
oe_runconf
}
+
+do_configure_prepend () {
+ export PKG_CONFIG=${STAGING_BINDIR_NATIVE}/pkg-config
+ autoreconf
+}