aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-06-19 13:52:33 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-19 13:52:33 +0000
commit316c1248d81df02fe60d562741f7547756b5c449 (patch)
treeaa57f88777ef4e25c338bf1abb4b14ff41467e58
parentf74a20456aadd77744203bcdb4a312795d052f50 (diff)
downloadopenembedded-316c1248d81df02fe60d562741f7547756b5c449.tar.gz
dcron: patched Makefile to not strip binaries - OE will do this
-rw-r--r--packages/dcron/dcron-2.3.3/strip.patch16
-rw-r--r--packages/dcron/dcron_2.3.3.bb4
2 files changed, 19 insertions, 1 deletions
diff --git a/packages/dcron/dcron-2.3.3/strip.patch b/packages/dcron/dcron-2.3.3/strip.patch
new file mode 100644
index 0000000000..51aef07f2d
--- /dev/null
+++ b/packages/dcron/dcron-2.3.3/strip.patch
@@ -0,0 +1,16 @@
+Index: dcron-2.3.3/Makefile
+===================================================================
+--- dcron-2.3.3.orig/Makefile 2006-06-19 15:47:35.774568368 +0200
++++ dcron-2.3.3/Makefile 2006-06-19 15:47:43.713361488 +0200
+@@ -14,11 +14,9 @@
+
+ crond: ${OBJS}
+ ${CC} ${CFLAGS} -o crond ${OBJS} ${LIB}
+- strip crond
+
+ crontab: ${D_OBJS}
+ ${CC} ${CFLAGS} -o crontab ${D_OBJS}
+- strip crontab
+
+ protos.h: ${SRCS} ${D_SRCS}
+ fgrep -h Prototype ${SRCS} ${D_SRCS} >protos.h
diff --git a/packages/dcron/dcron_2.3.3.bb b/packages/dcron/dcron_2.3.3.bb
index ed9f0ac9d4..d965bbecca 100644
--- a/packages/dcron/dcron_2.3.3.bb
+++ b/packages/dcron/dcron_2.3.3.bb
@@ -2,9 +2,11 @@ SECTION = "base"
DESCRIPTION = "Dillon's Cron is a multi-user cron written from scratch, \
similar to vixie-cron but with major differences."
LICENSE = "GPL"
+PR = "r1"
SRC_URI = "http://ibiblio.org/pub/Linux/system/daemons/cron/dcron-${PV}.tar.gz \
- file://compile.patch;patch=1"
+ file://compile.patch;patch=1 \
+ file://strip.patch;patch=1"
do_install () {
install -d ${D}${bindir} ${D}${sbindir} \